1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transmission has unstable but periodic speeds

Discussion in 'Tomato Firmware' started by callan.a.brown, Sep 3, 2014.

  1. callan.a.brown

    callan.a.brown Reformed Router Member

    Hi,

    Wondering if someone can take a look at my graph and let me know why my Transmission is unable to keep a constant stream. Currently I have it limited to 64KB up and 248KB down, and I left the default limits of 150 global peers, 30 per torrent and 10 upload slots per torrent. I currently have the Optware version running but I only bothered because I was getting the same the result with the built-in one.

    I'm on a WRN3500v2 using Shibby 1.28.0000 MIPSR2-121 K26 USB AIO. Other relevant info:

    CPU Load (1 / 5 / 15 mins) 1.64 / 1.61 / 1.66
    Total / Free Memory 123.77 MB / 96.58 MB (78.03%)
    Total / Free Swap 258.85 MB / 258.64 MB (99.92%)
    Total / Free NVRAM 32.00 KB / 8900 (27.16%)

    Thanks guys. transmission.png
     
  2. remlei

    remlei Networkin' Nut Member

    Use entware repository and install transmission. Its much faster than builtin transmission or optware equivalents. And it uses much less cpu cycles.
     
  3. callan.a.brown

    callan.a.brown Reformed Router Member

    Hi,
    I've installed Entware and transmission but I get the same problem. I am wondering if this log entry indicates some problem:

    Sep 2 23:34:54 unknown daemon.err transmission-daemon[5809]: UDP Failed to set receive buffer: requested 4194304, got 225280 (tr-udp.c:78)
    Sep 2 23:34:54 unknown daemon.info transmission-daemon[5809]: UDP Please add the line "net.core.rmem_max = 4194304" to /etc/sysctl.conf (tr-udp.c:83)
    Sep 2 23:34:54 unknown daemon.err transmission-daemon[5809]: UDP Failed to set send buffer: requested 1048576, got 225280 (tr-udp.c:89)
    Sep 2 23:34:54 unknown daemon.info transmission-daemon[5809]: UDP Please add the line "net.core.wmem_max = 1048576" to /etc/sysctl.conf (tr-udp.c:94)

    Can I add these lines safely? Or is there something else I have to fix?
     
  4. leandroong

    leandroong Addicted to LI Member

  5. callan.a.brown

    callan.a.brown Reformed Router Member

    I'm fairly confident the problem was simply my USB flash drive storage. Just for a test I thought I would try directing the download directory to my computer via CIFS1 I get a perfectly steady connection.

    What's the recommended storage option for the USB port on a WNR3500Lv2 then? Traditional HD formatted for EXT3 maybe?
     
  6. leandroong

    leandroong Addicted to LI Member

    I'm using EXT4 format on my usb 1.5TB seagate freeagent.
    In case you want to try @lancethepants binary, you just remove and replace transmission entware transmission. Also, change them to executables.
     

Share This Page