1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble Binding To Port 80

Discussion in 'Tomato Firmware' started by nhelder, Sep 10, 2008.

  1. nhelder

    nhelder Addicted to LI Member

    The short version: Apache, when listening on port 8080, processes both internal and external page requests just fine. However, when I switch Apache over to port 80 (and change the open port from 8080 to 80 on the router), internal requests succeed but external requests fail with a timeout.

    This exact same behavior is seen with Thibor15c firmware (which is what lead me to finally get around to trying Tomato, which I'm liking quite a bit). So, if the same problem existed across two independent router configurations, it must be an OS issue, right? ...maybe some other process is binding to port 80.

    Ok, so I pull up PortQueryUI and when the Apache sever (on port 80) is turned off, the UI shows that there is nothing listening on that port. Start up apache, and the UI shows that there is something listening. So, it appears it's not a port conflict (plus internal requests are making it to Apache just fine, so that's more support for it not being a port issue). Ok, well... maybe it's something to do with my Apache configuration.

    Trouble there is that I've tried a number of different Listen/ServerName/VirtualHost configurations, and with each configuration that worked on port 8080, once I replaced all 8080's with 80's, it's the same problem: internal requests process fine but external requests time out.

    So... there's my riddle... does anyone have any ideas what might be causing the problem or what I should check next?

    Outside of setting up port 80 to forward, is there anything in Tomato that needs to be done to enable that traffic?

    Thanks in advance for your help,

    - Nathan
  2. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    Have you tried externally accessing the tomato GUI on port 80 (after setting it up that way, course)? That would eliminate any possibility of the problem being on your web server setup or port forwarding. I only ask because many ISPs block port 80. If that's the case, there is no way (other than upgrading to a plan with your ISP that doesn't block ports) to get it working.
  3. TexasFlood

    TexasFlood Network Guru Member

    Is "Remote Access" disabled under Administration->Admin Access? If not then you'd have a conflict. Shouldn't be an issue as long as that's disabled, but maybe you could try changing the port listed there to something other than 80 to see if it makes any difference, shouldn't, but something to try.
  4. nhelder

    nhelder Addicted to LI Member

    Remote access had been disabled up until now, but I just got done enabling it for testing purposes, and the results do seem to indicate that my ISP is blocking port 80...

    Remote administration enabled over port 80 (using either http or https) works internally, but not externally.

    Over port 81, however, remote administration works fine.

    This is interesting to me, because up until now Charter had been very hands-off: nothing blocked, traffic not monitored for P2P traffic, no activity limits, etc.

    After doing some googling, I came across:

    ...so it appears that it is in Charter's policy to block various ports on occasion. However, this is the first time I've ever run across it in my particular location - which is why it didn't occur to me as something I needed to test.

    Thanks of the tips,

    - Nathan

Share This Page