1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trouble With Access Restrictions

Discussion in 'Tomato Firmware' started by GaretJax, Dec 27, 2013.

  1. GaretJax

    GaretJax Reformed Router Member

    Hello all,

    I have tried this with multiple firmware versions. The latest I have tried with is "tomato-E4200-NVRAM60K-1.28.0503.5MIPSR2Toastman-RT-N-VPN (1)".

    I have created a simple rule stating that all internet access should be blocked from 8pm - 7:30am everyday for a device with a particular MAC address (See screen print below).

    This device happens to be an iPod touch and I am expecting it to lose its wifi connection or at least not be able to surf the web or access IM or email. Once 8pm hits, I don't see any evidence of anything happening.

    I found an earlier thread stating that access restrictions don't work unless the time is set properly. I have confirmed that my router is able to hit the NTP server and has its time configured properly (See screen print below).

    I have confirmed that the rule is enabled (See screen print below).

    I have checked the log and don't see any entry indicating a rule is being evaluated or applied.

    Just for completeness, here are the things I have changed on my tomato router:
    1) I have created a Basic -> Wireless Filer for a number of MAC addresses. The one I am trying to block during the evening is among the ones configured for access.
    2) I have configured it to run a DHCP server.
    3) I have set the WAN/Internet type to "Disabled" and have manually configured the default gateway.
    4) I have changed the static DNS servers defaults to the ones from OpenDNS ( and
    5) I have enabled OpenDNS as my Dynamic DNS provider.
    6) I have changed the default IP address
    7) I have changed the default root password.

    I have not made any other changes. I want to get this time sensitive blocking working before moving on with anything more complex.

    Thanks a lot for your insight and Merry Christmas.

    Last edited: Dec 27, 2013
  2. gfunkdave

    gfunkdave LI Guru Member

    Two things:

    1. If you have set the WAN type to disabled, access restrictions (and much else) will not work. In access restrictions, Tomato assumes that it is routing your WAN connection. I am pretty certain this is half your problem.

    2. As to timing, you need to set two access restrictions. Tomato can't wrap around from PM to AM. So you need 8pm to 11:59pm and 12:00am to 7am.

    Note that when it's working, your devices won't lose the wireless connection. They just won't be able to connect to anything.
    Last edited: Dec 28, 2013
  3. GaretJax

    GaretJax Reformed Router Member


    Thanks for your response.

    1) I was starting to think along those lines last night. Starting down the path of trying to enable the WAN connection on the Tomato router.
    2) Good to know. Thanks.

Share This Page