1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unable to forward ports on Asus WL500gPv2

Discussion in 'Tomato Firmware' started by TheBus, Jan 5, 2010.

  1. TheBus

    TheBus Addicted to LI Member

    unable to forward ports on Asus WL500gPv2 using Tomato Teddy Bear mod Extra

    Not sure if this is the place to post this but hopefully someone here can help. I just installed Tomato Teddy Bear mod Extra on my Asus WL500gPv2 since I had been having problems with port forwarding using DD-WRT but the problem still persists.

    I have tried resetting the router with the 30-30-30 method and clearing the NVRAM in the tomato config without any effect.

    UPnP seems to work fine, programs like utorrent open ports properly but when I try to manually forward a port it doesn't work. I've tried testing the ports from sites like canyouseeme.org or through telnet and it shows them as closed. I'm unable to host games in Borderlands or play online at all in Medieval Total War because I am unable to forward the ports necessary to do so. I've tried on my desktop (running W7) and laptop (running XP) so I do not believe it is a software issue.

    Also I have tried running my desktop and laptop in DMZ mode which also doesn't seems to open the ports. It seems the only way ports work is if the program supports UPnP.

    Thanks in advance to anyone who has any idea what is going on.

    Edit: Also wanted to note I have tried disabling UPnP while manually forwarding the ports to see if that was causing a conflict without any success.
     
  2. LanceMoreland

    LanceMoreland Network Guru Member

  3. TheBus

    TheBus Addicted to LI Member

    Yes. I've even tried completely disabling Windows Firewall.
     
  4. karogyoker

    karogyoker Addicted to LI Member

    Are you sure about you filled the form correctly? And enable the rule by the tick.
    Did You forward to the proper LAN IP?

    Games need to forward the UDP, but better if you select Both just for sure.

    Other problem can be, if your ISP gives you a NATed IP, then you can not do anything about it.
    Try to connect your modem directly to your PC, and see what happens.

    edit: oh i see UPnP works, but it's not enough to see the forwarding rule in the table, check the port in uTorrent's port checker site, or elsewhere.
     
  5. TheBus

    TheBus Addicted to LI Member

    Yes. I'm certain I am filling out the form correctly and I have tried using the both setting and thinking that might be the problem setting up the ports under both TCP and UDP. Also I am certain I am using the correct LAN IP for my desktop and laptop.

    uTorrent's port checker site shows the port it uses when UPnP is enabled works and I get a green connection when downloading a torrent.
     
  6. TheBus

    TheBus Addicted to LI Member

    Just wanted to add that I tried disabling DHCP and setting up IPs manually and I am still unable to manually forward ports.
     
  7. TheBus

    TheBus Addicted to LI Member

    So it seems it's not a problem with the router after all. I tried connecting three different computers running Windows, Linux and Mac directly to the cable modem and making sure there was no firewall running it still shows the ports blocked when I test them. I have Comcast cable using a Motorola sb5101. I contacted Comcast and they said they aren't doing any kind of blocking from their end. Also this particular modem doesn't have any kind of firewall/port forwarding settings so I don't even know if it could be causing the problem. If anyone has any idea what could be causing this or could point me in the direction of a place that might be able to help I would greatly appreciate it.
     
  8. TexasFlood

    TexasFlood Network Guru Member

    I had a similar problem years ago. I don't even remember if I was using Tomato at the time. Never did figure it out, UPnP worked so I just called it good. Maybe it's an application configuration error unless you're using UPnP, dunno.
     
  9. LanceMoreland

    LanceMoreland Network Guru Member

    If you are forwarding to ports, the computer also has to be listening for them. For example if you are forwarding for Remote desktop to anything other than the default port which is 3389 you must make registry edits so that the computer that you are forwarding to is listening on the correct port. Try enabling for remote desktop on a machine and have your router forward to the default port. If it works change to a different port to forward to and make sure you set up a rule in windows firewall to the new port and make the proper edits in the registry to listen for the new remote desktop port. It should all work. This should put you on the right track for enabling ports for whatever else you are trying to forward to.

    Lance
    www.lancemoreland.com
     
  10. TheBus

    TheBus Addicted to LI Member

    Edit: Misread what you posted.
     
  11. TheBus

    TheBus Addicted to LI Member

    I got it working. It wasn't a problem with my modem or router.

    Like LanceMoreland had posted I wasn't paying attention to the fact that when I ran the port checker there wasn't anything actively listening on the ports on the Mac and Linux machines that I tried hooking directly to the modem. The only computer I did any real application testing like hosting a game was on the windows PC.

    The problem on the Windows PC was caused by a conflict with the VirtualBox Host-Only Network adapter.

    Thanks to anyone who posted their suggestions in this thread.
     
  12. LanceMoreland

    LanceMoreland Network Guru Member

  13. 66xx66xx66

    66xx66xx66 Networkin' Nut Member

    Hi, I have the problem as you but I use a Asus RT-N16. Tried everything that u did and utorrent its the only way I can get a port to open.

    LanceMoreland or TheBus can you give me more detail on how to fix this problem? I didn't get what you mean "default port which is 3389 you must make registry edits so that the computer that you are forwarding to is listening on the correct port." How do I registry ports in Windows XP? Not very good at networking.

    thx
     
  14. 66xx66xx66

    66xx66xx66 Networkin' Nut Member

    When I turn on DMZ 2 random ports opens (443 & 3389) none of them are in my port forwarding list.
     

Share This Page