1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Unable to save virtual wireless interface in Toastman 7496.2 on E3000

Discussion in 'Tomato Firmware' started by epikos, Mar 13, 2012.

  1. epikos

    epikos Networkin' Nut Member

    I flashed Toastman build 7496.2 and I'm using http://code.google.com/p/tomato-sdh...TEP_5_-_Configure_your_Guest_wireless_network to create a guest w-lan on its on Vlan to isolate from my primary lan traffic.

    I've made it to step 5. In Advanced > Virtual Wireless, I create virtual interface wl0.1, assign an SSID, Assign it to br1 and click add. This takes me to the wl0.1 tab. I assign WPA2 AES encryption, then click back to Overview with the button at the bottom of the page. I double check that wl0.1 is configured correctly, and go to click Save at the bottom. At this point, nothing happens.

    You can hover over Save, it highlights, but nothing happens when clicking it. No yellow bar that says services are being restarted, and no change in router activity based on the LEDS on the front.

    I have rebooted the router as well as tried clearing NVRAM and starting over. Nothing seems to get the virtual wireless interface to save.

    I read there could be problems with various types of encryption on the virtual wireless interfaces. Specifically it doesn't seem to play well when no encryption is selected. I've tried this with no encryption, WEP, WPA2 Personal AES, and WPA/WPA2 Personal AES.

    Anyone have any thoughts?

    I'm also not real clear on the proper place to enter bug reports against Toastman. I found this google code repo: http://code.google.com/p/tomato-sdhc-vlan/ but it seems like it might be for Teaman only.

    Thanks in advance!
     
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Do you mean that you flashed 0496.2, the VLAN-GUI build, or did I post the wrong stuff?

    The VLAN-GUI branch with Multi SSID is still somewhat experimental, it is "work in progress". Feedback on these new features to Teaman, the author, is very much appreciated, and the site you linked to is the appropriate place where he can gather all the incoming data.

    We've all been rather busy lately, but there are some fixes in the pipeline, I believe, we just have to wait to see what they are.
     
  3. epikos

    epikos Networkin' Nut Member

    I'm pretty sure the firmware was labeled 7496.2. It was E3000usb vlan-nocat. I'm at work right now and seem to have misconfigured my router remote access so I can't pull the exact details from About. I will confirm tonight when I get home.

    I totally understand work in progress. No worries about that. I'd like to provide feedback where I can, if it would be helpful.

    Thanks for your quick reply! Your firmware is fantastic!
     
  4. teaman

    teaman LI Guru Member

    Hi there!

    There's been some reports of issues when saving settings on the virtual wireless admin page... One of them seems to be triggered when the 'Wireless Network Mode' on any of your physical/primary wireless VIFs is not set to 'Auto' (which I'm still working on...).

    Can you please confirm if that's what happening on your router or... if it's another/new/different kind of issue?

    Also - feel free to open bug reports on http://code.google.com/p/tomato-sdhc-vlan/issues/list , provided it's about any of those new/experimental features I've been working on ;) such as:
    - IP Traffic/cstats
    - VLAN GUI
    - MultiLAN (part of VLAN GUI)
    - MultiSSID
    - SDHC/MMC mod (for WRT54GL)

    Thanks!

    EDIT: I think I just found what was wrong with saving WL VIFs - this particular issue seemed to happen when you had a 5 GHz radio set to 'n-only'. Will do more testing before pushing to git (so, probably it will make to other mods soon)
     
  5. epikos

    epikos Networkin' Nut Member

    Toastman,

    Hey so I'm home and I just checked the build I'm running.
    Tomato Firmware v1.28.7496 MIPSR2-Toastman-VLAN-RT K26 USB VPN-NOCAT
    tomato-E3000USB-NVRAM60K-1.28.7496.2MIPSR2-Toastman-VLAN-RT-VPN-NOCAT.bin


    Teaman,

    Both my radios are set to options other than Auto. My 2.4GHZ radio is G-Only and my 5GHZ radio is N-Only.
    If it makes a difference, I am only trying to create the VIF for the 2.4GHZ radio.


    Thank you both for the quick replies and fast testing!
     
  6. Toastman

    Toastman Super Moderator Staff Member Member

    epikos - Ok, thanks!
     
  7. jetstream

    jetstream Networkin' Nut Member

    Hey guys, I'm also super new to the forum and new to flashing my E3000. I was following some online tutorial to flash my router and I found varoius versions of tomato. What's the difference between VPN, NOCAT, VLAN?

    I believe I need to download this one, is that correct?
    "tomato-E3000USB-NVRAM60K-1.28.7496.2MIPSR2-Toastman-VLAN-RT-VPN"

    PS. dont mean to hijack the OP's thread, thought I would jump on since you guys seem to know what you are talking about.

    thanks
     
  8. epikos

    epikos Networkin' Nut Member

    On Toastman's download site, there's a file called "Versions" or something like that. It explains the differences.
    If you're not going VLANing, site to site VPN, or captive portal, and if you don't need USB functionality, you just need the base generic tomato-e3000-nvram60k-blahblah.bin. It won't have VPN-NOCAT or anything like that on the end of it. Also note that any "VLAN" build is considered experimental and in eternal "beta" status.
     
  9. epikos

    epikos Networkin' Nut Member

    Toastman,
    I read on another thread that the QOS Bandwidth monitor doesn't work on LAN bridges other than BR0.
    I'm not sure who owns QOS and who owns the bridging so if it's not you, point me in the right direction.
    Is there a bugtracker filed against it? Just wondering if anyone has considered fixing it.

    My thinking is that MultiSSID likely gets used for guest wireless pretty commonly. Well if you're making a guest wireless, you probably want it on a different vlan. And if you're doing that, you probably want to bandwidth limit it. So, at least to me, it makes sense to try and fix bandwidth limiting as a way to complete the vlan and multissid features.
     
  10. epikos

    epikos Networkin' Nut Member


    Jetstream,
    The versions.txt file I mentioned is linked here:
    http://www.4shared.com/office/GWhrv6Rt/Versions.html?

    If you're new to flashing the E3000 and you just want a completely awesome and extremely stable firmware, go with this:
    tomato-E3000-NVRAM60K-1.28.7496.2MIPSR2-Toastman-RT-Std
    The link is:
    http://www.4shared.com/file/mcPXAkwu/tomato-E3000-NVRAM60K-12874962.html?

    That's the base E3000 firmware with nothing fancy. It's EXTREMELY stable and a great firmware.
    Since you're new, I'd suggest that above firmware. Then once your'e comfortable and have enjoyed all the features available, you can move up to bigger and better builds.
    Some offer USB support for things like external HDD storage, Print Server, or 3g failover.
    Some have site-to-site VPN built-in, others have VLAN capability (always experimental and beta), and captive portal.

    There's even one that has ALL THE THINGS! USB support, VPN, VLANing, 3g failover, and captive portal. Plus a lot more.


    I hope you've found this helpful. Good luck!
    And protip for flashing new firmware: if something goes wrong and the router stops responding after the flash or you think you did something wrong, STOP. Google for the symptoms before unplugging the power. Unplugging the power at the wrong moment can leave you with a very sad E3000. At least checking for the symptoms online before doing so will tell you if it's safe to reboot the router (remove power) or if there are other things you can try before panicing.

    Again, ENJOY the E3000!
     
  11. Toastman

    Toastman Super Moderator Staff Member Member

    Yep. VLAN-GUI and Multi-SSID is work in progress, the points you raised are known about, and I expect that Teaman will get around to looking at them them in due course, when he has time.

    To ALL - epikos raises some good points in the above post. The 60K Linksys routers including the E3000 takea much longer time than normal to flash and digest the firmware. Many people reboot or unplug before it's finished, and this can be a disaster!
     
  12. epikos

    epikos Networkin' Nut Member

    Ok, cool. I just wasn't sure if QOS bandwidth limiting was part of those two things or who owned them.
    Thanks for the reply. I'm absolutely not trying to bug either of you about features and bugs. Just learning and asking questions.
     
  13. jetstream

    jetstream Networkin' Nut Member

    thanks guys, definitely helped the situation. I wouldn't be normally flashing my router, but the stock fimware is super annoying since I"m trying to get it to work with my synology diskstation and some surveillance cameras through the diskstation. thanks
     
  14. teaman

    teaman LI Guru Member

Share This Page