1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

unbricking

Discussion in 'DD-WRT Firmware' started by usgard, Sep 21, 2005.

  1. usgard

    usgard Network Guru Member

    Hi Guys,
    yesterday i have flashed my wrt54gs from V23 15.09.2005 to V23 20.09.2005.
    After flashing, i can't surf in the internet anymore and can't access the router (yes i have flashed with "set settings to factry defaults").

    Now i can ping the router for ~10 seconds. After that i get an error (timelimit). I've tried to tftp flash it, but i have no success cause it says "invalied password". So i've taken a tftp with password.
    But then the error: "wrong pattern" appears.

    I've a 54gs V2 and i've take the right firmware (dd-wrt V23 mini 20.09.2005 for GS)
    When i use the dd-wrt V23 mini 20.09.2005 for G the message don't appears. But cause i can ping my router only about 10 seconds the tftp process doesn't finish...
    so what can i do??


    Greets

    usgard
     
  2. templ

    templ Network Guru Member

    same problem here!! :(((
     
  3. BrainSlayer

    BrainSlayer Network Guru Member

    this is normal since the v23 like all other dd-wrt firmwares are internal handled as G firmwares. so the normal tftp does also work like a g unit. but the cfe unbricking tftp is still gs.
     
  4. usgard

    usgard Network Guru Member

    hi,
    wtf is cfe??

    thanks!

    greets
    usgard
     
  5. BrainSlayer

    BrainSlayer Network Guru Member

    cfe is the bootloader which is started before the firmware. with this bootloader you can unbrick a wrt also if the firmware itself is damaged or the flash has been failed
     
  6. MBChris

    MBChris Network Guru Member

    Hi,

    ive alot unbricking success with the following procedure:

    At first get WRT54GV3.0_3.03.6_US_code.exe from Linksys


    1. Do a hard reset (30 sec reset button + power cycle)

    2. Switch ur Laptops IP to 192.168.1.10

    3. Set the Network Card to 10 Mb Half Duplex <--- this is very important

    4. Start the Linksys Tool and flash the original Firmware

    5. Do a hard reset again

    Thats it

    Ive used this procedure many times and it fixes all bricked issues.
    Yesterday again, i recognized that if u have set ur Lancard to automatic or something else as 10 Mb Half Duplex the tool is running also and says successfull upgradet BUT this is wrong the router is still bricked ! As soon as u drop ur lancard to 10MB Half Duplex, flashing again, the router gets back to you !

    Chris
     
  7. templ

    templ Network Guru Member

    I have to make jtag cable.

    Than use Linux live CD to compile and use flasher to reflash cfe.
    CFE was ganerated on some homegapge with my mac address.
    than tftp small firmware:

    it works now
     

Share This Page