1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Unhalfbricking" WRT310N?

Discussion in 'Tomato Firmware' started by mvsgeek, Mar 3, 2013.

  1. mvsgeek

    mvsgeek Addicted to LI Member

    I've often wondered what Fairport Convention meant by the title of their 1969 album "Unhalfbricking"...
    After upgrading my Linksys WRT310N from Toastman 7633.3 to 7634 I encountered the empty "Advanced Wireless Settings" page reported in the Toastman releases thread. Flashed back to 7633.3 after a "thorough" erase of NVRAM (Admin --> Configuration --> Restore Default Configuration).

    The router now appears to be "Half-Bricked" :

    1. 30-30-30 reset gives a short window of about 2 or 3 pings with TTL=100 before timing out.
    2. During the short ping window, I successfully transferred the Linksys OEM firmware image via tftp - continuous ping is now successful, TTL=100, but power light flashes, and web GUI and telnet are unavailable.
    3. After power cycle, ping times out, power light is solid.

    4. Repeated the above steps with 7633.3 image, same result. Transfer successful, but no GUI.

    I'm pretty sure that the TTL=100 means it's stuck somewhere in the boot sequence.

    Is pin shorting / JTAG now my only option?
  2. lefty

    lefty Networkin' Nut Member

    Not your only option, you could probably recover via serial connection, which imho - is much easier than jtag.

    I have fixed many linksys units with the exact described details you are giving now, you can tftp an image, but the image doesn't ever take because the CFE isn't allowing it to because its stuck in a boot cycle, so even after you tftp the image, the CFE rejects it with another boot cycle. With serial, you can stop the CFE boot cycle and then use the shell to clear nvram and then initiate tftp.
  3. mvsgeek

    mvsgeek Addicted to LI Member

    @lefty, thanks for the explanation, it prompted me to google "linksys wrt310n flash serial port", which led me to this post on the dd-wrt forum :

    When I thought I had bricked my WRT310N, I finally found these steps that brought it back.

    Recovering WRT310N From Bad Flash or Corruption:

    a. Start two DOS prompt windows
    b. Enter “ping –t” in one DOS prompt window
    c. Enter “tftp -i PUT Linksys_WRT310N_OEM_Build.bin Linksys_WRT310N_OEM_Build.bin” in the other DOS prompt window
    d. Start the ping command in the first DOS prompt window
    e. While holding the reset button, power-cycle the router. The power light should flash continuously when in “management-mode”
    f. When ping is showing “ttl 100” the unit should accept tftp
    g. Transfer the original factory firmware to the router by starting the tftp command in the second DOS prompt window
    h. After successful tftp, the power light will stop flashing (1-3 minutes)
    i. Do a normal 30-30-30 reset and should be accessible

    I think steps (h) and (i) are the key - I did a 60-60-60 just for overkill, and it worked:) So now I'm back in business with stock Linksys firmware. I will however research the serial connection option, for future reference.
  4. lefty

    lefty Networkin' Nut Member

    excellent, glad you got it worked out, and taught me something new in the process. i'm always real fast to just use a serial connection to recover, but if that method works even better and save some time as well. thanks! :)
  5. Toastman

    Toastman Super Moderator Staff Member Member

    Glad you fixed it ok. 7634 has now been recompiled, please download it again if you need it.

Share This Page