"Upgrade are failed" and "code pattern wrong&

Discussion in 'EWRT Firmware Project' started by Rich-M, Aug 6, 2005.

  1. Rich-M

    Rich-M Network Guru Member

    I loaded the current Ewrt onto my WRT54GS so I could see how nocatsplash works and play with it some. After which I tried to reload what I normally run (DD-WRT)... well, I got the (topics) above error messages no matter what I tried to load reguardless of web interface or TFTP (variety of clients).

    What it turns out to be is that Ewrt's preface says its a WRT54G not an S, and from then on the web interface or TFTP wont allow you to reload a GS firmware...grrr.. So what I did was to edit the most recent linksys firmware file to a G (use a BINARY editor, and look at the first four characters of the file, then change it from "W54S" to "W54G" and load that), it worked fine for me, then I could load any other GS firmware (for some reason). Maybe the coders that brought us the message: "Upgrade are failed" can explain, or maybe, we wont be able to understand the explanation.... hahahaha

    -Rich
     
  2. BrainSlayer

    BrainSlayer Network Guru Member

    linksys firmwares does not only check the G/GS codepatter, but the version too. so you can't flash a older firmware over a newer linksys firmware. i fixed that today in dd-wrt.

    and additionally nocat has beed added to to the current sneak v23 version
     
  3. Xichekolas

    Xichekolas Guest

    So if I have a WRT54G v4 with the latest linksys firmware (4.20.6 I believe), that would explain why I can't get the latest v23-alpha to work? I just consistently get "Upgrade are failed" messages... know of a way to trick the darn thing into accepting v23?

    I know that lots of people are having problems with it right now, and someone here suggested using TFTP as the only way... but I have to admit I am super leary of TFTP because every time I use it I end up having to open the thing up and shorting pins...

    Thanks
     
  4. BrainSlayer

    BrainSlayer Network Guru Member

    the latest alpha (15.8.) works on it and doesnt show this message. i tried it out. just take the right binary for your router WRT54G/GS and use it.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice