1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Upgrading Firmware on WAG54G...Help!!

Discussion in 'Other Linksys Equipment' started by jjm1971, Nov 9, 2005.

  1. jjm1971

    jjm1971 Network Guru Member

    Hi hope someone can help here.

    I've been trying to upgrade to v1.01.22 but it doesn't seem to complete the upgrade.

    I upgraded as per the instructions for the router, it then rebooted but when it booted back up, it (i presume) hung. the power light was flashing constantly and I had to power off and back on.

    I have tried to upgrade in the past, I thought I had but the firmware version on the router status never changed. I can only assume that it didn't upgrade correctly.

    Can someone explain to me how to upgrade correctly

  2. limesoft

    limesoft Network Guru Member

    hi, what i suspect that you did actually upgrade the firmware correctly, the problem is actually when you finished upgrade the firmware DO NOT Power off the router when you see the power LED is flashing ( it means the router trying to erase the old firmware from the flash and rewrite the new one) - It normaly takes about 1-2 minuites, if you are the one who is unpation people go and turn it off when the LED is still blinking, then :shock: :eek: your router need to send back for warrenty.

    You can also try, PC/laptop (LAN cable) -> WAG54G , set your Local area connection as a fix ip ( manully assign ip to 192.168.1.xxx) then try to ping, if it got reply, use tftp to upload the firmware again and this times please wait the router finished doing his job!!

    Good Luck!!
  3. jjm1971

    jjm1971 Network Guru Member

    I understand what you're saying about the flashing light and not powering off. However, the power light was flashing for more than 1-2 minutes, I left it for about 5-6 minutes.

    I don't need to send the router back for warranty, I'm using it now.

    As I said, I've tried upgrading in the past and it doesn't seem to upgrade correctly. When I log on to the router, the firmware version hasn't updated.

    I have a Netgear DG834G at work and it's easy to upgrade, why is Linksys so difficult.

    Anyone else any useful advice?

  4. thedrill

    thedrill Network Guru Member

    What version router are you trying to flash..is it version two?
    If not its the wrong firmware your trying to use..if its version two, try re-setting the router first before the flash with the reset button the rear of the unit...it worked for me.
  5. jjm1971

    jjm1971 Network Guru Member

    Yes it's version 2. I tried that last night, but will try again.
  6. limesoft

    limesoft Network Guru Member


    Try to restore it to factory default the router, and try using WIRED to upgrade the firmware.

Share This Page