1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

upgrading to sveasoft firm ware: incorrect image file error

Discussion in 'Cisco/Linksys Wireless Routers' started by thijsj, Jan 7, 2005.

  1. thijsj

    thijsj Guest

    I downleaded the sveasoft satori v4.0 firmware and tried to upgrade the firmware. However, I get the following error message : Incorrect image file. Can someone help
     
  2. alienigena

    alienigena Network Guru Member

    Re: upgrading to sveasoft firm ware: incorrect image file er

    Same thing here! :( WRT45G v1.0 and no mather wich firmware i try, even the linksys one?!
     
  3. Toxic

    Toxic Administrator Staff Member

    what version of WRT54G do you have?
     
  4. alienigena

    alienigena Network Guru Member

    SN is CDF003271xxx. so it's got to be a WRT45G v1.0 right?

    thxia

    alienigena
     
  5. alienigena

    alienigena Network Guru Member

    me stuped, WRT54G v1.0 i ment
     
  6. alienigena

    alienigena Network Guru Member

    has anyone any ideas? i've been waiting all day long, please give me a hand. toxic?

    thxia
     
  7. linksysonline

    linksysonline Network Guru Member

    When you have downloaded you unzip'd it right and used the .bin file?
     
  8. alienigena

    alienigena Network Guru Member

    yes. i've tried the HyperWRT_2.1b1_G.bin, the Firmware_Satori-4_0G.bin ad some of the original Linksys files. Always got the same result : Java popup that says: incorrect image file. (I'm running a v1.01.4) thx alienigena
     
  9. Toxic

    Toxic Administrator Staff Member

    that is a very old firmare.

    i suggest you try updating with the windows updater first.

    ftp://ftp.linksys.com/pub/network/WRT54GV3.0_3.03.6_US_code.exe

    run this file first. i think the old firmware you hve is not accepting new firmware via the webpage utility.

    once you have updated, ig the WRT54G about 30 seconds to sort itself out, then press reset button for 30 seconds.
     
  10. joshag

    joshag Network Guru Member

    Important that you wait for the flash to finish. The router will generally do a "soft boot" after. You can tell it's finished by looking at the power led. Wait till it stops flashing.

    Worse case senerio you have to tftp your router. You must use a small (under 3MB) bin file.

    Good luck.
     
  11. alienigena

    alienigena Network Guru Member

    solved!

    thanx a lot for your support! using the WRT54GV3.0_3.03.6_US_code.exe solved the problem. I just did not think of using the .exe 'cause i'm running on gentoo... using linux narrows your view somehow...damed :D

    now the router is running on Firmware Version:v3.03.6 and i'll give the Satori-4_0G another go. I'll drop a Line if i've succeeded.... hopefully!

    alinigena
     
  12. alienigena

    alienigena Network Guru Member

    192.168.1.1 -> Administration -> Upgrade and there you go. Finally it was a piece of cake!!
    my router is now running the satori firmware and works flawless, at least till now.

    I still do not understand why i had to use the .exe instead of using the internal update tool... hey, it finally works so.... who cares....

    again thxal to anyone

    alienigena
     

Share This Page