1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

USB External Enclosures

Discussion in 'Cisco/Linksys Network Storage Devices' started by nstig8r, Nov 18, 2004.

  1. nstig8r

    nstig8r Network Guru Member

    I have a WD USB drive currently attached to my NSLU2 and it has been working okay. I want to add second drive but am considering going with an internal IDE drive installed in a USB External Enclosure. Are there any known issues with using these enclosures with the NSLU2? Thanks.

    Andy
     
  2. Aziona

    Aziona Network Guru Member

    I'm using a WD250GB harddisk in a Sweex USB2-case (EUR 35) and it's working great. The only thing is that you might want to look for a case that also keeps your harddisk cool as it will significantly increase the life of your harddisk. The Sweex stays around 40 degrees celsius and that's warmer then I wished for. I also understand that the cooler that is build in some USB2-cases, is not necessarily for the harddisk but for the build-in power-supply or electronics and does not increase airflow around the harddisk.
     
  3. nstig8r

    nstig8r Network Guru Member

    Thanks for the info.

    Andy
     
  4. DeeJ07

    DeeJ07 Network Guru Member

    My own experiences...

    I purchased the NSLU2 two days ago. I was planning on using a spare Seagate 4.3GB (yes, that old) in a metal gear external case. No luck. Here's what I noticed. For some reason I was not able to format the drive using the NSLU2 Format utility. I did find out that if I formatted it in FAT32 and connected it to the Disk 2 port it would work in the same way as a connected flash drive (it is even shared as 'FLASH'). So I contacted Linksys Customer Support and was quickly passed through to the Level 2 tech (Level 1's don't like feeling confused). The Level 2 ended up going over the whole situation with a coworker... no luck. This was all on the latest (r25) firmware. Oh well, back to the store and picked up a WD 160GB USB 2.0 drive, and now I have had very few problems (those that I have had seem to be my own fault). Here's my advice, make sure you're using an actual USB 2.0 drive (1.1 is too slow, and external enclosures have a very poor track record). By the way, Tom's Networking has a great How To and getting root access to the NSLU2 via Telnet, but also check 'http://www.batbox.org/nslu2-linux.html'. If you follow the tutorial but instead of physcially connecting the HD to another box just download the configuration files (must have HD attached) you can access them by changing the .bin to .tar and opening. I read this little trick somewhere and can't seem to find where it was, so sorry for not giving credit where credit is due. I'm loving the trip the NSLU2 is taking me on, but if you want to take it just be ready to make several trips to and from the store. :wink: Have fun!

    PS- when are we going to start seeing some forums on the firmware possiblities with the NSLU2. Last I heard there were over 450 developers on the IRC Channel...
     
  5. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    http://www.nslu2-linux.org/wiki/Main/HomePage is the most popular that I have come across so far. Sveasoft is looking into the possibility as well. I am running Unslung standard 2.12. If you are impressed with the adventure thus far, you need to "take the red pill Neo" and learn what the slug really is or can be. I have been experimenting a little with my unit and am impressed as well. The down side is, it is a Linux"geek" project (no insult intended) so you will need to fine tune your skills.

    http://www.polkadotninja.com/
    http://www.bytered.com/
     
  6. jor

    jor Network Guru Member

    there's really not much of a difference between the two. An external drive still uses the same internal drive, just in an enclosure that doesn't
    easily open.

    That said, I did find that for my $23 usb2 enclosure, I needed to install the drive in the PC, format it, then move it back to the NSLU2 and let it recognize it. It didn't seem to before, though this may be due to startup sequence. ??
     
  7. DeeJ07

    DeeJ07 Network Guru Member

    I'm curious, were you able to format the external/internal drive via the NSLU2 format utility? I found that if I attatched the drive to the Disk 2 USB Port and had it preformatted with FAT32 (not NTFS) it was able to recognize it but it behaved the same as a FLASH drive.
     
  8. jor

    jor Network Guru Member

    I formatted using NTFS - faster. And then used the web based utility.

    I'm not sure if it was necessary, or if I was running into trouble just getting the slug to see the drive (on usb 1). It seems to prefer being powered up, then seeing the drive spin up. But then I need to reboot so it will be properly unslung. I guess I need to spend more time figuring that out, but for now I'm content to let it serve up images and mp3s.
     
  9. RedLion

    RedLion Guest

    WD 9G Drive, Kingwin USB2.0 Enclosure

    I have a old WD 9G drive in a Kingwin USB2.0 enclosure, but the NSLU2 won't recognize it. Admin-Status says no drives are plugged in and I get a warning, Wrong USB flash attach on USB1 of USBserver ! I've formatted the drive as FAT, FAT32, NTFS, ext2, ext3, and even tried leaving it unformatted. None of those worked.

    Another peculiarity is that while I can access my Lexar 256M Jumpdrive when formatted as FAT, the NSLU2 doesn't recognize it nor allow me to format it. I tried formatting it as ext3, but it's then unaddressable.

    My ultimate goal is to uNSLUng it so I can attach a 7 port USB hub such that I can use a number of my old drives, but I need for it to allow me to download the backup. Alas...

    I suppose my next move is to try each of my spare drives -- from a WD 500M to a Maxtor 300G SATA -- to find out if *any* of them will make a difference.
     

Share This Page