1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Using WRT54G v3.0 for Tomato

Discussion in 'Tomato Firmware' started by glen4cindy, Aug 27, 2009.

  1. glen4cindy

    glen4cindy Addicted to LI Member

    Tried looking in the FAQ for this but didn't find anything. I have Tomato running on a 54G v 2 so I am experienced in loading the firmware but am having problems with this other router.

    I just obatined this router, did the 30 second reset button, power off, power on, reset factory defaults routine, then tried to install the most recent Tomoto using the Linksys GUI.

    Well, the little bar went all the way across once, then partway the next time, then said Upgrade are failed.

    I then set a static IP on the PC, reset the router, used Linksys TFTP utility to load the latest Linksys firmware for the router, had to do this 2x, but, now I have the Linksys GUI back.

    Should I try again using the GUI, or can I use the TFTP utility to flash the Tomato? I don't want to brick my router to the point where I will need a JTAG cable. I've never JTAGged anything!

    I am hesitant to try again. One note, the firmware that was on the router was 3.x and this is a 4.x but, I don't know if that would make a difference.


    Well, things are not going as well as I thought.

    Also, is there a guide to what the light behind the Cisco Systems label is? Sometimes it is flashing white, sometimes solid amber.

    Everything seemed to be working before I tried the Tomato upgrade.

  2. ringer004

    ringer004 LI Guru Member

    I had the same problem.

    I had the exact problem you described. I tried to upgrade to an alternative firmware from v3 of the Linksys firmware. The upgrade said 'failed' at the end. After a power cycle, the router just had a blinking power light, so I thought I bricked it.

    I had an old Linksys 4.20.7 around in the .EXE format. I think this executable does a tftp, but I'm not sure. I successfully reloaded 4.20.7 using this method. And once I had v4 Linksys firmware loaded, the upgrade to other firmwares was flawless.

    So I would try again if I were you. I think you said you tftp'd the latest Linksys, which would be 4.21.1. And to be safe, I would re-set factory defaults before and after the upgrade.

    Good luck.
  3. glen4cindy

    glen4cindy Addicted to LI Member

    Thanks for the tip.

    I actually got the nerve to try again, and had the same problem. The only difference this time, was I had to run the Linksys TFTP utility like 5 or 6 times to get the router to take the upload and work again.

    Then, I flashed with DD-WRT to see what I thought of it. There was this mini-1st time flash version, then I flashed with the Standard version. After playing with this for a hour or two, I knew that I liked Tomato better, so I flashed to Tomato and it worked.

    The router is now proudly running Tomato in it's new home.


Share This Page