1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

v1.25 - Cannot enable wireless (WL-500W)

Discussion in 'Tomato Firmware' started by tzoom84, Nov 20, 2009.

  1. tzoom84

    tzoom84 Addicted to LI Member

    I am trying to switch to Tomato 1.25 (ideally TB's USB mod) from DD-WRT.

    Starting fresh from the ASUS firmware, I flashed to dd-wrt.v24-11650_NEWD_mini_asus and then to tomato 1.25 ND on my WL-500W router.

    Wireless worked fine with Asus Firmware, along with DD-WRT firmware. But when I upgrade to Tomato 1.25 ND, the wireless is fixed at disabled.

    It shows disabled on the status screen of web gui, even if I press 'enable' there. However, the checkbox under Basic settings of web gui for wireless enabled is checked. I tried to uncheck, save, and re-check. No luck. I also tried soft-reboots, hard-reboots, and 30-30-30's.
    Also note, no security settings were being used (security disabled).

    Any idea why Tomato can't kick on the wireless, but Asus and DD-WRT can?

    Thanks.
     
  2. roadkill

    roadkill Super Moderator Staff Member Member

    just a guess - you don't have a compatible wireless card.
    WL-500W have an N type card I don't think Tomato support them at all, try to post the log so we can see what's going on
     
  3. teddy_bear

    teddy_bear Network Guru Member

    Flash from DD-WRT directly to my USB mod if you're going to use it anyway (in the last build I fixed incompatibility with 4704 chipset). Wireless driver in it works with WL-500W, while the driver in vanilla Tomato may not. There's no support for N-mode, but G works.
     
  4. roadkill

    roadkill Super Moderator Staff Member Member

    where did you got the driver from?
     
  5. tzoom84

    tzoom84 Addicted to LI Member

    Flashed to build 39 this morning and it worked great! Wireless is now enabled and I can connect, ping, and access tomato's web gui wirelessly. I didn't realize the vanilla tomato have wireless working for the WL-500W. Good to know!

    Thanks again.
     
  6. teddy_bear

    teddy_bear Network Guru Member

    The particular one I'm using in my mod now - 4.150.10.29 - came from recent Asus GPL releases for WL-500gPv2 and WL-520GU. This version seems to be the most stable and have better compatibility compare to others.

    I also tried a few other versions - one from OpenWRT (4.150.10.5), another one don't remember from where (4.150.10.16), and one from Linksys WRT600N (4.158.4.0).
     

Share This Page