v1.28.7633 -Toastman-VLAN-IPT-ND ND Std and VLAN

Discussion in 'Tomato Firmware' started by PGalati, Mar 1, 2012.

  1. PGalati

    PGalati Network Guru Member

    I just installed this amazing firmware on a WRT54G v.4. These routers just keep getting better and better. It is amazing how much life these little routers still have left in them. Anyway....

    I am trying to configure the router to have 4 VLANS and 4 Wireless SSIDs. I am not sure what I am looking at in the VLAN section is correct. After flashing the router I did the 30-30-30 reset and configured. I was able to initially give each LAN port it's own VLAN but at some point I went back to this screen later and noticed that VLAN0 has all 4 LAN ports assigned to it even though ports 2-4 have individual ports assigned to it, as well as the WAN port. Now when I try to make a change, I get an error indicating that I cannot assign a LAN port to more than one VLAN, but somehow it is configured that way.

    I have not tested yet, but should I expect that any LAN port can see any other LAN port? I guess that is not a problem but I would like make sure each SSID can only see others members of that SSID.

    I understand this firmware addition is considered experimental and will no doubt be revised, but is the behavior I am seeing correct?

    Thanks for your time.
     

    Attached Files:

  2. teaman

    teaman LI Guru Member

  3. PGalati

    PGalati Network Guru Member

    Teaman, thanks for the tutorial. That is a great help troubleshooting my issue. I am trying to configure a flashed WRT54G v.2 and everything I try I cannot seem to get the VIF screen to allow me to add an interface, as if it is grayed out. Image attached.

    I am going to try flashing another WRT54G v.4 and see if it allows me to configure an additional VIF. Maybe I will try reflashing the v.2 if the v.4 is good.
     

    Attached Files:

    • VIF.png
      VIF.png
      File size:
      25.7 KB
      Views:
      34
  4. teaman

    teaman LI Guru Member

    I guess you forgot to see the 'See also' section on that link :/

    http://code.google.com/p/tomato-sdhc-vlan/wiki/ExperimentalMultiSSID#STEP_0

    Long story short: the WRT54G v2 is simply not capable - I had one flashed/tried myself and yeah: confirmed it doesn't work with that particular model.

    Here's what you should get on a WRT54GL:
    Best of luck!
     
  5. Daijoubu

    Daijoubu Serious Server Member

    Sorry for hijacking this thread, just wanna point out that the non-VLAN version tomato-NDUSB-1.28.7633.2-Toastman-IPT-ND-Lite doesn't show LAN information under Status, Overview, tried to click on Show/hide but no go.

    And the VLAN version is spelt VALN, must have been just a typo lol
     
  6. Toastman

    Toastman Super Moderator Staff Member Member

    Daijoubou, yes, you're quite right. I'll take a look later, and repost it when fixed.

    Thanks!

    EDIT

    The LAN shows up correctly on all builds here. Nothing to fix ..

    The VALN I can do :)
     
  7. Daijoubu

    Daijoubu Serious Server Member

    Thanks for the prompt reply!

    While waiting I tried flashing 7 previous versions, had to go back to 1.28.7628.1 to see the LAN info under Status, Overview
    Starting 7629 when VLAN was added, the non-VLAN version doesn't show the LAN info anymore. Shows up fine in the VLAN version though

    I tested the following versions:
    tomato-NDUSB-1.28.7629.2-Toastman-IPT-ND-BETA-Lite
    tomato-NDUSB-1.28.7630-Toastman-IPT-ND-Lite
    tomato-NDUSB-1.28.7631-Toastman-IPT-ND-Lite
    tomato-NDUSB-1.28.7632.3-Toastman-IPT-ND-Lite
    tomato-NDUSB-1.28.7633-Toastman-IPT-ND-Lite
    tomato-NDUSB-1.28.7633.1-Toastman-IPT-ND-Lite
     

    Attached Files:

    • lan.png
      lan.png
      File size:
      12.2 KB
      Views:
      22
  8. Toastman

    Toastman Super Moderator Staff Member Member

    Yep. Got it now.

    7633.2 on my AP's which were updated are showing the LAN ok and the toggle works. Linux, Chrome & Firefox.

    I just went through my other AP's which are still on 7633 and several of them don't show it. Show/Hide does expand the display area slightly, there's just nothing to show. So now I have something to look at :p
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice