1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

V23 - IP logging issues - AGAIN

Discussion in 'DD-WRT Firmware' started by dellsweig, Nov 23, 2005.

  1. dellsweig

    dellsweig Network Guru Member


    WRT54G V3.1 DD-WRT V23 Standard build 11/21

    Was running 11/16 build. Configured as AP, some access lists, WEP 128, logging enabled and working, syslog enabled and working

    Upgraded to 11/21

    IP logging stoped. Syslog and kernel level logging continued but no IP traffic is logged (either in GUI or syslog)

    Clear nvram, Hard reset and re-configure - logging is OK again

    I save configuration to file and hard -reset router again

    Reload from save configuration, IP logging does not work.
    Hard-reset and hand re-configure - IP logging works fine

    I have gone through the ticket system with past V23 releases with this problem and have had tickets closed out - admin cant reproduce.

    Is anyone else out there having any issues like this with IP logging??

    Assuming it is a problem with my configuration - anyone have any ideas??

    Lots of folks are reading this thread - I wonder why no one sees the problem

    Edit: Same behavior with 11/23 build. Also, IP logging stops working after power cycle of router. The ONLY way I can get IP logging back is to hard reset and re-configure
  2. 4Access

    4Access Network Guru Member

    Hey dellsweig,

    I've noticed you've reported this many times but no one has confirmed the problem or really even responded... are you still having the same problem with the latest build? I don't run the v23 beta on my logging routers which is the main reason I haven't tested this in the past when you've reported it but I'd be willing to try and duplicate it this weekend if you're still having problems. I don't think I have a WRT54G v3.1 available right now for testing but I do have several other WRT's sitting around... have you tested this on any other hardware versions?
  3. dellsweig

    dellsweig Network Guru Member


    I swapped in my V2.1 WRT54G in place of the 3.1 and can still duplicate.

    Here is one that works/fails every time

    1) clean flash - hard reset.
    2) configure all settings - logging OK
    3) save config
    4) restore config - logging no longer works

    Only way to get logging back again is hard reset and hand reconfigure

    Occasionally, a power cycle is all it takes to get into this state
  4. 4Access

    4Access Network Guru Member

    What logging options do you use?
  5. dellsweig

    dellsweig Network Guru Member

    Dropped == on
    rejected == on
    accepted == on

    I also have a syslog host configured.

    When the 'issue' occurs, 'iptables --list' returns an empty list. Also, the syslogd continues to process and send kernel log messages to the syslog host - for example, if I reboot the router, my syslog viewer will see all of the kernel init stuff.

    Also, I can telnet into the router - issue "logger test" from the shell and see the test message on my syslog host

    No IP logging occurs
  6. dellsweig

    dellsweig Network Guru Member

    4access - any luck reporducing this??

    I ugraded from 11/24 V23 Std to 12/2 last night.

    Before upgrade - logging was configured and working (with 11/24)

    I did an upgrade flash. All features worked fine EXCEPT IP logging.

    I then did a hard reset and re-configured the router by hand and logging again works. I assume the problem is still there.

    Later today I will do a backup and restore of the config and see if IP logging survives.
  7. dellsweig

    dellsweig Network Guru Member


    It looks like my reported issue has been narrowed down.


    0000048 and 0000355 on bugtrak

    Certain L7 access restrictions cause IP logging to fail

Share This Page