1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

very slow internet with Linksys WRT54GL only in wireless mode (wired is OK)

Discussion in 'Tomato Firmware' started by Mike_Tyson, Jun 9, 2012.

  1. Mike_Tyson

    Mike_Tyson Serious Server Member

    I bought a new Cisco Linksys WRT54GL router to connect my laptop (running Windows 7) to the internet. I installed Tomato 1.28 firmware on the router.

    When I connect the laptop to the router via ethernet cable, everything is fine and I get extremely fast up- and download speeds. When I connect wirelesssly however, websites load extremely slow - it takes dozens of seconds to load a website! <-- This is my question, how can I fix the wireless speed issue?

    Gmail for example is unusable this way. I tried speedtest.net, but this always fails in the upload part of the test so I can't even test the bandwidth (could the fact that it fails in the upload part, not the download part, be an indication what the problem is?!).

    I have isolated the problem a bit, I am convinced it has to do either with the router itself, the router settings, or the settings of the wireless connection in Win 7. Because previously, I was using another router by Buffalo and I had no problems whatsoever. I have tried to reproduce the settings from the Bufallo router as closely as possible on the Linksys router (same channel, same encryption etc). The download speed problem only occurs with the Linksys router, and only in wireless mode! When I exchange the Linksys router with the Buffalo router I have here for testing, the wireless speed is up to normal again.

    Also, before I had installed the Tomato firmware I had exactly the same problem, so it has nothing to do with the firmware itself.

    Notes & things I already tried:
    • Changing the channel: does not seem to affect anything, I am also on the same channel (10) which I was previously on when I had a Buffalo router.
    • QoS is off.
    • Ping to the router itself is OK, ~ 1 ms.
    • Some current settings of the linksys router:
    • WAN / Internet Type: DHCP Wirelesss Mode: Access Point B/G Mode: Mixed Broadcast: check Channel: 10 - 2.457 GHz Security: WPA2 Personal Encryption: AES
  2. adlerfra

    adlerfra LI Guru Member

    Try Victek's firmware, version - Tomato RAF 1.28.8515 ND. You can get it here. http://victek.is-a-geek.com/tomatoen.html
    I have found this to be the best performing firmware for my WRT54GL especially the wireless G performance. I use Channel 6 which gives me the strongest signal.
  3. Toastman

    Toastman Super Moderator Staff Member Member

    Yes, I agree. 8515ND is a kind of reference build, it was sweet. There's absolutely no question there's anything wrong with it, so if you still have a problem using it, then suspect something else!

Share This Page