1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Victek RAF Releases 1.28.8550 for RT-N16

Discussion in 'Tomato Firmware' started by Dashiell, Aug 29, 2010.

  1. Dashiell

    Dashiell Network Guru Member

    Victek has released a new version for the RT-N16 (MIPSR2)!

    http://victek.is-a-geek.com/tomato.html

    Info:

    REMEMBER to execute a nvram erase through after upgrading to this version and configure manually again to avoid unstable behaviour. Do not restore your configuration file, some values and new values are removed/added in the nvram.
    IP/MAC limiter extended up to 140 user / Limitador IP/MAC hasta 140 usuarios
    140 PC's allowed in Access Restriction / Hasta 140 máquinas permitidas en Access Restriction.
    IP_Conntrack up to 8192 IP's / Hasta 8192 conexiones posibles.
    PFIFO packets GUI(Advanced/Qos) / PFIFO. Ayuda a reducir el lag en tratamiento de paquetes para P2P, (Advanced/QoS)
    Valores conntrack ajustados por defecto para P2P / Conntrack default values adjusted for high P2P load
    Theme for visual handicaped / Tema para deficientes visuales.
    Eight additional themes / Skins mejorados, Red USB, Bluedream, Enlightenedd, Tijuana, Asus, Linksys, Buffalo.
    Spain TZ per default / Zona horaria de España por defecto.
    CPU Frequency & Oveclocking (125-300MHz).
    Previous WAN IP / IP WAN previa
    DSLAM ISP identification / Identificación del DSLAM del ISP
    Sistema de ofuscación para P2P mejorado. (dejar pasar 24 horas antes de postear..)
    Code Optimization / Optimización de código
    All the features of Official Tomato 1.25 and Teddy Bear 1.27/ Todas las funciones del Tomato oficial 1.28 & TB 1.27
    And all the standard features of the Tomato RAF version / Más las funciones estándar del Tomato RAF.
    Wireless & Ethernet driver v.4.158.4.0 with Intel 2200 b/g cards fix. Only ND Version. / Driver WL4.158.4.0 en versión ND solo
    Busybox 1.16.2
    DNSmasq 2.49

    Thanks to Jon Zarate & Teddy_Bear for his contribution to this superb firmware.


    Welcome back, Victek!
     
  2. Azuse

    Azuse LI Guru Member

    If this means mac limiting is working on the N16 his server will probably die, again :)
     
  3. wasp87

    wasp87 Network Guru Member

    Working alright, but download tests show below average results.


    Why the default 40mhz channel width? Apparently 40mhz causes issues for a lot of people.
     
  4. myersw

    myersw Network Guru Member

    I always run with 40Mhz channel width and have not had any issues. I do make sure that the client as well as the router is set for 40mhz. Currently running DD-WRT BrainSlayer build 14929 big. Now that Vectek has a build that supports my RT-N16 I will give Tomato a try again. Had issues with the TB builds which caused me to give DD-WRT a try. Have not had a reason to switch back until now.
    --bill
     
  5. wasp87

    wasp87 Network Guru Member

    EDIT: nvm
     
  6. myersw

    myersw Network Guru Member

    I kept hearing folks crying for a Vectek build. Now that there is one I do not see lots of reports from folks as to it working, etc other then the 3500L folks that is. Anyone besides Dashiell installed and had good luck? I see one in this tread that is questioning through put.
    I would like to install Vectek's build on my N16 but it is running good with DD-WRT and if the wife cannot get her email in a timely manner I will have family issues. Remember, Happy wife, Happy life!
    --bill
     
  7. FattysGoneWild

    FattysGoneWild LI Guru Member

    Most likely because it was a silent release and unexpected. So not many people probably know about it yet. Give it a few more days. As for the wife issue. Its a 2 way street not 1 way. You should inform her of that. :biggrin:
     
  8. GhaladReam

    GhaladReam Network Guru Member

    Also, since this is Vic's first release for a MIPSR2-based router, all of his followers up until this point are/were MIPSR1 users, so it makes quite a bit of sense that there hasn't been a huge amount of hooplah over this release (yet). Since I don't own an RT-N16, i'm still waiting for his MIPSR1 release for my WRT54G-TM.
     
  9. Dashiell

    Dashiell Network Guru Member

    I also have a couple of TMs that are running 1.25.8515.2. It would have to be a sweet-featured release to top that one.
     
  10. myersw

    myersw Network Guru Member

    Well I decided to install Vectek on my N16. Install went just as you would hope. I did have DD-WRT 14929 big installed which has run flawlessly. First thing I did notice was the speed of the WEB interface. Had forgotten how much slower DD-WRT WEB interface is.
    Have my basic configuration right now which is just PPoE and wireless. Will see how that works and if fine then start adding things like USB support.
    One thing of note so far is my download and upload speed seems to be a little slower. My download speed is around 2.34Mbps and .38Mbsp upload. These speeds were consistent over multiple tries to more then one site. With DD-WRT these would be around 2.54Mbps down and .410Mbps up.
    My wireless connection is N getting 300Mbps on both wireless PCs.
    Have seen one error so far. When I go to Status/Web Usage I get a pop up message;
    Which says:
    Message from Webpage
    Type Error: "this,tb,rows" is null or not an object.
    Only way out at that time is to close the browser. This was using IE8.
    --bill
     
  11. Dashiell

    Dashiell Network Guru Member

    That error is in relation to the new "web usage" feature. I had turned it on before clicking it, so I never got the error on setup. I tested it right now and got the error. In short, if the web usage feature is turned off and you click on it, that is when the error occurs and it does lock up the browser.

    You can find the on/off area in administration/logging.

    I am not seeing any throughput drop, though... my other two rt-n16s are running teddy's 49vpn build at the moment and they seem to run neck and neck with vic's.
     
  12. psk31

    psk31 Guest

    Just noticed that the tx power is set down to 27 mW where default says it should be 42. Is there any reason it should be set that low? I have my old 54GL's running at 50 without issue.
     
  13. FattysGoneWild

    FattysGoneWild LI Guru Member

    Transmit power stock for the N-16 is 17mW I believe.

     
  14. myersw

    myersw Network Guru Member

    Am running Vectek's 1.28 on my RT-N16. The default transmit power is 17mw on mine which matches the OEM from Asus as well as DD-WRT.

    Dashiell, yup. turned on the web logging and now I do not get the error message. Guess it needs a default oops you have not turned logging on type of message. I was just starting at the top of the menu and clicking away to see what was there when I got that message.

    Other then the question of throughput things seem to be running fine.

    Update:
    Just rebooted the N16 and now my throughput seems to be about what I would expect. I'll keep an eye on it for a few days and see that things seem to stay. Know that one test on one site is not conclusive but have run multiple times on multiple sites before reporting.
    --bill
     
  15. wasp87

    wasp87 Network Guru Member

    I'm getting 4.0-4.25MB/s transfer from LAN to a Wireless N machine, is this acceptable or no?

    I was expecting closer to 10MBps....
     
  16. myersw

    myersw Network Guru Member

    From my windows 7 64 bit with 100Meg network card to the RT-N16 to my wireless connected N laptop I get about 50Mbytes/sec. That was done using Iperf. Running the Windows 7 as the client and the laptop as the server. Get about 72Mbits/sec when running the windows 7 as the server and the laptop as the client. That is with Vectek 1.28 on the router.
     
  17. Sopmod

    Sopmod Network Guru Member

    Anyone know the default ASUS transmit power for a wl-500gp v2?

    So I can set Tomato to the same.

    Cheers.
     
  18. maurer

    maurer LI Guru Member

    same issue for me - 4.3 MiB/s wifi // 4.5MiB/s wired.
    But i had the same values with TB's beta 19.
    I have an old MSI RG60G and getting 11.3 MiB/s from wan (internet) - wired connection.
     
  19. PanRatio

    PanRatio Networkin' Nut Member

    Can`t flash it on Netgear WNR3500L.

    :frown:
     
  20. roxy74

    roxy74 Addicted to LI Member

    idem for me on WNR3500L
     
  21. teddy_bear

    teddy_bear Network Guru Member

    Yep, it should be 10-12 MB/s on 40MHz bandwidth with client cards supporting up to 300Mbps speed - unless you have a bad interference. That's what I'm getting when transferring large files between wired and wireless-N clients with AES encryption (with many small files the speed could be a lot lower). I suppose Vic's mod doesn't have any kernel or wi-fi driver changes compare to mine - so it should be exactly the same in this regard. I believe your slow speed is configuration issue.

    Make sure you use 40MHz bandwidth - otherwise 5-6 MB/s is all you can get. Don't use TKIP unless you absolutely need it - the best combination for wireless-N is WPA2/AES. Also you may try different channels and different sidebands. Note that other wireless APs are not the only source of interference - it could also be caused by various electronic appliances in your or your neighbor houses, so even if you see the "free" channel on the wireless survey it doesn't necessarily mean that this channel will be interference-free. Upgrading (or sometimes downgrading) the client wireless driver can also make a big difference. The fact is that the wireless-N is a lot more picky to configuration and environment compare to wireless-G, so don't expect that your old settings will "just work" as good as before. So it's always worth experimenting...
     
  22. maurer

    maurer LI Guru Member

    Teddy,
    The strange thing is that i had the same low speeds on wired connection to Tomato RT-N16 (4.5MB/s) although on the old MSI I had 11.3 MB/s wired.
    Now i put dd-wrt and i got 8MB/s wifi N and 9.3 MB/s wired.
    So it has something to do with your tomato code.
     
  23. teddy_bear

    teddy_bear Network Guru Member

    maurer,
    Please note that I responded to wasp87's post who was asking about LAN to WLAN transfers.

    What you're talking about is hard to say... WAN to LAN (wired and wireless) computers? Or transfers between wired/wireless computers and the router itself (usb drive on the router)? In such cases you're mixing too many variables... If WAN speed is concerned, I can tell you that people have measured up to ~90-100Mbit down with this firmware, which is very close to the throughput of all other K26-based firmwares without the "fast NAT".
    If however you mean the same as wasp87 - LAN-to-LAN transfers - then my answer is above for wireless, and for wired - the router only works as a switch, so the router's software is not involved when transferring data between 2 wired LAN machines.
     
  24. maurer

    maurer LI Guru Member

    teddy,
    sorry for my confusing post.
    i'm talking about wan<->lan/wlan transfers.
    Maybe no one noticed it - but the speeds are maxing out to 5MB/s.
    I have a 100mbps GPON internet connection.
     
  25. myersw

    myersw Network Guru Member

    I just did a dmesg on my RT-N16 with Victek 1.28 loaded. We now know who made all bugs.
    found this message in the dmesg output

    "All bugs added by David S. Miller <davem@redhat.com>"
    So now we know. ;-)
     
  26. Victek

    Victek Network Guru Member

    myersw .. I think he 'davem' has nothing to do with the bugs .. due to GPL spirit you should keep all contributors who release any utilities/modules you are using in your build. Keep the GPL spirit alive a trusted.
     
  27. teddy_bear

    teddy_bear Network Guru Member

    This has been fixed in git (along with some WebMon improvements suggested by Toastman). And although I'm happy to know who to blame for all bugs now, I regrettably admit that D. Miller was not responsible for this particular one ;)...
     
  28. myersw

    myersw Network Guru Member

    Victek, just having a laugh nothing more. Have looked at lots of code and comments but never one like Dave M's
    On another note, I have been running your 1.28 RT-N16 firmware and very happy with it. Have not had any issues so far and this is 5 days now.
    --bill
     
  29. 56kb

    56kb Addicted to LI Member

    RT-N16 Victek RAF Releases 1.28.8550 running 10 Hours faultlessly. Wireless very stable but I can get max 243 Mbps
    Thanks "Victek"
     
  30. 4char

    4char Network Guru Member

    RT-N16 running v1.28.8550 very smooth. The only thing is that when I try to change the "CPU Frequency" from the web. It won't take "532,266". Seems like it only takes 3 digits, have to change it from the telnet.
    Thanks for the firmware!
     
  31. 56kb

    56kb Addicted to LI Member

    Try this
    Code:
        #Default:
        nvram set clkfreq=480,240,120
        nvram commit
        reboot
    
        #Overclock(532MHz):
        nvram set clkfreq=532,266,133
        nvram commit
        reboot
    
        #Overclock (533MHz) sometimes doesn’t work:
        nvram set clkfreq=533,266,133
        nvram commit
        reboot
    
    To check if the over-clock worked, simply check the bogomips:
    
        cat /proc/cpuinfo | grep BogoMIPS
    The value should be around 250 or higher… if it’s below 100 try the default clock again.
     
  32. jsmiddleton4

    jsmiddleton4 Network Guru Member

    If its like previous versions of the firmware the only thing you need to enter is the speed. The other two sets of numbers are redundant. The firmware sets the other two parameters internally based on the speed/freq you select.

    So you only need the first 3 digits.
     
  33. chchia

    chchia LI Guru Member

    hi victek, any planning for a 4MB router like RT-N12?
     
  34. 4char

    4char Network Guru Member

    Hi Victek,

    Does the build-in FTP server (vsftpd) support TLS/SSL?
     
  35. azdps

    azdps LI Guru Member

    does this firmware have usb support?
     
  36. myersw

    myersw Network Guru Member

    Yes. Have a flash drive mounted and available via share on RT-N16. This is one of the best firmwares I have loaded, including Teddy-Bear and DD-WRT. Victek has done it again.
    --bill
     
  37. ladysman

    ladysman LI Guru Member

    looks like Teddy's just no VPN...
     
  38. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "Can`t flash it on Netgear WNR3500L."

    Did this get sorted out and fixed?
     
  39. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Just wondering as Fry's has the Netgear's on sale. Do you need to do the mini-ddwrt first and then Victek's?
     
  40. 56kb

    56kb Addicted to LI Member

    I don't think this support "Netgear"
    Victek RAF Releases 1.28.8550 for RT-N16
     
  41. jsmiddleton4

    jsmiddleton4 Network Guru Member

    The Netgear is a MIPSR2 router as is the Asus.
     
  42. ytsejam

    ytsejam Network Guru Member

    According to Victek himself (http://www.linksysinfo.org/forums/showpost.php?p=366943&postcount=736), this firmware should work on a Netgear WNR3500L. However, he seems to be the only one that has successfully flashed it. I have seen at least three posts in these forums where people have bricked their WNR3500L trying to flash Victek's new firmware.
     
  43. jsmiddleton4

    jsmiddleton4 Network Guru Member

    In the discussion on the Netgear 3500 for the 2.6 kernel the process is you flash the mini-ddwrt first. Then the Tomato 2.6 mipsr2 firmware.

    I do not have the router. I would not recommend anyone do anything that I have not done successfully myself.

    I am hoping someone has and can let us know if it worked.
     
  44. ytsejam

    ytsejam Network Guru Member

    The posts regarding bricking the WNR3500L were all upgrading from Teddy Bear's TomatoUSB firmware. So they had already flashed mini DD-WRT and had a version of Tomato running. I would love to hear from someone who has successfully flashed a WNR3500L with Victek's 1.28.8550. I have this router and I am currently running Build 50 of TomatoUSB without any problems, but I would love test out Victek's mod.
     
  45. 4char

    4char Network Guru Member

    Victek,
    Is it possible to have VPN build for the RT-N16 version?
    Thx!
     
  46. jsmiddleton4

    jsmiddleton4 Network Guru Member

    "had a version of Tomato running."

    Yes you are correct.
     
  47. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Sure would like to hear something on this Netgear issue.
     
  48. Azuse

    Azuse LI Guru Member

    I'm with 4char.

    Is there any plan/possibility of a vpn build for the N16 at some point?

    As much as I love my 54Gl, it's showing it's age these days, and is needing replaced soon... :)
     
  49. siaokia_leong

    siaokia_leong Addicted to LI Member

    erm..juz would like to ask..is asus n10 supported as well?
     
  50. Kibe

    Kibe LI Guru Member

    Victek, thanks a lot for your hard work on RAF 1.28!

    Would you check the link on your website for the Tomato RAF 1.28.8650. ONLY FOR RT-N16 or MIPSR2 routers (Kernel 2.6) Extended + VPN?

    For some reason its broken.
     
  51. Kye-U

    Kye-U Addicted to LI Member

    Quick question: can I use WPA2 AES over two WRT54 routers (both Access Point + WDS) with this new firmware? I know before it supported only WPA.
     
  52. Devotedfollower

    Devotedfollower LI Guru Member

    Kye-U,

    my experience was the same with you...WPA only would be curious to hear if it works? Can you just test it out?
     
  53. Kye-U

    Kye-U Addicted to LI Member

    I managed to get it working using the steps on http://www.polarcloud.com/tomatofaq. One additional step I had to do for BOTH routers (that I was missing I guess), I just had to go to Advanced => Routing and TICK Spanning-Tree Protocol (other settings were left as default, Gateway, Disabled, DHCP Routes ticked)

    WPA2 with AP + WDS enabled on both routers working fine :)
     
  54. Devotedfollower

    Devotedfollower LI Guru Member

    nice man thanks for trying this out and getting it working! Next time I have to setup such a network I'll be sure to send you a pm if I run into probs ;)
     
  55. Dashiell

    Dashiell Network Guru Member

    I think we just got one... ;) The link seems down at the moment, though...


    http://victek.is-a-geek.com/tomato.html
     
  56. Azuse

    Azuse LI Guru Member

    That's 2.6 mipsr1, not mipsr2.
     
  57. Kibe

    Kibe LI Guru Member

    Did anyone manage to download Tomato RAF 1.28.8650. ONLY FOR RT-N16 or MIPSR2 routers (Kernel 2.6)?

    I'm trying to download it, but the link on Victek's website is broken. I would really appreciate if someone would provide a mirror for this version.

    Thanks a lot!
     
  58. Dashiell

    Dashiell Network Guru Member

    Seems live now!
     
  59. Kibe

    Kibe LI Guru Member

    Indeed! Thanks for the info!

    My RT-N16 is rocking solid with RAF 1.28.8650!
     
  60. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Did anyone ever figure out the Netgear 3500 issue?
     
  61. dkirk

    dkirk Network Guru Member

    I have the 8650 build running for a week now and everything has been fine. I turned on the USB sharing and turned on the WINS server as well. Seems that ever since that change I've been having troubles with DHCP and one device alone. I've got a dozen devices getting and holding an IP address from the Tomato DHCP but my Samsung Galaxy / Android mobile phone has issues. It'll get an IP address and use it successfully for a while but if I make the Android device sleep and wake up, or reboot, it'll get stuck in a loop requesting a new IP, and here is but a small snippet of the log:

    Oct 26 16:48:14 router daemon.info dnsmasq-dhcp[6120]: DHCPREQUEST(br0) 192.168.1.128 b4:07:f9:2d:fb:9a
    Oct 26 16:48:14 router daemon.info dnsmasq-dhcp[6120]: DHCPACK(br0) 192.168.1.128 b4:07:f9:2d:fb:9a
    Oct 26 16:48:28 router daemon.info dnsmasq-dhcp[6120]: DHCPREQUEST(br0) 192.168.1.128 b4:07:f9:2d:fb:9a
    Oct 26 16:48:28 router daemon.info dnsmasq-dhcp[6120]: DHCPACK(br0) 192.168.1.128 b4:07:f9:2d:fb:9a
    Oct 26 16:48:39 router daemon.info dnsmasq-dhcp[6120]: DHCPREQUEST(br0) 192.168.1.128 b4:07:f9:2d:fb:9a
    Oct 26 16:48:39 router daemon.info dnsmasq-dhcp[6120]: DHCPACK(br0) 192.168.1.128 b4:07:f9:2d:fb:9a
    Oct 26 16:48:49 router daemon.info dnsmasq-dhcp[6120]: DHCPREQUEST(br0) 192.168.1.128 b4:07:f9:2d:fb:9a
    Oct 26 16:48:49 router daemon.info dnsmasq-dhcp[6120]: DHCPACK(br0) 192.168.1.128 b4:07:f9:2d:fb:9a

    This will go on until the Android gives up. Resetting the Android does not cure it. Rebooting the router cures it, for a while, maybe a few hours or so. During this time where it works I can make the Android sleep and it will request and accept a new IP and it works fine, but somewhere in time something changes and I need to reboot the router in order for the Android to get another successful IP. No other device I have is seeing this problem. The Android had a static IP setting but I removed that to make sure there wasn't a problem there but nothing changed.

    Second *minor* issue, when I reboot the router from the web GUI the final "Continue" button appears before the router is ready for it, resulting in the web page timing out. If the reboot process would count just another 5, maybe 10, seconds then the "Continue" button would work as expected.

    Thirdly, the "CPU Frequency (MHz)" setting on the "Status/Overview" page shows no value. In the "Advanced/Misc" the CPU speed is blank there. I ran the process that clears the NRAM after install so is should be at default, but is [blank] the correct default value? If not, what should it be?

    [edit] I set the CPU value manually by running "nvram set clkfreq=480,240,120" and then rebooting, and that value now shows. I'm left wondering if my "clear nvram" was not successful and maybe that is also the cause of the DHCP issue. Thoughts?
     
  62. rhester72

    rhester72 Network Guru Member

    The first problem looks like an Android issue - DNSmasq is (correctly) advising the device that it had that IP before and is acknowledging that it is still issued (and updating the DHCP lease in the background), but for whatever reason, the Android isn't "buying" it. The reason rebooting the router appears to "fix" it is because DNSmasq does not persist the IP lease table across reboots and the router will think that the lease is "new" after a restart.

    The router _really_ shouldn't be taking that long to reboot...I've found the Continue button to actually take too long on the devices I've used (Linux WRT54G/GS/GL, Asus RT-N16). Anything interesting in dmesg that suggests some sort of timeout? Have you increased boot_wait beyond the default 5 seconds?

    No idea re: the CPU speed issue.

    Rodney
     
  63. dkirk

    dkirk Network Guru Member

    I did not increase the boot time, this router was essentially new, just bought it last week and didn't do too much to it yet. Turned on the USB toys and played with them is about all I did.

    I just executed a clear NVRAM and the router reboot was not yet complete at the end of the countdown and pressing the "Continue" resulted in error. Waited 10 seconds and tried again and that pause got me in. I ran the "thorough" clear NVRAM this time and it was fully loaded and ready to go when I pressed "Continue". The thorough clean most certainly did something to fix that little problem.

    The CPU speed still shows blank after the clear. I forced it through NVRAM SET and now I see values there. After both clears the values I entered into "Tools / System" were still there, both clears did not touch this field. There might be something amiss in the configuration clear with this 8650 build with regard to the CPU speed and Tools/System.
     
  64. myersw

    myersw Network Guru Member

    Interesting. I have a Samsung Galaxy S Facinate from Verizon. It connects and works fine with my RT-N16 running Vectek's latest.
    --bill
     
  65. dkirk

    dkirk Network Guru Member

    I just went through a configuration clear and reconfigure the router, with no changes seen and same issue with the Galaxy alone. When it, the phone, comes out of sleep and re-establishes the WiFi connection it shows an IP of 192.168.1.254 instead of the previous one of 192.168.1.108 and the router log is showing:

    Oct 27 13:37:51 router daemon.info dnsmasq-dhcp[745]: DHCPREQUEST(br0) 192.168.1.108 b4:07:f9:2d:fb:9a
    Oct 27 13:37:51 router daemon.info dnsmasq-dhcp[745]: DHCPACK(br0) 192.168.1.108 b4:07:f9:2d:fb:9a David-Android

    I have a static IP configured for it now and it works the first time, gets the proper IP, but after sleep/awake it's gone. It was working fine all weekend, that's the odd thing, and I haven't touched the router since the first day I installed it. I'm sure it's a Galaxy/Android thing now that I look at it deeper. One of the network apps shows the device having that .254 "Device IP" while the IP is shown as being correct ".108". Something is confused inside the phone and I'll look at the apps running a bit closer. The router is acting fine and proper now that I ran the thorough clear, and the log is no longer showing the bouncing DHCP error message anymore, I merely get a single instance now.

    [edit] The android problem ended up being a program called "Android Desktop Remote" and once I un-installed that the DHCP problems went away.

    [edit II] The DHCP problem returned the following day. This is obviously an Android issue
     
  66. myersw

    myersw Network Guru Member

    Thanks, I'll try to remember not to install the Android Desktop Remote on my Galaxy S.
    --bill
     

Share This Page