1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Victek's mod based on x.23 is available...

Discussion in 'Tomato Firmware' started by jsmiddleton4, Nov 20, 2008.

Thread Status:
Not open for further replies.
  1. jsmiddleton4

    jsmiddleton4 Network Guru Member

  2. Victek

    Victek Network Guru Member

    I'll change in few hours.. but the upload speed has been improved. Thanks

    The server is ready and you have access also to the source code in the same page.
     
  3. kiskakas

    kiskakas Network Guru Member

    I downloaded 1.22.8005 and tried. Everything works fine, but cpu speed change not work.
    I tried 216mhz, then Save, but nothing happens. I cleared nvram, try everything, but not works. (WRT54GL)
     
  4. Victek

    Victek Network Guru Member

    Yes, is not working until I can see how to avoid a disaster for WRT54 V1 ..., the feature is disabled now
     
  5. jsmiddleton4

    jsmiddleton4 Network Guru Member

    The old fashion way works fine though.

    nvram set clkfreq=216,108
     
  6. seraphsf

    seraphsf LI Guru Member

    Vegas script

    thanks victek for the mod. I upgraded from your previous mod and the Vegas script wasn't in the Script\Init screen when I upgraded. Is it possible for you to post the Vegas script that's in the Script\Init screen?
     
  7. kiskakas

    kiskakas Network Guru Member

    Victek,

    WRT54G v1 / v1.1 uses Broadcom 4710. Maybe is it possible to watch dmesg at boot, to find out, if wrt is v1 or v1.1 ? If yes, disable CPU settings.
     
  8. Victek

    Victek Network Guru Member

    Yes, by stats.nvram.boardtype I think is the best fit to hide the option. Thanks
     
  9. Meffy

    Meffy LI Guru Member

    Any chance to add tcp vegas inside?O_O
     
  10. humba

    humba Network Guru Member

    @meffy: check out this thread.. it's already available.
     
  11. Victek

    Victek Network Guru Member

    It's built in already.
     
  12. microbob

    microbob Network Guru Member

    Do I need to add the startup script or is it already activated by default?
     
  13. Victek

    Victek Network Guru Member

    Already written in administration/scripts/init
     
  14. microbob

    microbob Network Guru Member

    I didn't see it there. I did add it though. I upgraded from 1.21.8005.
     
  15. gingernut

    gingernut LI Guru Member

    Did you do a clear Nvram to clear out some old settings?
     
  16. Victek

    Victek Network Guru Member

    No, just upgrade, new variables are added but none is deleted or swapped, so, only upgrade should be enough unless you want to clear everything. :)
     
  17. Victek

    Victek Network Guru Member

    echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid

    But if you reset the router after upgrade or after performing a clear nvram will create the restoration of default parameter and show you the script in the administration/scripts/init window
     
  18. jsmiddleton4

    jsmiddleton4 Network Guru Member

    How do you tell if TCP Vegas is doing anything vs. Tomato without it? What will we see?

    Sorry have another question. I don't want to assume anything.

    If DHCP server is disabled, like for Pure AP type setups, do we need to disable it with

    echo 0 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid

    in those devices?
     
  19. rhester72

    rhester72 Network Guru Member

    There is no visible indication. The question is how efficiently your uplink throughput is managed. Are things better or worse than before? With or without QoS?

    It depends.

    If it is primarily used for wireless, it's better to disable it for higher throughput. If not, it's fine to leave it enabled.

    Rodney
     
  20. spliff

    spliff LI Guru Member

    When I try to extract Tomato_RAF_1.22.8005.7z I get an error that it is not a valid archive. I tried winrar and 7zip.
     
  21. Victek

    Victek Network Guru Member

    Ok, try again, I think 7z in Gnome is producing some strange results... I swapped to other location with the package done in windows.
     
  22. Kiwi8

    Kiwi8 LI Guru Member

    I have a question for Victek. Are u planning to compile the version for New Drivers (ND) too? Thanks :)
     
  23. spliff

    spliff LI Guru Member

    Thanks it works now. Do these include the ND driver? I have three ASUS WL-520GU routers.
     
  24. Merlyn_3D

    Merlyn_3D Network Guru Member

    Good question. Is there going to be a ND version of this?
     
  25. Victek

    Victek Network Guru Member

    Yes, but at first I would like to try with test before going public. Do you want to try? send me a PM and I let you know the link. I need feedback before showing the link.

    Thanks
     
  26. Kiwi8

    Kiwi8 LI Guru Member

    I dun mind trying. :)
     
  27. kardzzz

    kardzzz Addicted to LI Member

    I just upgraded to Victek's 1.22 mod from 1.21. I have read about Vegas congestion control when I was using DD-WRT so wanted to try it again. I added the following the my admin/scripts/init:
    echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_alpha
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_beta
    I have disabled QoS (which actually worked pretty well) and can see faster uTorrent speeds.

    I will test for a few more days. Thanks Jon & Victek for all the work!!

    *I did notice that my 1.21 required frequent reboots.
     
  28. ~nephelim~

    ~nephelim~ LI Guru Member

    Thanks for this mod :thumbup:
    I also used the previous one and I really appreciated it.

    In this version I noticed that every syslog message logged by my syslog service (Administration\logging\Log to Remote System) got a trailing string <\0x0A>.

    Is there a way to revert back to the previous syslog messages without <\0x0A> (maybe an additional optional setting)?
     

    Attached Files:

  29. Victek

    Victek Network Guru Member

    nephelin, I did not touch this part of the code, you should ask Jon about it.
     
  30. rhester72

    rhester72 Network Guru Member

    Not sure if it helps, but I'm not seeing this on 1.22 - my syslog forwards look completely normal. You sure it's not a local issue?

    Rodney
     
  31. Toastman

    Toastman Super Moderator Staff Member Member

    Hi All

    Thanks Vic for the Vegas! My preliminary findings are based on the following.

    I have a condo block currently with 54 active users. About 8 P2P users in there. Rest is a full mix of everything including a few games players.

    Vegas on it's own.... much better than no QOS at all. Pings with no QOS betweeen 350 and 810mS - with 20% dropped (no reply). With Vegas, almost 100% returns, between 350 and 563mS - an improvement.

    The chief online games player here, however, reports no improvement in his latency under heavy load.

    I personally notice that IPTV is workable under full load and free of any lag/stuttering.

    The compile seems stable.
     
  32. Victek

    Victek Network Guru Member

    No Rodney, is a bug, reported by some users to Jon, I got a patch, I hope will be public in some of the coming releases.
     
  33. ~nephelim~

    ~nephelim~ LI Guru Member

    Thanks for verifying the nature of this issue and the additional infos.

    I guess my syslogd software cannot handle that format properly but I will surely stick with Tomato (and your Mod) for a long time :)
     
  34. Victek

    Victek Network Guru Member

    Use Syslog Watcher personal edition.. it solves the issue.
     
  35. Meffy

    Meffy LI Guru Member

    I have read the ddwrt forums regarding this but have you actually felt a difference between just echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid and the above setting?
     
  36. microbob

    microbob Network Guru Member

    Is it recommmended to turn off QOS when running Vegas or can you run both?
     
  37. Dashiell

    Dashiell Network Guru Member

    I am running Syslog Watcher Personal from Snmpsoft, and there is a "<\0x0A>" after each log entry...
     
  38. Meffy

    Meffy LI Guru Member

    I am currently using both and i find it alot faster then the previous version that has no vegas enabled
     
  39. rameshb_v

    rameshb_v LI Guru Member

    Your setting is working very good. I have disabled QOS and only enabled the TCP vegas and inserted the additional lines.
     
  40. peyton

    peyton LI Guru Member

    I'm also OK to try if it doesn't brick my buffalo. :tongue:
     
  41. Victek

    Victek Network Guru Member

    It's already tested and finally ready to be downloaded in few moments.

    Definitive release.

    1.22.8010. Stock driver. Fixed the Syslog remote bug.
    1.22.8500. ND driver.

    Both version include Victek mod's.
     
  42. chchia

    chchia LI Guru Member

    hi victek, what is the benefit of ND?
     
  43. peyton

    peyton LI Guru Member

    That was fast !
    great.
     
  44. Victek

    Victek Network Guru Member

  45. peyton

    peyton LI Guru Member

    I'm unable to connect my laptop with my router since i flashed the ND version.
    My drivers are up to date (wireless 2200BG).
    Any clue ?
     
  46. Victek

    Victek Network Guru Member

    well, you know the ND behavior and incompatibilities... I just integrated. :)
     
  47. peyton

    peyton LI Guru Member

    Arg, will downgrade to normal one.
    Thanks. :p
     
  48. Dashiell

    Dashiell Network Guru Member

    Using Victek's Mod, 1.22.8500ND, on a WRT54GL. Uptime so far, 1 day, 1:53.

    I must say, I have never seen such performance out of this router! Fantastic!

    I've got 5 of these routers over 3 locations. 2 are running tomato stock and 3 have been running Victek's mod. I upgraded the 3 to the newest version above, after learning these models would be compatible with the ND versions. I am running Vegas, a complicated QoS scheme, an elaborate dnsmasq script and an ad blocking script.

    At one location I instructed all with wireless to really "have a bash" at the network last night! One was running the new Xbox LIVE Netflix option (with one feature streaming at an HD resolution!), another was streaming DivX from a pc one floor up. I was one floor down on a wireless laptop doing basic surfing and one other was on a wired connection at the site of the router. This went on for hours. The person streaming DivX even left it running through the whole night. Not a single issue and it seems that the range for the wireless is even further than it ever used to be. In the past, I've noticed the wireless laptop drop to 48, 32Mbps and lower, but even with all this going on last night not once did I see it drop under 54Mbps.

    Applause to Jon and Victek! At the moment it really seems this version is an absolute winner!


    11/26: Uptime - 4 days, 10:27
    This firmware is fantastic. I was logged into 2 different citrix sessions, wirelessly, from 2 different laptops while streaming DivX from a PC upstairs. The connection did not falter at all. I've been bashing away at the network since flashing this ND mod. Victek, I take my hat off to you!
     
  49. duntuk

    duntuk Addicted to LI Member

    also using Victek's Mod, 1.22.8500ND, on a WRT54GL....(4hours with 4 active users downloading and browsing) so far so good...
     
  50. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Using Victek's ND mod on 2 Buffalo 54hp's and one WRT54GL. All doing fine.
     
  51. bgcngm

    bgcngm Addicted to LI Member

    The ND firmware file extension is .trx. Could this be flashed without any problem on a WRT54G v1.1?
     
  52. Dashiell

    Dashiell Network Guru Member

    The .trx file flashes just like a .bin file. I used the same upgrade procedure through tomato console. I am using a "GL" but I don't see the G being much different.

    Some have even said you can rename the .trx to a .bin, but the need doesn't seem to be apparent to me. I am told the .trx flashes just as good as a .bin file provided you are not on stock linksys firmware.
     
  53. kardzzz

    kardzzz Addicted to LI Member

    Can I update to the 'ND version' via simple upgrade with no nvram clear? I'm thinking about trying the ND version then roll back without re-inputting my settings.
    Thx
     
  54. Victek

    Victek Network Guru Member

    New Test version Tomato RAF 1.22.8011 & Tomato RAF 1.22.8501ND

    Changelog. Updated to DNSmasq 2.46, that's all. Available in few moments. :)
     
  55. chchia

    chchia LI Guru Member

    hi victek, what command to check is Vegas enabled?
     
  56. Victek

    Victek Network Guru Member

  57. bodbod

    bodbod Addicted to LI Member

    SD/MMC support

    Thx for the hard work to Victek and all the other guys who have contributed in this nice firmware.

    I woul dhave just one question concerning the SD/MMC support, are you planning to integer it into your firmware ?

    much appreciated
     
  58. Victek

    Victek Network Guru Member

    I did on previous releases, but IMO the number of people using this feature is low, then I do not consider to implement it. USB connectivity as it's implemented in some Tomato compatible models is a more natural feature to go.
     
  59. Trunkz

    Trunkz LI Guru Member

    Any chance of the beta builds (test versions) to include the unstable branch of busybox, rather than the stable branch? You could alternatively create a seperate test build, and call it bleeding edge or as such. Would appreciate it :) (Busybox 1.13.0 has some notable improvements that I would like to see in your builds, hence the request)

    Edit ~

    Thought I'd mention this. I had read the TCP implementation by neal (the co-author of tcp vegas), and have stumbled upon a few useful tweaks. These are mentioned/linked to via rodney's thread. It seems there are three entries that control tcp vegas, two of which I'm currently using. I'm not so good at explaining things, so I'll leave it up to those interested to have a read. If you're lazy, this is what I've got running atm: (Paste into the Init section of Scripts, under Tomato)

    Seems to work well. :)

    2nd Edit ~
    Been messing around with QoS on Tomato, and I've got a few queries. Firstly, I seem to have alot of unclassified entries, 98% of which are coming from this:

    Protocol: TCP
    Source: 192.168.1.14 (Me)
    Source Port: <x> (All in the 652xx range))
    Destination: 192.168.1.1 (Router)
    Destination Port: 80

    This could quite possibly be me accessing the webgui, however I've placed an entry into the classification section of QoS, as follows:

    Protocol: TCP
    Destination Port: 80
    Destination: 192.168.1.1
    (In theory, all TCP traffic bound to 192.168.1.1 on port 80 would then be classified as Low, however it doesnt.)

    I've removed port 80 from all my classifications, minus that one ofcourse as I connect behind an HTTP proxy (university) thus the only port used is 8080. Any ideas? :eek:
     
  60. bodbod

    bodbod Addicted to LI Member

    To Victek

    Thx Victek for the feedback,

    shame for SD/mmc support as modifications are already done on my router and i am using it for testing some network applications. In this case, could you direct me to one of your previous version which works on WRT54GL V1.1 and SD/MMC support.
    I am running the 1.14 tomato firmware.

    Is the module supporting this part easy to compile in your last version source ?

    thx for your help and the hard work anyway !
     
  61. Victek

    Victek Network Guru Member

    Well, I think you can do it simple, download my source code, download the source code of any mod supporting SD/MMC card and make a diff to see differences but only related to SD/MMC. You should also build a new kernel with fs for the SD/MMC. I think is not difficult.
    I got almost information for kernel build to SD/MMC from Openwrt hardware mods. :)
     
  62. Dashiell

    Dashiell Network Guru Member

    First let me state I am by no means a Linux expert, but I thought I'd ask...

    Is it correct that the script should read:

    echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_alpha
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_beta


    ?

    Should not the second entry be "echo 2 >" ?

    Pardon if I am such a newb.


     
  63. bigclaw

    bigclaw Network Guru Member

    Yes.

    No.

    See http://neal.nu/uw/linux-vegas/.
     
  64. Dashiell

    Dashiell Network Guru Member

  65. Kiwi8

    Kiwi8 LI Guru Member

    This has been discussed before. The issue is that the QOS only affects WAN-side traffic and thus, all local connections (ie from one computer to another computer connected to the same router) are not classified.
     
  66. spliff

    spliff LI Guru Member

    Victek,

    I am having trouble getting the IP QOS working properly. I tried setting hard limits for my desktop at 500k but it still downloads at full speed.

    [​IMG][​IMG]
     
  67. rhester72

    rhester72 Network Guru Member

    Tomato QOS ignores all LAN requests by design (read: source and destination both on the local subnet) and thus considers them Unclassified.

    Rodney
     
  68. vanhh

    vanhh Network Guru Member

    echo 1, echo 0, echo 3 or echo 2

    What does the number following 'echo' command mean? Why do we have to chose which number to use? How do we know which number to choose from? And how's important? noob questions, want to learn :)

    thanks,
     
  69. rhester72

    rhester72 Network Guru Member

    The reply that answers your question is only 5 posts up (#63).

    Rodney
     
  70. Trunkz

    Trunkz LI Guru Member

    Oh alright, I just thought it was weird. I dislike so many unclassifieds xD Makes my graphs look crap, and we all know the real reason people use QoS is to have pretty graphs! ;)

    On another note, I remember Tomato used to support overclocking the CPU of the router from the admin panel. Was this feature removed, as I can no longer see it :eek:
     
  71. rhester72

    rhester72 Network Guru Member

    It was removed for safety reasons, I believe, but can still be set manually in NVRAM from the CLI.

    Rodney
     
  72. vanhh

    vanhh Network Guru Member

    you missunderstood my questions, but nevermind.
     
  73. rhester72

    rhester72 Network Guru Member

    *shrugs*

    The page linked to in that reply _precisely_ answers all the questions you asked.

    Rodney
     
  74. ntest7

    ntest7 Network Guru Member

    The command "echo 1" prints the number "1" to standard output, just as "echo hello world" would print "hello world". The "> /path/to/somewhere" redirects standard output the the specified path.

    In the example posted earlier, the vegas driver looks at that special location for a specific value, and changes its behavior based on the value it finds. So the value you echo is determined by the vegas driver and documented there.

    For further enlightenment, you'll need to get a book on Unix/Linux, or maybe google around some.
     
  75. Ropson

    Ropson Guest

    SD mod very welcome :) this mod don't need many resources so whay not ??

    Are you planning join SgtPepperKSU mod (with VPN GUI) into your firmware ?
    If yes please add also IMQ increase up to the 16 like in Test version 1.20.8003

    (static unsigned int numdevs = 15 ; in tomato/release/src/linux/linux/drivers/net/imq.c
    )


    WE want all-in-one mod :biggrin:

    P.S thank's for the great work !!!
     
  76. illtww

    illtww Network Guru Member

    Help!
    How Do i set up QoS on my Tomato'd wrt54gv4. my XBMC keeps dropping the connection while doing other things on the network. UGH! Cannot watch my movies.

    Config:
    Wrt54gv4 ---> P330w ----> Xbox

    P330w Wireless Wpa2 bridge to the xbox.
     
  77. bripab007

    bripab007 Network Guru Member

    QOS doesn't get applied to LAN-to-LAN packets, so your XBMC dropping connection is due to something else.
     
  78. illtww

    illtww Network Guru Member

    hmm..

    I am thinking my zyxel p330w cant handle wpa2 then. :(
     
  79. Victek

    Victek Network Guru Member

    ....
     
  80. bodbod

    bodbod Addicted to LI Member

    Hey Victek, sorry to bother you again with this SD mod... but
    what was the previous version which was stable, could you direct me to it (ND or not ND I don't mind)
    I would need it to compare with the last source if possible in order to check the code

    much appreciated
     
  81. Victek

    Victek Network Guru Member

    Release 1.14.8500 was very stable, slow transfer but stable, unfortunately I don't have the source for this version, neither the bin file, if somebody got this version you will have a chance. After the low response I declined to build in the following versions. I think roadkill version 1.14 was also stable, we shared the code.
    Link of SD/MMC pictures. http://www.adslzone.net/postp879296.html#879296
     
  82. Outer Marker

    Outer Marker Guest

    Hello Victek,

    You may not have seen some of my other posts, but can you tell me a little bit about your testing with NAT-PMP via miniUPnP? I was wondering if you are still considering including this in your mod.

    Thank you! :biggrin:
     
  83. Victek

    Victek Network Guru Member

    I have no plan to go for it because I have no information and enough skills. Sorry.
     
  84. mstombs

    mstombs Network Guru Member

    I'm a big fan of miniupnp, I'm sure I can build a working example for Tomato that can be run from /var or /jffs via a shell script. That would help others review and decide what options should be configurable if built into a mod. I am not brave enough to attempt to build in and distribute a customized mod of Tomato (cheap adsl routers are easier to brick then repair or throw away!). Maybe have time this weekend...
     
  85. Outer Marker

    Outer Marker Guest

    Oh thanks! This is brilliant news.
     
  86. mstombs

    mstombs Network Guru Member

  87. clweb

    clweb Addicted to LI Member

    I have installed Tomato RAF 1.22.8500ND today.
    Worked fine, better up and down speeds than standard Tomato.
    But after a few hours I noticed that the transfer speed from internet was very slow (120KB/s instead of 1.5MB/s). Also a transfer WiFi to LAN was that slow (120KB/s).
    Before I restart my WRT54GL, I put the WLAN MTU from Auto to Manual 1500, and the speed is OK again.
    Anybody else noticed that ?
     
  88. wasp87

    wasp87 Network Guru Member

    Installed RAF 1.22.8011, running fine so far :)
     
  89. Victek

    Victek Network Guru Member

    Happy to see this mod release is running free of troubles. I can go for another job now for the next release.
     
  90. gptro81

    gptro81 Addicted to LI Member

    Hi Victeck, I'm using Tomato RAF v1.22.8010 on a WRT54GL v1.1 and IP/MAC Bandwidth Limiter its not working, I have another WRT54GL v1.1 running Tomato RAF v1.21.8005 and IP/MAC Bandwidth Limiter works perfect ! Is this a known bug?. Gracias for this amazing firmware.

    Greetings from Mexico!
     
  91. Victek

    Victek Network Guru Member

    I go to check it, thanks
     
  92. Larix

    Larix LI Guru Member

    Victek did you fix it, too?

     
  93. Victek

    Victek Network Guru Member

    Yes, remote logging bug is fixed in the first mod release and updated to DNSmasq is fixed in the test version.
     
  94. bodbod

    bodbod Addicted to LI Member

    Would it be possible to add a function which i think should be included in the router with a simple and nice interface : a socks5/proxy.
    this would be a real plus comparing to all the other firmwares, srelay could be one of the option. The interface would make it really simple to configure.
    what do you think victek ?
     
  95. Meffy

    Meffy LI Guru Member

    Reporting my experience after 2days uptime.Noticed a huge drop in speeds with tcp vegas after roughly 2 full days of bittorents.Websites are slow and sometimes even timing out real fast.Doing a router reboot seems to fixed this tho.Is this related to vegas in any way?
    10mb dl/1mb ul btw
     
  96. Meffy

    Meffy LI Guru Member

    Have you tried the SSH daemon?
     
  97. Victek

    Victek Network Guru Member

    I don't know without deep deep information, but I think this version is one of the most robust versions of Tomato since you have SpeedMod and Vegas working together. You can try to run QoS also (it can run in paralell also) but as I said, logfile is needed to know what happened.
     
  98. Meffy

    Meffy LI Guru Member

    EDIT:A reboot didnt fix it.I upgraded to the test ver(8011) 2mins ago and the problem went away.8010 seemed to be giving me massive timeouts after 2 days of heavy BT.I'll see how it goes in a few days!

    Running qos(no speed limits tho) with vegas all this time btw
     
  99. Victek

    Victek Network Guru Member

    The 8011 test version only adds DNSmasq 2.46, no other changes. Let see what reacts now.. but thinking objective, the behavior should reproduce again.
     
  100. Meffy

    Meffy LI Guru Member

    Wow...And just when i thought it was gone.
    Updated firmware->ran torrents->surf net
    Less than 1hour and it suddenly went to a crawl.UL speeds were high as usual but dl dropped to 3mbit?wtf?(I did a speed test from my ISP after the update(8.xxmbit) and ran one during the crawl(3.xxmbit)

    Is there any way for me to grab the logs you need?
     
Thread Status:
Not open for further replies.

Share This Page