1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Victek's mod based on x.23 is available...

Discussion in 'Tomato Firmware' started by jsmiddleton4, Nov 20, 2008.

Thread Status:
Not open for further replies.
  1. Victek

    Victek Network Guru Member

    Just use QoS and restrict the priority for P2P (the default QoS configuration example is pointing in this way). Look at warning messages in Logfile
     
  2. clweb

    clweb Addicted to LI Member

    I would say, try a complete reset and reconfigure by hand. The problems from my earlyer post came back a day later, and are solved after I did a reset and reconfiguration.
     
  3. Meffy

    Meffy LI Guru Member

    Done in 8000.Did a full nvram clear

    Done in 8000 as well(DNS+Games highest.Http high.Everything else low).I'll go take a look at log files now

    Only error im seeing
    Dec 1 00:35:49 Bankai user.err kernel: sflash: found no supported devices

    EDIT:I have found the problem i think
    When my UL exceeds 50% of my full UL speed my dl starts to drop massively to some dumb value like 20KB/s.Been reading the ddwrt forums and some people have also noticed that they are unable to maintain full ul speeds with vegas?(ul drops at a certain point n stays there)Its nothing to do with the firmware!

    Close to a 99% dl drop with this when ul is above 50%
    echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_alpha
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_beta

    Close to a 90% dl drop with this when ul above 50%
    echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid

    I'm getting rid of vegas if i cant find a way to fix this:(
     
  4. Victek

    Victek Network Guru Member

    Meffy,

    You pointed a very good advice about Vegas and behavior, I read it also in dd-wrt forums, you are right in your investigation.

    BTW, after BusyBox had some some issues related logging I'm upgrading to 1.13.1 (stable version), another test release will come soon.
     
  5. mstombs

    mstombs Network Guru Member

    Anyone tested the new feature to be able to assign multiple MACs to same IP? Should be useful for a laptop that can connect either by wired or wireless, but will probably need custom config not web gui?

    Any comment about size - do you now have room to tick the box to enable the sendmail client?
     
  6. wasp87

    wasp87 Network Guru Member

    I've been using 1.22.8011 for days now, and 8010 before that, with TCP Vegas enabled the entire time on a WRT54GL v1.1 with no issues. On my laptop right now running a download and upload test at the same time, and it's still extremely fast.

    Try using these TCP Vegas values:

    echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_alpha
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_beta
     
  7. Victek

    Victek Network Guru Member

    You have your test version ready, sendmail, fetchmail and dropbear 0.52 built in, read PM. :)

    And SORRY for the other people, I try to release few test versions to avoid confusion but if you want to try feel free to ask for, I'll send a PM with the link.
     
  8. mstombs

    mstombs Network Guru Member

    Thanks Victek,

    I can confirm that sendmail works, here's an example script to send an email with the recent log messages as an attachment

    Code:
    #!/bin/sh -x
    # -----------------------
    # Script to send an email
    # -----------------------
    #===============================
    FROM=user@name
    TO=user@name
    SMTP=smtp.yourisp
    SUBJECT="test email"
    ATTACH="/var/log/messages"
    #===============================
    SENDMAIL=/usr/sbin/sendmail
    
    echo "To: $TO
    Subject: Router test message
    Date: $(date)
    
    Hello $TO
    
    Please find attached the latest log messages
    
    Best regards,
    Your beloved router."|$SENDMAIL -t -H "$SMTP" -f "$FROM" -a "$ATTACH"
    All is not quite right however, I couldn't get winscp to work with the new version of dropbear - initially connected then kept timing out. So had to test script using Telnet and vi. I'm sure its not my PC as I can connect to adsl router through Tomato router and edit files fine (same version of Busybox 1.12.2 on Adsl router, older dropbear).

    [edit] A reboot of PC and router being left overnight has fixed winscp, probably an issue to do changing hardware at same IP address
     
  9. Meffy

    Meffy LI Guru Member

    I'm actually more interested in long periods of high UL and high DL then short speed tests,

    I've disabled QoS and am using

    echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_alpha
    echo 3 > /proc/sys/net/ipv4/tcp_vegas_beta
    echo 2 > /proc/sys/net/ipv4/tcp_vegas_gamma


    My ul increases rapidly..reaches the max then drops shortly after before increasing again to the max,repeating itself
    .Same pattern is seen by dls in which they drop increase then drop,repeating itself without ever going near its max values.I'll see how it goes in a few days before i try enabling QoS to improve it further
     
  10. peyton

    peyton LI Guru Member

  11. tievolu

    tievolu Network Guru Member

    Try the default values instead (and no QOS) - they seem to work much better for me:

    Code:
    echo 1 > /proc/sys/net/ipv4/tcp_vegas_cong_avoid
    echo 2 > /proc/sys/net/ipv4/tcp_vegas_alpha
    echo 6 > /proc/sys/net/ipv4/tcp_vegas_beta
    echo 2 > /proc/sys/net/ipv4/tcp_vegas_gamma
    I initially specified the values you describe in your post after reading about Vegas on the DD-WRT forums, but I noticed some odd problems with upload maxing out at about 50% of my capacity after a couple of hours, and never returning to normal.

    The behaviour is MUCH better for me with the default values. QOS seems to be completely unnecessary for me now.

    Hope this helps!
     
  12. Meffy

    Meffy LI Guru Member

    EXACTLY whats happening here.Im getting round 50-60% upload maxing and when this happens my DL crawls down by 90%.Will try your advice here:)

    Edit:Dls are still slowed down but Ul seems slightly higher.Included a picture and QoS is disabled.

    Black arrows show DL speed when UL is closed to disabled
    Red arrows shows DL speeds when UL is above 60% but below 80%

    [​IMG]
     
  13. Victek

    Victek Network Guru Member

    The first mod and test releases incuded already the modified SpeeMod.. no changes. :) look at the log when Tomato starts and you can see the patch applied. I followed the resther procedure
     
  14. Victek

    Victek Network Guru Member

    luk-a-sz, your modified version with BW expanded to 40 user is ready, you have a PM with the link. I say the same, if some user is interested in this modified version let me know by PM, it will not be released to public until next version.
     
  15. peyton

    peyton LI Guru Member

    Oh sorry, my mistake. :tongue:
     
  16. Toastman

    Toastman Super Moderator Staff Member Member

    Meffy, I haven't noticed this behaviour myself, but could it be prevented by setting your uplink QOS max setting to 50% ?
     
  17. Victek

    Victek Network Guru Member

    You welcome, it's normal when there are many mods in the forum, in the other way.. is positive, Tomato is alive again ;)
     
  18. Meffy

    Meffy LI Guru Member

    @ Toastman
    Yes dls are high as usual.I noticed in several graphs then when dl goes up,ul drops.Ul goes up dl drops.Doesnt seem like its random as i can reproduce them
     
  19. Victek

    Victek Network Guru Member

    If your connection is using adsl modem you must keep enough ul to allow a SYNC between your adsl modem and the DSLAM, if you didn't a random drop in speed connection will be usual. I keep my upload rate at 2/3 of the total UL bandwidth.
     
  20. Meffy

    Meffy LI Guru Member

    Cable modem here.Tcp vegas disabled allows me to use dl and ul both 80% and above.I would have disabled vegas but lots of people reporting high speeds without qos does sound tempting:)

    EDIT:
    I have found several graphs here
    http://img374.imageshack.us/img374/4339/tcpccalosspf3.png
    http://img356.imageshack.us/img356/609/tcpccadelaygq9.png

    Seems like while vegas may be better for wireless connections,BIC seems to be alot better for wired one.Can someone using a wired connection do a DL test when UL is above 60% and post some results here?Thanks!
     
  21. StSanya

    StSanya Addicted to LI Member

    Hi!


    Tomato 1.22.8501 - Linksys WRT54GL


    What's this? Big problem?
     
  22. Trunkz

    Trunkz LI Guru Member

    I appreciate that the test-build is being upgraded to incorporate BusyBox 1.13.x, will the build be posted on your site first, or here?
     
  23. Victek

    Victek Network Guru Member

    StSanya

    No it's related to some of the host files in your PC's.. check for inconsistencies in your PC's hosts files
     
  24. Victek

    Victek Network Guru Member

    I will post here
     
  25. StSanya

    StSanya Addicted to LI Member



    Thx! You calmed me... :)
     
  26. spliff

    spliff LI Guru Member

  27. Victek

    Victek Network Guru Member

    I checked and works OK, did you read the IP/MAC limiter manual settings?
     
  28. i1135t

    i1135t Network Guru Member

    OK, one thing I noticed is that after enabling logging for firewall that reports blocked incoming and outgoing connections, I decided to undo it. But when I do, and save, it still shows up in the logs. I even rebooted and still they are in the logs. I hope I don't have to clear NVRAM and reconfigure everything again ...? Right now, I just have logging disabled... :(

    Oh, forgot to mention, I am using Victek 1.22.8501 ND Test version. Just wondering if it's a bug?
     
  29. Victek

    Victek Network Guru Member

    I think not, is a procedure issue, unclick, save, reboot and check. :)
     
  30. Toastman

    Toastman Super Moderator Staff Member Member

    Meffy & others

    I am a little confused when there is mention of Vegas being better for wireless connections, BIC for wired etc. Firstly, I read the opposite, so maybe we need some definitive source.

    The graphs you link to appear to show little significant difference between systems, not enough to worry about IMHO.

    But anyway, the Wireless connection between PC and router surely isn't what this mod is about. Tomato's Vegas congestion control is working between the router and the distant server, which is not a wireless connection.

    Don't the posts you mention refer to Vegas when it is enabled on the PC itself, and not to firmware running on a router?

    For Vegas to work between the PC and Router, it would have to run on the PC. In fact, a Microsoft variant of Vegas is already available within Windows (I don't believe it is enabled by default). You might like to experiment with it, there are details on the web.

    EDIT - it's a hotfix - and only available for 64bit XP. Thanks Rodney!

    So why bother to run Vegas on the router? Because it will then control congestion and improve throughput for everyone connected to that router, without them needing to run Vegas themselves.
     
  31. rhester72

    rhester72 Network Guru Member

    I concur with your statements regarding Vegas being on the outbound link rather than the LAN (where it is of dubious value on a home network).

    However, what I've read about XP suggests that the algorithm is actually Compound TCP (which has similarities to Vegas in terms of fast start, but differences in terms of packet queuing), and is available via hotfix only in the x64 product (as well as Vista, et al).

    Rodney
     
  32. spliff

    spliff LI Guru Member

  33. mejobloggs

    mejobloggs Addicted to LI Member

    I'm using this mod, but cannot telnet or ssh to my WRT54GL. It says invalid password each time. I've tried reseting router and using admin/admin (which works for http login), tried changing the password to whatever, but nothing works :(
     
  34. Victek

    Victek Network Guru Member

    Read FAQ about Tomato before,... when you telnet the router the user is root, password= the same you fixed as login password... :rolleyes:
     
  35. peyton

    peyton LI Guru Member

    Did you tried "root" as the user for ssh/telnet connexion ?


    PS : owned by Victek. Too slow. :halo:
     
  36. mejobloggs

    mejobloggs Addicted to LI Member

    Cool thanks guys, that works. rtfm? :p
     
  37. gsan

    gsan LI Guru Member

    I try the cpu overclock option in the WebUI, but it wont work, so I try it by using below command.

    nvram set debug_clkfix=0
    nvram set clkfreq=240,120
    nvram commit
    reboot

    this method success, but under system info, CPU frequency (WebUI), it shown 240,120....

    what about if I use below command?

    nvram set debug_clkfix=0
    nvram set clkfreq=240
    nvram commit
    reboot

    does it brick the router?
     
  38. Victek

    Victek Network Guru Member

    Just write it:

    nvram set clkfreq=240
    nvram commit
    reboot

    It's enough :) , but be careful, overclocking CPU can damage your router.
     
  39. gsan

    gsan LI Guru Member

    I dont think this is the proper command as I did it last time and it bricked my router but fortunately I manage to debrick it by shorting the pin 16 of ROM with ground.
     
  40. darthboy

    darthboy LI Guru Member

    tomato newbie here. I just flashed v1.22.8010 to my Buffalo. Switched from ddwrt v24-10431.

    An observation. Whenever I reboot my router with ddwrt, the WAN IP that my modem gets from the ISP stays the same. For Tomato, the WAN IP changes with every reboot.

    Is this expected behaviour? thanks.
     
  41. Victek

    Victek Network Guru Member

    Is thee expected behavior if your ISP gives you a public dinamic IP, you're lucky for a restricted download by IP locked from some sites.
     
  42. Toastman

    Toastman Super Moderator Staff Member Member

    #131 Rhester 72 Re Compund TCP

    Yes, you're right Rodney.

    I thought I had read that it was for XP - but when you actually read the Wiki or go to MS website, it does indeed say that it's only for 64 bit XP - and it's a hotfix update. My apologies.

    With all of the excitement over TCP Vegas, I was reminded of the days when I was using Phil Karn's NOS (or rather JNOS - a derivative of same) on amateur packet radio. Rather than the exponential backoff used by TCP on the web, we used linear backoff which was less affected by missed packets. We also had an option to set a backoff limit. The difference was very noticeable. At the time the consensus of opinion was that it must never be used on the web, as it was too aggressive. And somewhere in Vegas notes I seem to remember linear backoff being mentioned - part of the reason for the improvement, maybe?

    EDIT - December 24th - by coincidence, today I noticed a note in SP3 for XP which acknowledges use of software originally written by Phil Karn! Perhaps in Compound TCP, the MS answer to TCP Vegas ???
     
  43. mejobloggs

    mejobloggs Addicted to LI Member

    If I turn IP/Mac Limiter on, my wireless lan screws up and runs at like... 1byte/s. I thought the IP/Mac limiter didn't affect lan?
     
  44. Victek

    Victek Network Guru Member

    IP/MAC limiter affects any LAN device :)
     
  45. T.lancer

    T.lancer Addicted to LI Member

    hey I just upgraded to this new verion, but now my UPnP service isn't workling, anyone have any idea why that might be?
     
  46. Victek

    Victek Network Guru Member

    ??, It works on my router, did you reset nvram and started from zero configuring?...
     
  47. T.lancer

    T.lancer Addicted to LI Member

    yes, I flashed my router (WRT54GS) and reset the nvram and reconfigured everything. yet it still didn't work.

    btw, I read in an earlier thread of yours about IGMP Proxy, which is something I need to get my new IPTV receiver working right. Is this still included in the current version, or was that just a test version?
     
  48. Victek

    Victek Network Guru Member

    Not included in this version.
     
  49. T.lancer

    T.lancer Addicted to LI Member

    ok, I can't seem to find a download link for the older version with IGMProxy. Perhaps you could be so kind and post a link? I'm guessing one can do a full downgrade to an older version, right? my main reason is to get IPTV working, and maybe the downgrad will fix my UPnP problem too.
     
  50. bagu

    bagu Network Guru Member

    Same thing here. Without igmp proxy, i can't watch iptv.
     
  51. Victek

    Victek Network Guru Member

    Well, I never said that this feature was implemented in the mod, neither the official Tomato includes it. Thanks for the comments, I can try to do it, mstombs did somewhere in the forum posts.
     
  52. mstombs

    mstombs Network Guru Member

    I've been interested in miniupnpd and sendmail. Sendmail should be easy - it is just a busybox option when using latest busybox versions, basic email sending worked in the special beta Victek prepared for me.

    igmp proxy is in Linksys WRT54GL official firmware I believe, its not part of upnp.
     
  53. T.lancer

    T.lancer Addicted to LI Member

    of course it's not part of UPnP, but still, I currently have neither ;)
     
  54. Trunkz

    Trunkz LI Guru Member

    @Victek: When will the test versions be upgraded to BusyBox 1.13.1? I was told that the next released version (the one you just released) would include this, however from the changelog, only dnsmasq was updated. Appreciate the efforts :)
     
  55. Victek

    Victek Network Guru Member

    It's not upgraded, did you see any new or interesting command in the new release?, I checked and from my understanding and knowledges there are no remarks for an upgrade.. what do you think?

    Thanks
     
  56. mejobloggs

    mejobloggs Addicted to LI Member

    Ok I can't figure this out. I've set the following as my IP/Mac limiting. Note these two ip's are wired pc's.

    [​IMG]

    Why does my wireless lan now slow down to nearly nothing? Note wireless lan. Wireless internet is fine. Just when I try to get a file off one of the wired computers.

    Turning the speed limiting off makes the lan fine again, and I can transfer files between the wireless and wired pc's fast as
     
  57. Meffy

    Meffy LI Guru Member

    I found out my DL dropping like hell problem was due to my upload maxing out at a value lower then my max upload.Now limiting my torrents via QoS solved this problem but ive seen many people reporting good settings with vegas and qos off.Anyone got a solution or suggestion that i may try out?

    EDIT:Happens around 85% of max ul speed.I'll go see if anyone has any suggestions on the DDWRT forums as they have been using vegas for a longer time
     
  58. T.lancer

    T.lancer Addicted to LI Member

    through magic my UPnP works again, so just waiting for a means t get IGMP Proxy :)
     
  59. gsan

    gsan LI Guru Member

    is there any command to reduce the PPPoE dial-up duration? It seem taken around 20s to redial it if the username or password of the acc is not correct.
     
  60. mstombs

    mstombs Network Guru Member

    Linksys WRT54GL GPL source code contains a binary only module for IGMPROXY, it seems to run under Tomato

    Code:
    # igmprt -?
    Usage: igmprt [-v] [-f] -i upstream_interface
    Options:
    -v                   -- Print debug messages
    -f                   -- Do not fork
    -i upsteam_interface -- Upstream interface name
    The RC logic is also binary only so I can only guess the required starting command is

    Code:
    igmprt -i $(nvram get wan_iface)
    [edit] The binary clearly comes from the GPL source for WRH54G_v1.01.04_USA.tgz, and the required RC files are also there in plain C. May also need an iptables command to enable/block igmp multicast.
     
  61. Pooch

    Pooch Addicted to LI Member

    Smtp auth

    I'm really trying to get sendmail to work and unfortunately I think I'm running into an issue with my ISP (ATT.NET) I've found all the info I'm supposed to use but I can't seem to get it to work right. From what I can tell this it what should be going in the -H string (username:pass@smtp.att.yahoo.com:587) problem is the username has an @ symbol in it too leading the script to believe the server name is everything after the first @ and not the last one. Has anyone had any success getting this to work with ATT as their ISP? Is there another SMTP server I should try using? (Not sure if I can since my ISP is strict about sending unauthenticated email on port 25) Any ideas would be greatly appreciated.
     
  62. Pooch

    Pooch Addicted to LI Member

    Also, are there any other mods for tomato (or other firmware) that use a mail server other than sendmail anyone knows about? I'm trying to get some alerts emailed to me...
     
  63. T.lancer

    T.lancer Addicted to LI Member

    ok thanks I'll try it out and report back. Just to note, I have a european version of the router (germany). But I'll try the command. Where should I insert it? scripts->init? or is there a special place to put it?


    edit:
    ok I just tested a SSH connection and I get the following output wehen I give in that command (igmprt -i $(nvram get wan_iface)):

     
  64. mstombs

    mstombs Network Guru Member

    There's no other tomato mod I know, there are some binaries of ssmtp/msmtp or mini_sendmail that can be used via jffs. There's bound to be a version of dd-wrt with smtpclient that works, but latest may have moved to the busybox version.

    Your problem above seems a simple bug for busybox to fix (but bugtracker is own!), looking at the sourcecode there may be a workaround though. Do not use the the "-H" or "-S" command line options, but put your full smtp server details into a variable

    SMTPHOST="yoursmtphost"

    which is looked for by the code.

    [edit] scratch that - sendmail is much changed in BusyBox 1.13.x "-H" becomes the Helper, "-S" the Server
     
  65. mstombs

    mstombs Network Guru Member

    Oh sorry, suggests to me something extra must be added to kernel build config to enable that option - you need a developer to pick up!
     
  66. T.lancer

    T.lancer Addicted to LI Member

    rats, then I'm stuck for the moment. Maybe Victek can intergrate it into the next version or something, or maybe make a hotfix? I'd really appreciate it :) I'm note the only one with this problem at least, so there is a demand for it ;)

    thanks anyway :)
     
  67. mstombs

    mstombs Network Guru Member

    Hey don't give up - can't see anything wrong with the kernel config. Please try

    Code:
    igmprt -i $(nvram get wan_iface) -f
    The usage comment is wrong, "-f" means fork, i.e. run as a standalone daemon in the background returning control to the console.

    I get

    Code:
    # igmprt -i $(nvram get wan_iface) -f
    # the ifr_name is lo no math
    set the bothstream1 sussess
    set the bothstream0 sussess
    
    # ps
      PID USER       VSZ STAT COMMAND
    ...
     1372 root       628 S    igmprt -i vlan1 -f
     1373 root      1964 R    ps
    
    The mispelling of "success" in clear in the source!
     
  68. T.lancer

    T.lancer Addicted to LI Member

    supprisingly it didn't work. I'm note sure which frimware your using, but I'm using the one of Victek's page. I get the same output as before.
     
  69. T.lancer

    T.lancer Addicted to LI Member

    oh.... I just unchecked the "allow multicast" option in the web interface, put in the command again and it has now given mir the following:


    so just tried my IPTV receiver, no luck. the picture just freezes after around 10 seconds. if I then turn multicast back on, still the same.

    I know howevver, that the DD-WRT firmware does work with this receiver I have, so I guess I need have whatever DD-WRT has. getting there though. :)
     
  70. mstombs

    mstombs Network Guru Member

    doh, Victek's mod already has the same binary in /usr/sbin/igmprt, and it is started by that multicast tickbox in the web gui. The issue is that is just doesn't work I guess!
     
  71. T.lancer

    T.lancer Addicted to LI Member

    hm then I was under the impresion that the IGMP deamon was a differnt one, as the one in tomato doesn't work. what ever...
     
  72. mstombs

    mstombs Network Guru Member

  73. T.lancer

    T.lancer Addicted to LI Member

    yeah I thought that that was somehow allready integrated, but hidden or something. fine.

    then I just have no clue how to add it manualy to the kernel and replace the buggy IGMP thing.
     
  74. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Of course I would like to see this working for your IPTV stuff. Don't get me wrong here. I am wondering why the IPTV thing is using a protocol, whatever the right word is, that is seemingly limited in its application/availability? Is part of the fix for this to get with those folks and ask them to start using something else, something more mainstream, for this thing?
     
  75. Victek

    Victek Network Guru Member

    simple question, do you want me to integrate dd-wrt igmprt in one build and try it?
     
  76. T.lancer

    T.lancer Addicted to LI Member

    well yes that would be really great if you could give it a try :)
     
  77. gsan

    gsan LI Guru Member

    When I'm using VPN such as BolehVPN or Hotspot Shield, the UPnP does not working. is it normal?
     
  78. mstombs

    mstombs Network Guru Member

    igmp is a special type of protocol that must be efficient for ISPs to stream TV to lots of users simultaneously "multicast". It is formally defined in RFC standards so it appears that the CyberTan router proxy is just broken, not an option to use something else. The sources make sit clear that they have been taken from a version in the WAG54GV3, maybe its just old and doesn't handle the latest RFC? IPTV is relatively new in mainstream, and ISPs usually supply their own modems/routers - its good to get the opensource variant working!

    I have another version of igmp-proxy in my adsl router source which is also old

     
  79. jsmiddleton4

    jsmiddleton4 Network Guru Member

    Thanks for the explanation and again I home it gets working for you in Tomato. But your explanation doesn't reduce the credibility of my point. It reinforces the validity of it. If the folks who are doing IPTV want it to succeed, they will have to make it easier for end users such as your self to use it successfully. The idea that they will succeed in this market by using some kind of protocol that is as you have described is ludicrous. The IPTV folks need to make it simple and easy and widespread to maximize their chance of adoption in the market place. It appears to me they are narrowing their chances of success due to their implementation. The pieces of their process is going to harm their business profitability regardless of how kewl IPTV may or may not be.

    Glad Victek is looking for ways to implement it for you. I continue to wonder how one would get the folks behind and doing IPTV to take a bigger picture look at their "pieces".
     
  80. GhaladReam

    GhaladReam Network Guru Member

    Tomato 1.23 released, gonna wait for your mod based on it Vic! :D
     
  81. peyton

    peyton LI Guru Member

    Me too :)
     
  82. Victek

    Victek Network Guru Member

  83. GhaladReam

    GhaladReam Network Guru Member

    aw yeah... You rock Vic!

    Also, I couldn't help but notice that you removed any reference to SpeedMod 8502 from your mod.. Have you removed speedmod?
     
  84. peyton

    peyton LI Guru Member

    don't think so.
    I guess it's that line in the desc :
    I have interrest in this option.
    Could you please make a test version for 1.23 ?
     
  85. LeoKesler

    LeoKesler Addicted to LI Member

    What is this ?

    Sistema de ofuscación para P2P mejorado. (dejar pasar 24 horas antes de postear..)
     
  86. T.lancer

    T.lancer Addicted to LI Member

    I don't suppose that you've integrated IGMP proxy into this build yet? ;)
     
  87. Victek

    Victek Network Guru Member

    No, I will not integrate any "special requeest / features" in the mod version if you like to update your version quick. These features will be implemented in the test releases, later.
     
  88. ryanq

    ryanq Addicted to LI Member

    Hi Victek!

    Your version 1.23.8010 even without the IP/MAC limiter is working very well, TCP vegas combined with QOS priorities is a good solution for networks with also P2P clients. Finally torrenting does not flood anymore my ADSL connection with DNS queries (UDP/53)

    Thank you again!!
     
  89. barry80

    barry80 Addicted to LI Member

    do i need to reconfigure my QoS setting once upgraded from the previous version 1.22.8010?
     
  90. Victek

    Victek Network Guru Member

    barry80, no, not needed.
     
  91. Victek

    Victek Network Guru Member

    ryanq, Thanks, IP/MAC limiter and other features will be built in the test versions to be released soon:

    _ Sendmail /fetchmail
    _ IP/MAC limiter up to 40 users
    _ other features upon request...

    In this way I can release standard RAF mod versions earlier and check/test all the changes introduced by Jon Zarate in his build is not affecting to the new functions in the mod.
     
  92. barry80

    barry80 Addicted to LI Member

    oh thx Victek! this gonna be easier to upgrade ver. by ver. since any latest ver. modded by u can gain much more improvement!
     
  93. Toastman

    Toastman Super Moderator Staff Member Member

    Vic, many thanks for the 1.23 "simple" release with no IP/MAC system, this method of release in stages is nice, though it may be more work ?

    One thing I really don't like in 1.23 is the visibility of the "OUI/add users to lists" function, in Device List. The list is now messy and difficult to read, and mostly off-screen. I'd love a function added to hide the choices but leave them available for mouse selection, like before.

    Toast
     
  94. Victek

    Victek Network Guru Member

    :) .. well ... I'm free of guilty, this is an official modification implemented in 1.23 release ...
     
  95. gsan

    gsan LI Guru Member

    what about with usb support for the WL500gP ? is it possible to include in the coming v1.23 ?
     
  96. agrinmote

    agrinmote Addicted to LI Member

    After upgrading to Tomato RAF 1.23.8010(Victek) which I unable to find IP/MAC limiter option on the left hand side menu. I down load the firmware (Tomato RAF 1.23.8010.7z format) from http://victek.is-a-geek.com/tomato.html, have been reboot the device after upgrade from 1.22, by the way, it works on a WRT54GL. Is there anything wrong with the setting?
     
  97. agrinmote

    agrinmote Addicted to LI Member

    I just read the previous threads, waiting for the important features for IP/MAC limiter, I'm going to temporary downgrade back to 1.22 , thanks Victek, IP/MAC limiter is really cool, the only thing now i'm looking for is per user traffic usages view/control, I'm running a simple scripts at the moment, but find the rules be changed if done any changes such as save IP/MAC limiter settings. Understand that feature is base on iptables. Still have no idea how to sharp the bandwith if over the limit for per user. Look forward if can see user traffic usages control in future versions. Thanks again for you great job.
     
  98. Victek

    Victek Network Guru Member

    agrinmote, please read previous post, I'll implement these features in test version later. :)
     
  99. ryanq

    ryanq Addicted to LI Member

    agrinmote I think you could manage to add QOS classification rules like this:

    Src MAC = 00:AA:BB:CC:DD:EE
    Protocol = Any Protocol
    Port = Any Port
    IPP2P disabled
    L7 disabled
    Class = the priority class you want

    You can define one class for machine / MAC address. Or you could create a class for several ones, in which case you would have to bear in mind that the limits for bandwidth would be shared between all the MACs currently active.
    I, personally, have managed to use a class for one machine with high traffic and low priority (mainly P2P), another one for one machine with normal traffic and normal priority (local server), the rest is shared between the active machines based on protocol/port or service content filter (IPP2P for P2P and eventually L7 for specific applications)

    I managed to do this without the IP/MAC bw limiter, and I could say it works
    as expected, even better seems to have more grained control over bandwidth limiting.

    It needs a little testing to fine tune like this but it can be really worth in my opinion.
     
  100. ryanq

    ryanq Addicted to LI Member

    Since you are open to requests, I put my one.

    SNMP (to continously monitor traffic / bandwidth statistics from another machine without using the admin pages or using rstats which seems quite limited)

    I think there is a binary in the forums and it seems that one already could mount it externally on CIFS.

    If it could be integrated in a test version, more people could be testing this function on different routers

    I don't have any clue whether this could be possible at all in respect of file size impact on the image and impact on CPU (never tested *wrt on my Buffalo).
    What do you say?
     
Thread Status:
Not open for further replies.

Share This Page