1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Vista not connecting to WPA/WPA2.

Discussion in 'Tomato Firmware' started by Devileyezz, Jul 6, 2008.

  1. Devileyezz

    Devileyezz LI Guru Member

    [Solved] Vista not connecting to WPA/WPA2.


    I'm running the latest Tomato, and uptil now everything worked just fine. Now, suddenly, for some reason my Vista Business laptop (Asus V2S-B1) stopped connecting to the WPA and/or WPA2 on Tomato.

    The card is an Intel 4695 ABGN WiFi with uptodate drivers.
    Someone pleaseeee help!

  2. ifican

    ifican Network Guru Member

    well first off you need to determine if it is the router or the laptop. Ideally see if you can connect to some other AP in your area or if you even see any others. See if anyone else can or any other computer can connect to your AP. Once you determine where the problem lies you can focus on fixing it.
  3. Devileyezz

    Devileyezz LI Guru Member

    Thanks for your reply.

    I'm pretty positive it's not the router because it initially worked and nothing was changed (infact, I think two days after the laptop not connecting, I upgraded to Victek's mod)

    However, on the laptop, nothing was changed either. But upon googling, I do see a lot of WPA2/Vista issues.

    I'm on here so someone who might have had the same problem can help out.
  4. ifican

    ifican Network Guru Member

    Well until you rule out one or the other you really wont know. Can you connect to the AP with vista with just WPA or WEP or nothing at all. Anything outside of spectulation will be helpfull because if will give you a baseline to work from.
  5. Devileyezz

    Devileyezz LI Guru Member

    Oh, sorry, I apologize for not even mentioning that basic thing.
    WEP and no encryption connects just fine!
  6. HennieM

    HennieM Network Guru Member

    Something to try: On Vista, delete your wireless network's definition. On XP this is in the "Properties > Wireless Networks" of the wireless adapter, but I forget where in Vista. Make sure your Tomato is set up for WPA(2) or whatever scheme you want long term, the first time you reconnect to it.

    This way you force Vista to rescan networks, and re-ask for the authentication keys. Win seems to store the authentication keys somewhere, and then when you change authentication scheme for instance (like from WPAx to WEP), it gets all confused.

    Your problem may not be due to Vista only. The Intel adapters also have a mind of their own. The above fix usually solves it.
  7. LLigetfa

    LLigetfa LI Guru Member

    I don't use Vista (hate it with a passion) but have run into issues on XP where the Intel software would not let go of the wireless profile so I could not delete it. This was happening when I was flip flopping between dd-wrt and Tomato and using the same SSID. I think the Intel software was hanging onto the BSSID. What I ended up having to do was to setup a second AP with another SSID (and obviously a different BSSID), connect to it, and then delete the problematic profile.

    I've run into this issue as well when playing with different security settings while keeping the same SSID and BSSID.
  8. Devileyezz

    Devileyezz LI Guru Member

    Thanks, Hennie.
    I've done this earlier, infact even did a full "Recovery" using the CD. And right off the bat, the first connection to the AP didn't work. This is from a fresh install.
  9. Devileyezz

    Devileyezz LI Guru Member

    This sounds like a good idea.
    Can I change the SSID to something else, maybe change the channel and then try connecting to it?
  10. LLigetfa

    LLigetfa LI Guru Member

    Do you have a spare router you can test on? The problem with changing SSID is the BSSID stays the same.

    I don't need two routers for coverage but I like having a spare for testing/playing.
  11. Devileyezz

    Devileyezz LI Guru Member

    Unfortunately, I don't.
    But I have a Tomato at my office, I could go try it there I guess. Totally different settings with WPA.
  12. Devileyezz

    Devileyezz LI Guru Member

    My friend, your suggestion worked!
    I tried connecting the Vista to the Tomato at the office set as WPA/WPA2 Personal, WPA Personal, and WPA2 Personal. It connected to ALL of them!

    So, I'm guessing it's to do something with Tomato at home?
    Help, please!
  13. LLigetfa

    LLigetfa LI Guru Member

    Maybe it's time to erase NVRAM and reflash. Do not restore from backup.
  14. Devileyezz

    Devileyezz LI Guru Member

    I will do that.
    Just one question, coming to think of it, I'm not sure if I flashed Victek's mod before or after the troubles. You think it could be that?

    Could you also confirm about the erasing NVRAM in a step please, because I don't want to mess it up.. :S

    1) Go to Admin -> Config -> Restore Default Configuration -> Erase all data in NVRAM (thorough) -> Ok.

    2) I have no idea what happens next.

    PS: Funny thing is, My wife's EEEPC with Xandros connects to it just fine, heh
  15. LLigetfa

    LLigetfa LI Guru Member

    Yes, for step #1
    For step #2 you could keep the current build and try just setting up all the options by hand or you could reflash first. If you reflash, erase NVRAM again after the flash just to be safe.
  16. Devileyezz

    Devileyezz LI Guru Member

    Does it give an option to reflash? (Which I'm guessing is reuploading the WRT54GL.bin?)
  17. LLigetfa

    LLigetfa LI Guru Member

    You can do it one of two ways... Upgrade from the WebGUI or TFTP. I think TFTP is the best way.
  18. Devileyezz

    Devileyezz LI Guru Member

    Ok, I think I'll do the WebGUI, I loved this more about Tomato than anything else having to do the stupid things we had to do in DD-WRT.

    Thanks a lot for your help so far. I'll keep you updated.
  19. Devileyezz

    Devileyezz LI Guru Member

    LLigetfa, you are the man!
    Thank you so much. I did what you asked, and I'm typing from the laptop now!

    I was about to go all nuts on Asus for this.

Share This Page