1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VPN: Is this normal?

Discussion in 'Tomato Firmware' started by gregg098, Dec 23, 2008.

  1. gregg098

    gregg098 LI Guru Member

    Im using Tomato 1.23 w/ the VPN gui version and have the VPN setup as follows:

    TAP, UDP, Port 443, Static Key, Default Encryption, Compression enabled.

    In the other boxes, I have only the static key box filled with my key. As for server startup, I have an init script with sleep 40, then the server start command.

    Here is what my logs show however:

    This seems to just repeat over and over. The one line:
    Dec 23 10:21:41 Main daemon.warn openvpn[942]: NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables

    Also seems like a problem. I have not changed any other vpn settings other than what I described as my setup. Why does this keep repeating and what does the error mean?

    Thanks
     
  2. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    You can ignore the script-security message.

    Sounds like the pings aren't making it through the tunnel, so the keepalive assumes the connection has gone down. I'll have to look into this more later.
     
  3. gregg098

    gregg098 LI Guru Member

    I have not been on any other networks to be able to test the vpn connection yet, but I never saw this information when I had the GUIless VPN version.

    Thanks for the help.
     
  4. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    If you are referring to the script-security message, I think it was only added in the last couple of OpenVPN rc versions. It is a change in behavior from earlier versions, so they apparently wanted to make sure everyone knew about it. You aren't trying to run any "user-defined scripts or executables" so it doesn't apply.
     
  5. gregg098

    gregg098 LI Guru Member

    OK, so Im at work and trying to connect to my VPN at home. When I try to connect, I get this error over and over:
    For my VPN client, Ive tried two different settings. The first is what Ive used for a long time with the other VPN builds.
    The second is as follows which I got from this forum:

    I get the same error with both. My WRT54GL is setup as mentioned in my first post. Any ideas?
     
  6. gregg098

    gregg098 LI Guru Member

    Another update:

    I switched to TCP as per this post, and it connected just fine.

    I have no restrictions on ports at work so that is not the issue.
     
  7. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    This is very curious. There is nothing is my layer of code that cares UDP vs TCP (other than naming the right one in a couple of places), so maybe there is a bug in OpenVPN-2.1rc15. If there isn't a new version after the holidays, I'll make you a special build with an older version of OpenVPN to see if the problem goes away.
     
  8. dopee

    dopee LI Guru Member

    I think I have exactly the same problem.
    Although I was able to connect to the VPN via UDP, changing protocol to TCP stopped throwing out log entries like gregg098 posted...
     
  9. gregg098

    gregg098 LI Guru Member

    I still have problems with UDP. Only TCP works for me for some reason.
     
  10. occamsrazor

    occamsrazor Network Guru Member

    I am having the same restarts every minute or so as you are getting.....
     
  11. SgtPepperKSU

    SgtPepperKSU Network Guru Member

    Sorry I haven't made a new release with a downgraded OpenVPN yet. After the holidays I was busy until I went on vacation, then had to catch up from being on vacation, then got sick. Excuses, excuses, I know, but I will try to get one out soon.
     
  12. gregg098

    gregg098 LI Guru Member

    Slacker... Just kidding. You're the one doing us all a favor so no sweat. My life doesnt hinge on your releases :)

    And thanks for your contributions.
     

Share This Page