1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VPN Problems

Discussion in 'Tomato Firmware' started by gregg098, Jul 9, 2008.

  1. gregg098

    gregg098 LI Guru Member

    I am trying to get VPN with Tomato working, but have been unsucessful so far.
    My setup is as follows: Three WRT54GL's. One main one, and two others (.2 and .3). These two are connected via Cat 5, Lan port to Lan port. .2 and .3 routers are in router mode, DHCP disabled. Everything works great through them. Now, I want VPN on the .3 router. With DDWRT, I just port forwarded 443 udp to that router and did the setup like normal. Worked great. With tomato installed, I get the message in my VPN log:

    Tue Jul 08 17:02:16 2008 read UDPv4: Connection reset by peer (WSAECONNRESET) (code=10054)

    Over and Over again.

    To save space, my VPN scripts are exactly like Splats post in the VPN mod thread for the router as a server and then connect via PC except I changed to ip address and port numbers and obviously the dyndns host to connect to. Ive tried everything I can think of, and I just keep getting that connection reset by peer message. When connecting that router to my cable modem, however, and setting those settings accordingly, it works. It just does not work in my configuration. Is there some reason I cannot connect to the VPN in this method? Is there some special configuration?

    I do not want the VPN server on my main router because it will be under heavy user load anyways so Id like it to have more stability.

    Anyone have any ideas?


Share This Page