1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

VPN server setup pptp

Discussion in 'Sveasoft Firmware' started by Pye, May 8, 2005.

  1. Pye

    Pye Network Guru Member

    Anyone got a walkthrough on setting up my wrt as a vpn server?
    Alchemy final.
    I'd like to allow 2 way traffic: work lan to home lan and viceaversa.
    both lans are WRT54G runningg alchemy final. dynamic dns addresses. using dyndns service. I would like to use remote desktop or better yet, ultravnc over the vpn.
    I have no idea where to start.

  2. carlp

    carlp Network Guru Member

    I have tried the alchemy "Final" version to use my WRT54G as a VPN server, but I can never connect.
    I have tried everything noted on this site.
    Has anyone had success? If so, what are all of your related settings????
    I enabled PPTP Server using the correct CHAP username/password format, the internal router IP is the IP for the PPTP server, I have tried disabling Loopback, PPTP passthrough, 1723 port forwarding, client side settings in XP Pro VPN connection, etc.
    It never gets past Connecting..
    Then Error: 800
  3. DocLarge

    DocLarge Super Moderator Staff Member Member

    If you're getting error 800, that means that encryption between the client and the vpn server are off; I can't remember whether or not Alchemey supports MS-CHAP2 (or MS-CHAP for that matter). CHAP puts your business out across the internet. But I digress...

    Check out this link:


    Although you're not connecting to a 2000/2003 server, the error looks similar.

    FYI, I tried setting up Alchemey on my WRT54G for vpn until I finally realized you can't make a pinto run like mustang; I ended up buying a real vpn router (WRV54G) and cut my losses with that experiment. Incidentally, you can get an smcbr18vpn 8 port wired router from newegg.com for $78 and it has 5 built-in windows capable vpn clients, 40 tunnels, configurable for PPTP, L2TP, IPSEC; I bought one and I don't regret it. I had a spare wireless router that I hung off it as an access point so I can manage it and now I have two functioning vpn devices:


  4. Pye

    Pye Network Guru Member

    I have a WRT54G on both ends, each behind a dedicated linux firewall (also hosting a few persistant ipsec vpns.). I can connect via WinXP pptp easily from either end. Is your router behind a firewall? If so, you'll need to forward port 1723 AND gre protcol 147 (I think, I'll have to check the #)

    does your secrets look like this:

    username * password *

  5. carlp

    carlp Network Guru Member

    Yes, my secret looks like that.
    My WRT54G is connected directly to my ISP behind my DSL modem which is setup as a bridge to pass a real internet IP to the WAN port of my router. I am just trying to make one VPN connection to this router from the outside. Seems this function doesn't work with Alchemy "Final".??
  6. Pye

    Pye Network Guru Member


    It does work, that I know. I used it alot (and still do occasionally) before I set up a permanent vpn.

    Have you tryed unchecking 'use default gateway on remote network' in the tcp/ip properties of your client connection?
  7. Pye

    Pye Network Guru Member

    Oh, and one more thing:

    are you connecting by ip address" if so, is it static?

    or are you using a dynamic dns service? if so, you'll have to set it up on the router.
  8. carlp

    carlp Network Guru Member

    Yes, I have unchecked 'use default gateway on remote network' on the XP Pro client and I have a DHCP address that is set using dynamic dns, but it also fails using the actual IP address. I can now get to verifying username and password because I realized I setup the VPN DHCP range wrong. But, now it just hangs at Verifying Username and Password. I tried forwarding port 1723 to the router's LAN IP and I tried disabling PPTP passthrough, and disabling Loopback. My secret is correct: myusername * mypassword *
    What settings did you use to make this work?
    I also tried just about every possible XP Pro vpn client setting too.
  9. carlp

    carlp Network Guru Member

    It works!

    I can actually establish the VPN connection after all.
    The problem was that I was trying to connect from where I work and they apparently don't allow 1723 to come back in I suppose for the authentication to succeed.
    The VPN works fine if I connect from my laptop Sprint wireless card.

Share This Page