1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG200G way to slow

Discussion in 'Other Linksys Equipment' started by ctgilles, Dec 8, 2007.

  1. ctgilles

    ctgilles LI Guru Member

    Hi,

    Because of the reputation of Linksys and my experiences with their networking equipment, I decided to get me a WAG200G for wireless and PSTN ADSL.

    But major problems concerning speed :( I have a Thinkpad T43p with Intel Wireless 2200BG (newest drivers) and Windows XP Home (had Vista Premium until a week ago)

    My network is encrypted WPA2 AES and is on channel 11. Neighbours have channel 6 but I don't have interference.
    Now with my 802.11g, speeds were slow and not constant for internet. And certainly not for Windows filesharing or FTP. Maximum 200-400KB/s :thumbdown:
    Now with my laptop wired and the desktop (stick: WUSB54GC) I can get a maximum of 1600KB/s. Still not up to what it should be, even taken into mind that g is NOT full duplex......

    I tried:
    • Getting rid of Vista now using XP: no change
    • Update fw to 1.01.06 beta: no change
    • Change channels: no change
    • wiring laptop: still only 1600KB/s (13Mbps)
    • No encryption: no change
    • ...

    I have no idea what's causing the problem. My laptop can easily get up to 2.2MB/s over at a friends 20Mbps wireless cable router. At school I can manage over 1MB/s on the WEP g and 802.11x.
    I am really bummed out because I need the desktop's DVD-RW unit to burn DVD ISO files. And with a throughput of 1600KB/s... Well it's too slow... What can it be?!

    Router is standing 1-1.5m from desktop and laptop and has perfect (54Mbit connection). Also, Windows has all updates and wireless patches (like the one for WPA2)

    Regards,
    Gilles
     
  2. ReDFlaG

    ReDFlaG Network Guru Member

    hello,

    i've a T40 and T43p. I had the same issues that you have: slow speed, lost of connection. I moved to vista then different linux distros to check if the problem was coming from a "system" point of view. It did not fix anything.

    It it between the 2200BG and the linksys' routers (got the same issue with a WAG54G v2). I now use a WPC54G pcmcia card and all of those troubles have disappear (xp, linux or vista)

    Regards.
     
  3. ctgilles

    ctgilles LI Guru Member

    Well, I was thinking in that direction because with other clients it works ok and my 2200BG performs excellent with other AP's. It's a shame though :(
     
  4. fits79

    fits79 Guest

    Why after 2 - 3 days it bring me this outrageous downstream margin??
    I have try all the firmwares(1.01.03,1.01.04,1.01.05,1.01.06beta, 1.00.03....)
    But the problem still remains.
    Have anyone solve this prob and if it do how exactly do that?

    A lot of thanks.
     
  5. mstombs

    mstombs Network Guru Member

    The silly number for downstream margin is due to software bug in the Ti atm driver code, it is outputting a negative number as an unsigned integer. But it means that you have a wiring problem, something has changed since the modem has synched. Normally downstream attenuation is double the upstream, your ratio is much higher. Try the "isolation test" plugging the modem directly in a master telephone socket without filters or extension wiring and see if the problem is within your house.
     

Share This Page