1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG54G - Annex B firmware

Discussion in 'Linksys Official Firmware' started by ja_cek, Apr 18, 2005.

  1. ja_cek

    ja_cek Network Guru Member

    Does anyone use/tested firmware for WAG54G Annex B router?
    I'm exeriencing problem with ADSL connection, it's unavailable (led is red) or sometimes led is green but internet and router configuration page could not be accessed. I did some test and tried latest firmware published on linksys ftp but upgrade doesn't help. I also suspected quality of my provider but I tried my friend's router (pentagram cerberus) and it works really good.
    Any advice welcome
  2. askamat

    askamat Guest


    some clarifications first:

    1. Are you using WAG54G v1 or v2? (see that on bottom of router)
    2. Which firmware are you using?
    3. Latest firmware for WAG54G V.1 Annex B is available on ftp://ftp.linksys.com/international/firmware/WAG54G-DE_AnnexB_ETSI_v1.02.7_03_code.bin.

    4. Be sure that if you try to apply this firmware you are connected via an Ethernet port on your WAG54G.

    5. Follow instructions contained on the downloaded zip file.

    6. Having upgade the firmware, reset the modem to its factory default settings, as some stored parameters are not compatible to the new firmware.

    7. Reconfigure the modem.

    Hope this will work for you. :thumbup:
  3. JGHink

    JGHink LI Guru Member

    Sorry, but what is Annex B..? I could do with a firmware upgrade for a wag v2, but not sure what is Annex B?
  4. Wouter06

    Wouter06 LI Guru Member

    annex a/b:

    a => analog/pstn
    b => isdn
  5. jack7447

    jack7447 Guest

    WAG54G V2 help!

    I am trying to get the WAG54G V2 to connect to MSN Messenger and some (not all) web sites. I cannot connect to microsoft at all. No updates, email times out on ISP, yet i can go through mail2web and get email from server. ISP can see me connected, i can see emails on server, but it times out. I have read endless problems with this WAG54G V2 so do i upgrade firmeware? Where do I get it as Linksys don't have it. I am running 1.00.19 firmware now.

    Any help is appreciated. I am ready to throw it as I cannot return it to the store. Linksys sucks as far as i am concerned, Tech support when cannot answer problem leave you hanging on line.

Share This Page