1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG54G-UK & DHCP problem

Discussion in 'Other Linksys Equipment' started by FatManUK, May 10, 2005.

  1. FatManUK

    FatManUK Network Guru Member

    Hi folks,

    I've got a v1.2 WAG54G running 1.02.7 firmware. I tried 1.02.9 briefly but it seemed unreliable (don't recall why now, it was a while ago) so reverted to 1.02.7. Anyway, for the last 24hrs or so the WAG54G won't allocate IP addresses. I can get internet access via ADSL if I manually choose an IP address, but if I set WinXP to obtain one automatically it takes the address

    Is this a known bug? I tried switching the WAG54 off over night (normally it's on 24*7) but that didn't help. Is it worth trying 1.03 beta-4? Or, is my router shafted?

    thanks... :)
  2. dribble

    dribble Network Guru Member

    Firmware versions...

    I have tried all of the versions going and have always been able to get dhcp working. I take it there is a reason why you are trying to run DHCP (lots of PCs or people come over to use your connection?)

    If you only have a few wouldnt it be more advisable to run static addressing (gives a little bit more security, along with the added potential functionality - file/printer sharing)


  3. FatManUK

    FatManUK Network Guru Member

    Hi Lee. No, I've not tried every version going. I'll try the 1.03 beta-4, assuming it's the most recent.

    Disabling DHCP wouldn't be a major problem, just a minor inconvenience. The router is bolted-down with encryption, small range of allocated IPs, MAC-filtered etc, so if it's possible to 'fix' the apparent DHCP problem I'd rather do that first.

    I've never had a persistent problem with DHCP from the WAG54G. On the one or two occasions it did play up, a quick power cycle resolved it.

    If I need to use static addressing, I'll do so but I'd still have a nagging doubt that the WAG54G was faulty in some way.
  4. modrisco

    modrisco Guest

    Think I’ve got the same DHCP issue.
    I have DHCP issue over the WLAN as DCHP via the switch is working - WAG54G V1.2 (1.03.0 Beta4).

    I have used a Protocol Sniffer to try and trouble shoot and have found the WAG54G just doesn’t respond to the DHCP request via the WLAN. Powering down the WAG54G temporality solved the problem for me but the fault reoccurs.

    As I’m not prepared to power down the unit every hr or so my work around (while I await a V2 replacement unit that might be another mistake) is to configure the Alternative Configuration Settings for the TCP/IP manually.

    So when the DHCP works everything is assigned automatically just as you expect/want – but when that fails (basically all the time for me over WLAN), rather than let Win XP assigning a unrelated network address 162.0.x.x or something the (manual) Alterative Configuration Settings should be invoked.

    Someone out there is going to say why not just set it all up manually – you’re doing that anyway by default. My response is sure you can do that – but why then did we invent DHCP. Once all your house hold devices become WLAN enabled (Stereo/TV/VCR/Fridge/Microwave/Dishwasher) you’ll see why DCHP is required.

    Anyway once Linksys (I’m forever the optimist) fix the firmware - DHCP will work right fine.

    Tip: You can tell if the alterative configuration has been instigated by viewing the connection status information for the particular connection you’re using.
  5. FatManUK

    FatManUK Network Guru Member

    The problem is that nowadays I don't have the time to try every permutation of setting and firmware available. It should 'just work'. My Netgear kit arrives tomorrow and the WAG54 is going on eBay. Let's just hope I'm not jumping from the frying pan into the fire!
  6. Joeykins

    Joeykins Network Guru Member

    try switching UPnP off

Share This Page