1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG54G v1.02.3 AnnexA/B

Discussion in 'Other Linksys Equipment' started by Toxic, Jul 25, 2004.


Firmware Functionality

  1. Works very well

  2. Works well but some issues

  3. Works occassionally

  4. Serious problems but some parts work

    0 vote(s)
  5. Firmware crashes device

    0 vote(s)
  1. Toxic

    Toxic Administrator Staff Member

    v1.02.3 both AnnexA and AnnexB

    Firmware version 1.02.3
    - fixed disconnect issues?

    Firmware version 1.02.1

    - Added "Remote Upgrade" UI
    - Fixed issue with Nortel VPN clients not being able to connect to Gateway using certificates
    - Fixed disconnection issue during large file FTP download when using IPSec passthrough(UDP)
    Note: If after upgrade you have problems with disconnection on the wireless, it may be necessary
    to restore the unit to factory defaults and set it up again to solve this problem.

    Firmware version 1.01.7
    - Fixed Intel UPnP issue
    - Fixed port forwarding bug

    Firmware version 1.01.5
    - Updated Modem driver

    Firmware Version 1.00.7
    - Initial release
  2. yonnage

    yonnage Network Guru Member

    missing firmware

    Simon, there is also firmware versions 1.01.6 and 1.01.9. dont know release notes though
  3. yonnage

    yonnage Network Guru Member

    new firmware 1.02.5 (beta)

    new firmware available, but not released on ftp. it is 1.02.5. notice logging is broken on it. just wonder if anything else is
  4. komUnec8

    komUnec8 Network Guru Member

    New firmware v1.02.7 Annex A and B released, and A seems to be working well, at least for me!
  5. Ben119

    Ben119 Network Guru Member


    I'm planing to install firmware 1.02.6_FR (in French). Since it's a beta version I'm not sure it's a wise move... Any feedback on this firmware ?

    Also, if I have too many problems, can downgrade to an older firmware version ?

    Many thanks in advance !
  6. martymcr

    martymcr Network Guru Member

    Linksys WAG54G - Firmware 1.02.7_3

    Version 1.02.7_3 - Problems experienced with this release:

    1. Single port forwarding doesn't work - have to use both single and port range forwarding to get it to work.

    2. Wireless suffers random disconnects. Frequency of these disconnects can be reduced by setting the "beacon" setting to 50 instead of the default of 100.
  7. Ben119

    Ben119 Network Guru Member

    Many thanks for your reply !
    I have installed the 1.02.7 (English) directly.
  8. Bobo

    Bobo Network Guru Member

    I have just installed firmware 1.02.7 which seems to work fine. I have completely reset the box. I have also switched BACK on the firewall. This is working fine now. This was NOT the case with the previous firmware 1.02.5. Since I've installed that version I had to switch of the firewall completely. Now it's running fine with the 7 version.

    Although: so far so good since it's just an hour ago I have installed it.
  9. Ben119

    Ben119 Network Guru Member

    It's been almost a month now with 1.02.7 and it works fine.

    I've just had a few problems when power was cut by mistake and the modem would not dial anymore. I reflashed with latest version and everything went back to normal.
  10. KoP

    KoP Network Guru Member

    Re: Linksys WAG54G - Firmware 1.02.7_3

    I had the same issues. But I did´nt change to 50 the "beacon" setting. Maybe it was that. I can´t believe why linksys doesn´t take off this product from the market.
  11. Taurus

    Taurus Network Guru Member

    No problems with the latest version.
  12. fighne

    fighne Network Guru Member

    version 1.2.507

    I have recently flashed the firmware version 1.2.5_07 annexe A onto a wag54g v1.0 with no issues I'm using a Compaq Presario V2000 for wireless connection and a Cobalt Qube on the switch ports.
    I'm looking at upgrading to the version 1.2.7_03 anybody have any experience with this?
  13. MagsS

    MagsS Network Guru Member

    where can i get this firmware please?
  14. Toxic

    Toxic Administrator Staff Member

  15. bulla80

    bulla80 Network Guru Member

    Cant upgrade firmware

    Hi guys when I try to upgrade my firmware on my WAG54G V2 from 1.00.19 to WAG54G_AnnexA_ETSI_v1.02.7_03_code.bin or WAG54G_AnnexA_ETSI_v1.03.0_beta4_00_code.bin I get the "Upgrade is failed" page, can somone tell what is wrong and how I can go about fixing it??
    Thanks in advance.
  16. Ghost_pt

    Ghost_pt Guest

    that's because that firmware is not for your router

    you have WAG54G V2 ...

    that firmware is for WAG54G ... not the same

    File: WAG54GV2-AU_AnnexA_ETSI_v1.00.39_000_code.bin
    File: WAG54GV2-EU_AnnexA_ETSI_1_00_19.zip
    File: WAG54GV2-FR_AnnexA_ETSI_1_00_19.zip

    in ftp://ftp.linksys.com/international/firmware/
  17. jocomomola

    jocomomola Network Guru Member


    is it it possible to load the different firmware versions (e.g. the german _DE_ version, the Annex A and B versions) on the router ?

    Are there any hardware differences in the routers sold in different countries ?`

    My specific problem is, that I need a router which works in spain (ADSL via POTS) and in germany (ADSL U-2R). If I can solve this problem with a firmware change, this will be very helpful !

    Anyone with experiences concerning this issue here ?

    Kind regards

  18. Vook

    Vook Network Guru Member

    I have Annex A V1 router bought in France. But I use it in Russia.

    I'm tired of 'Port forwarding disconnection issue', but...

    with any firmware after 1.01.7 (1.02.x, 1.03.x) router cannot establish connection with PPPoE server. ADSL link is up but connection is down.

    Can anybody help me understand and correct this problem?
  19. Piske

    Piske Network Guru Member

    Hi... I've wag54gV2.. firmware 1.01.01..... .... i don't understand if there is a new firmware... someone can give me a link??? thanks a lot
  20. turkish

    turkish Guest

    try it with empty service name.

    It is working on TTNET at TURKEY.
  21. djarema

    djarema Guest

    i have the same problem like VOOK

    I use the WAG54G (Annex B Model) with Firmware 1.01.7. and it works. (Router getting very hot on the top, i think there is a Problem with the Wireless Card in the Router, but this is not the real problem)

    When i update the Firmware to a newer then 1.01.7... i've see the message "can't connect to PPPoE-Server.
    I need the firmware 1.02.7 - because it has WDS support
    The firmwareupdate load sucessfully, but when ever i try, the message "can't connect to PPPoE-Server" is showing.

    The VCI and VPI Value are right (answer from the support of my provider)

    Have anyone a idea for me ?
  22. smughead

    smughead LI Guru Member

    Annex A and B?! Help!

    :) Hi,

    I have tried to Download the Latest Firmware from the linksys site, but it says that version 1.00.19 is the latest firmware for the WAG54G V2 that I have.

    however, upon visiting the UK site, I found an update that might help me out. The problem is, there are 2 types: Upgrade for Annex A and Upgrade for Annex B..

    What is the difference and how do I know which one to go for? I have checked my device physically and it only says WAG54G V2. I have also checked the GUI but still says the same. Please help.

    Second Question: Will this the firmware update help me solve my problem? My router drops the wireless connection after some time if my laptop is wireless, and LAN is dosconecting and reconnecting every couple of seconds?

    Appreciate your reply TOXIC
  23. vieuxtemps46

    vieuxtemps46 Guest

    I also suffer from random wireless disconnect. Can only fully agree with you why Linksys has not taken it off the market. It is the worse product I ever use as wireless router.
    I got an Asus WL500G, works perfectly. Now I need the WDS function with Asus and use WAG54G as main router :-(.
    Will try with Beacon 50, hope it will fix the problem.
  24. waxmund

    waxmund Guest

    hi, i've got wag54g. which firmware should i use?
    1.03.0_beta4 ? (give me link plz, cause i can't find it anywhere.... :D)
    currently i'm using 1.02.7 and i got many problems with it....
    every 10-20 minutes i'm unable to browse www pages, but connection is still up (emule/msn still works).
  25. sokettro

    sokettro LI Guru Member

    wag54g 1.03.0_beta4 firmware

    Here is the link for the http://hosting.toshib.fr/wag54g/firmware/unofficial/WAG54G_AnnexA_ETSI_v1.03.0_beta4_00_code.zip make backup and use ethernet interface for flashing, not wi-fi, because you will loose the flashing process and the router. I have a router like this and since i have flashed with this version, i had not any problems. The only problem is the over heating of the wi-fi module from the inside, so you have to keep it, the router, on a adapted place, to prevent the freezen of the conection, because of the over heat of this.
    My english is not so good but ive talked from my expirience.
    Good luck.
  26. HiSpeed

    HiSpeed Network Guru Member

    There is a major trouble with the display of menu on the WAG54G 1.x with all the firmware versions.
    That comes from the page design due probably to a non open source coding...
    The trouble increases when using a firewall (like ZoneAlarm, etc.) which slows down the display...
  27. sokettro

    sokettro LI Guru Member

    Right. Another good procedure, is to eliminate the firewall from ther router, and other security settings, and keep any other firewall software, on the computer. This procedure will take off any interferencing security modules, between your computer and the internet network. I don't have any problems with the router, no web traffic disconnect, no internet adsl disconnections. The only problem wich remain is the over heating, but if you will put the router on a vertical way, the temperature dissipation will increase in reasonable conditions.
    Good luck.
  28. NoWaYsA

    NoWaYsA Addicted to LI Member

    can any body put this file
    WAG54G v1.02.3 AnnexA/B

    bin format

  29. HiSpeed

    HiSpeed Network Guru Member

    Here it is !

    But it's not the best one !

  30. NoWaYsA

    NoWaYsA Addicted to LI Member

    sorry i have wag54g V2 with 1.02.00 firmware
    what is the best for it?

  31. HiSpeed

    HiSpeed Network Guru Member

    If you have a WAG54G v2.0, your firmware version is the best I know.
    However, there is a more recent version : here , but I didn't test it yet...

Share This Page