1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG54G v2 disconnecting when playing mmorpg

Discussion in 'Other Linksys Equipment' started by edyed, Jul 15, 2005.

  1. edyed

    edyed Network Guru Member

    Hi, i've just purchased a WAG54G v2 wireless router 2 days ago and am new to this stuff, but managed to set up the internet on it so that it works mostly fine on surfing, downloading etc, but the main reason i use the internet is for playing online games, namely one called Lineage.

    The weird thing is that when i try to play this game i can log on then between straight after logging on and 5 minutes into playing, my connection freezes up for about 10 seconds, then the the router disconnects and reconnects, making the game unplayable, ive noticed that if i minimize the game i can open internet explorer in the 10 seconds before i am disconnected and it will unfreeze the connection and i wont be kicked off the internet or the game, but it will repeat every 5 minutes or so.

    This is highly annoying and i have searched for hours for an answer with no success so i decided to post here and see if anyone could help...

    I have contacted linksys several times by phone and opened the ports for the game in 192.168.1.1 which did nothing to help, any suggestions please?

    Note: this only happens with the game, if i am surfing in any other way i stay connected indefinitely
     
  2. ReDFlaG

    ReDFlaG Network Guru Member

    have you set "keep alive : redial period" to 20 sec?

    try to update your firmware : 1.01.01 is the latest beta, but i use it and it works great.

    Try disabling the firewall and/or block wan request just for testing (because it's insecure) and see if this correct the problem.
     
  3. edyed

    edyed Network Guru Member

    It still doesnt work if i disable firewall in 192.168.1.1, i have that version of firmware and am set to keep alive:redial period 20sec, but i also use zonealarm(all lineage prompts are set to remember: allow) and win Xp sp2 if that is important.

    i dont know how to block WAN request i looked for it but cant find...
     
  4. ReDFlaG

    ReDFlaG Network Guru Member

    you should try to disable ZA and only use the firewall of the device.
     
  5. edyed

    edyed Network Guru Member

    ok, tried that and still doing same thing to me
     
  6. ReDFlaG

    ReDFlaG Network Guru Member

    You said that if you have a net activity (IE) with the game minimized then the problem does not occurs?

    did you tried p2p network and download something legal (but big enough) on it like a linux distro just to make a try and see if multiple simultaneous connection does not drop down your connection. (kind of what it should be with your game)
     
  7. edyed

    edyed Network Guru Member

    I have tried with MSN messenger and it didnt work(edit: i mean i still can minimize and 'kickstart' it, but unless i do its goodbye connection), and i think the game should really be doing it by itself, sending and recieving constantly otherwise i would just get lag...weird and i think ill have to spend a 3rd day trying to fix it tomorrow now :cry:
     
  8. Ofloo

    Ofloo Network Guru Member

    i think linksys wag54g doesn't like udp.. apparently it crashes everytime i play css, or it reaaaaaaaaaaaaally lags a lot when it doesn't crash..
     
  9. ReDFlaG

    ReDFlaG Network Guru Member

    i play warcraft III without problem and it uses udp
     
  10. Ofloo

    Ofloo Network Guru Member

    well i use that latest version .. i don't know if it is beta or not but... anyway, everytime i play cstrike css, i get disconnected.. that really seems weird to me.. because before i used to have no problems with this and my router (dlink-T504) is god of the bad routers, it disconnects like every 4 hours then u got to do a hardboot ..

    so that router even managed to stay online so something defenatly is wrong in the firmware when playing that game !!!! and because it uses udp .. i can't think of anything else but.. that hmm.. well it has to got to do something with that,.. either it is some weird packet steam sends.. but the router shouldn't disconnect .. eitherway they game may crash my computer may explode but the router should still function.. as it should
     

Share This Page