1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG54G v2 Major FTP problems

Discussion in 'Other Linksys Equipment' started by manonfire, May 7, 2005.

  1. manonfire

    manonfire Network Guru Member

    Hi Guys, really need some help here as I spent allot of time last night on this forum trying to find an answer, also all day trouble shooting with linksys, my ISP etc...

    My Spec:
    Linksys WAG54G v2
    Bios: 1.00.19 UK.
    ISP: Pipex ADSL Business account with static IP
    2Mb line, 512Mb upload.

    ISP FTP Sever is 100% working with no problems.


    Problem.
    Well, all is well on the internet side and WIFi works a treat.
    The only problem is that when I try and upload via FTP, using any FTP software, it all grinds to a hault. EG: I connect to my ISP server to upload some files, it reads that I am uploading, but its speed start at 23kbps and then drops to 0.9kbps, also if and when the file uploads, its file size reads "0" size?

    I have no VPN activated on the WAG54G, all FTP ports are open, tried deactivating the firewall etc and still no joy. Linksys are saying that this could be a faulty unit... some how I got a bad feeling thats its not just a faulty unit, but a fault in all WAG54G's....

    Please can someone make some suggestions.

    Cheers.
    Neil.
     
  2. DocLarge

    DocLarge Super Moderator Staff Member Member

    What's going on, Neill?

    Firstoff, although you and I know using explorer isn't the most secure way of moving information to an ftp site (because the password is transmitted in cleartext) can you at least get anything to upload going from I.E. to your server? The only thing I noticed with my WAG54G (before I went back to using my WRV54G) was that there was a slow response time when making the connection through I.E. and WS FTP PRo (ftp pro is my client I use with my WS FTP Server application). When I switched to the WRV, the connection was instantaneous through I.E. and ws ftp pro.

    I think the issue you may be running into is the processor speed of the WAG. I've noticed this firsthand. Additionally, I had someone try and utilize an "ftpget" command from an application he uses to to extract a file from my ftp server and then put it into a different location on the server from his location 10 miles away. This action timed out when done via the WAG54g, however, when I put my WRV54G in place immediately afterwards, the process went through without fail.

    Hope this gives some insight...

    Doc
     
  3. manonfire

    manonfire Network Guru Member

    Hi Doc...

    Thanks for the reply, actually I have tried WS-FTP Pro, Coffeecup FTP all with the same results.. its now got to a stage that I may have to go away from a WAG54G because its really Cr*p!

    How can this unit fail so badly?

    Like I said, once I connect to my ISP's FTP server for an upload, (which is an instant)... its seems like it just struggles to uload even a 35k file... starts the upload, 20kbps, then goes right down to 0.6 etc within 5 secs... I have also tried uploading to another ISP, same results.

    I must be doing something wrong!

    :eek:(
     
  4. sirmac

    sirmac Network Guru Member

    Hi

    I have the same problem. I have found that using Cute and Wise ftp clients connected with no problem, but then the files fail to upload after a couple of kb (The file names are visable on the remote server but with low file sizes). I found that disabling my personal firewall (zonealarm) would allow everthing to work fine.

    I also use a photo image program called ClicPic that has a ftp file uploading program integrated in it. It has no problems at all with zonealarm running. So this seem to rule out a processor problem with my router. Someone on this forum suggested putting my ftp server ip address into the trusted zone of zonealarm. I haven't tried that yet as I wasn't sure if this compromised my security.
     
  5. DocLarge

    DocLarge Super Moderator Staff Member Member

    Hmmm, my father always said if I were going to pull something out of my azz that could be useful, it would help if I stood up (I'm standing now..). Okay, check your MTU. By default (if I remember correctly), the wag mtu is 1492. Try dropping it to 1350 or 1300 (this will "slightly" affect your page refresth times) to see if you're having packet fragmentation. Look at it as your ftp server having a doorway designed for people who are 5ft 5in yet your packet is equivalent to a person who is 6ft 6in.

    Try that...

    Doc
     
  6. DavidC

    DavidC Network Guru Member

    Hi - just a bit of comparison info - thought I'd try ftp on my V2 as some seem to be problematic for some people.

    Result - it's busy uploading a file rock steady at max connection speed 31KBps. The router is set to default MTU and set for auto MTU selection. FTP done using WSFTP v9. (this was done using a LAN port not wireless)

    Sorry I can't suggest a fix as I don't ftp much and this seems to work OK.
    I have no port forward settings allowed for the WSFTP program Norton Firewall is in use and was set to permit full access to WSFTP.

    Have you considered saving your profile reseting the router to factory and then trying ftp after setting your isp connection details. Bit of a faff but worth a try I suppose.
     
  7. DeBois

    DeBois Network Guru Member

    Ok I had the same problem with my Linksys router WAG54G V2. I can't find the solution on WS_FTP though but in CUTE FTP, I use the work around to set it to PORT mode and it works !!!!!!!
     
  8. manonfire

    manonfire Network Guru Member

    hi Guys, thanks for all the feedback, how do I set up PORT MODE only?

    Thick question, I know... sorry
     
  9. jiauka

    jiauka Network Guru Member

    Hi,

    I have no problem on my WAG54G v2 1.00.19 , but i had in the past. Just change the MTU to a lower value (1300 i.e.) in your Windows Registry, NOT the router MTU. You can change it in the registry or use a software like http://www.dslreports.com/drtcp to do it.

    BTW, i use filezilla http://filezilla.sourceforge.net/ free and IMHO better than cuteftp.

    have fun,

    jiauka
     
  10. Jonny_H

    Jonny_H Network Guru Member

    Hi Guys,
    I work for a small software house and we always recommend the Linksys WAG54G to our customers, but since the version 2, we will not. We found this same problem, and after spending much time trying to figure out what was wrong with our software we narrowed it down to the new version 2 router. I contacted Linksys support and after I had to explain what passive FTP was, the guy had chat with a sensor technical support person and they said to just keep email them, and when they have a resolve they would reply

    I’ve now had an answer from them (if this is not indicating a major fault, then I don’t know what is).

    “Hi Jon,

    If you would like to try a version 1.2 router we can arrange for an
    rma so that you are able to get version 1.2 routers as opposed to
    version 2. If you would like to do this then please do not hesitate to
    contact us by phone.

    Best Regards “


    I’ve tested numerous versions of the same router and it’s only the version 2, which it affected with the passive FTP problem, however we have found that even POST FTP can be problematic.

    I’ve told Linksys that I can’t get involved swapping all my customers affected units and to pull their finger out and get a firmware released, even if it’s a beta. Still waiting for a reply, finger crossed they can resolve this.


    Jon
     
  11. DeBois

    DeBois Network Guru Member

    ok MANONFIRE, launch the Cute FTP then go to SITE MANAGER then go to the TYPE tab. The 3rd drop down box from the top should be "use PORT" I found this solution for someone in this forum way back. It seems to work for me. Don't ask me why !!!
     
  12. manonfire

    manonfire Network Guru Member

    Hi Guys,

    Want to say a BIG thanks to all those who have tried to assist.... but after several hours, days of pain I have decided to send tis heap of junk back and ordered a Netgear unit. I have always been a Linksys fan for several years, but I am just getting fed-up with the lack of support from Linksys etc....

    Its a shame, but here I come Netgear.

    Thanks again peeps.
     
  13. Jonny_H

    Jonny_H Network Guru Member

    Linksys will swap for a version 1.2 router for free, but you will have to cope with the poor wireless quality. Let me know which Netgear unit you get as I’m looking to replace a number of affected WAG54G units.

    P.S. anybody want to buy any unusable routers, thought not!


    Jon
     
  14. acarlo

    acarlo Network Guru Member

    Hello guys,
    I'm owner of a linksys wag54g v2 router and i had the same problem about to upload with ftp and firmware version 1.00.19
    After that i was talking with Italian linksys support they was sending me a beta version of firmware version is 1.00.47 that is solving this problem.
    Just what is wrong in this version is the DDNS service that is not good working.
    If someone want try this firmware can ask me and i'll send.
    Bye.
     
  15. Jonny_H

    Jonny_H Network Guru Member

    Hi Acarlo,

    Just been onto Linksys UK support and they deny all knowledge of this firmware, please send to jon.hoyle@demopad.com. Oh and then they hung the phone up on me, when I was pressuring for this version! It doesn’t matter about other functions at the moment, just need to get passive FTP working for a customer that’s the main thing.


    Thanks


    Jon
     
  16. acarlo

    acarlo Network Guru Member

    Now i'm in work so you need wait that i'll return at home to send you an email with this new firmware, as i said you before it's working pretty good just is not going the DDNS service.
    Bye.
     
  17. Jonny_H

    Jonny_H Network Guru Member

    Thanks for you help.

    Just sent Linksys a very upset customer email.

    Thanks

    Jon
     
  18. acarlo

    acarlo Network Guru Member

    you an email with the new linksys firmware.
    Bye
     
  19. Jonny_H

    Jonny_H Network Guru Member

    Thanks acarlo,
    Passive FTP working, now

    Not tested other fuctions, yet.

    Thanks


    Jon
     
  20. Jonny_H

    Jonny_H Network Guru Member

    Italian Technical support are great, I copied them on an email that was sent to UK support. They replied (UK still not replied) and included a working firmware, and apologised on behalf of UK support. Suggest you email support.it@linksys.com if you expect decent answers and support.

    I told them that I’d been provided this firmware by a customer (thanks once again Carlo), but that how grateful I was for the prompt service.

    Jon
     
  21. acarlo

    acarlo Network Guru Member

    so is good that even you can be happy from this firmware.
    I was trying very much functions, even is working time, if you go to look your logs you'll find great time. Nat and trigging is good and the same is for the upnp just ddns has problem and is pity because is great future.
     
  22. Jonny_H

    Jonny_H Network Guru Member

    From Linksys regarding beta firmware version 1.00.47 004:

    Dear Valued Linksys Customer,

    Thank you again for contacting Linksys Technical Support.

    So far there isn't anything you need to be aware...
    The new beta one seems working fine.
    In any case, please contact us for any problem you or your customer
    could experiment.

    If you have further questions, please contact us by phone or send us an
    email, so that we may further assist you.
     
  23. acarlo

    acarlo Network Guru Member

    Sorry i didn't understand, they was sending you a newer firmware ?? 1.00.47.004 ???
    If yes, so can you send me ? Maybe is solving problem with ddns server.
    Thanks
     
  24. Jonny_H

    Jonny_H Network Guru Member

    Carlo,

    It's the same version you sent to me:

    WAG54GV2_AnnexA_ETSI_v1.00.47_004_code


    Regards

    Jon
     
  25. Jonny_H

    Jonny_H Network Guru Member

    Arie M


    Tried to sent you a email but was returned.


    Regards


    Jon
     
  26. acarlo

    acarlo Network Guru Member

    Jhon,

    You have a private message
     
  27. DevilWAH

    DevilWAH Network Guru Member

    carlo you have pm :)
     
  28. Jonny_H

    Jonny_H Network Guru Member

    Just to let anyone know, regaing this Beta firmware. I let linksys know about the problem Carlo reported with DDNS and they replied with:

    Dear Valued Linksys Customer,

    Thank you again for contacting Linksys Technical Support.

    I was reading the web site, Mr Carlo got the firmware from us... I'm going to test the DDNS features and I'll send a feedback to USA to
    get a work around or a new firmware...
    I'll let you know as soon as possible. Even in the forum of
    linksysinfo...


    Jon
     
  29. DevilWAH

    DevilWAH Network Guru Member

    if any one has a copy of this firmware could they let me have it please. i have PM carlos but jsut in case he not on for a bit
     
  30. Jonny_H

    Jonny_H Network Guru Member

  31. acarlo

    acarlo Network Guru Member

  32. Arie

    Arie Guest

  33. stealth

    stealth Guest

    annex_b beta ?

    arg :(

    You guys all have annex_a beta version of firmware i guess. I have same problem with my new WAG54G V2 Annex_b .

    I tried to upload something, but didnt work.
    Even tried to open ports, to be sure I did nothing wrong, but also didnt help ;(

    so..
    I hope those italian guys can make some annex_b beta's :)

    if some one has it allready plzz mail it to

    sijbe200@planet.nl
     
  34. DevilWAH

    DevilWAH Network Guru Member

    i found the beta firmware much better.

    still some stability issues but much better. still dosent like connectiong to msn while p2p is running. i think its still a upnp thing.

    i also cant get QOS working. just locks the whole thing up

    (mine you i not sure how to configer this correctly)

    cheers for the update though guys :)
     
  35. jimbo35

    jimbo35 Network Guru Member

    :cheering:

    Folks,

    Solved the issue with FTP on V2 the QoS is what causing the problem. Goto App & Gaming, enable and click on the

    Fragment packets' size of AF and BE traffic to be equal to the
    size of EF traffic : bytes.

    option. I've set the value to 500 bytes and all works even FTP and even MSN.co.uk my home page on IE comes back up
     
  36. mingwingming

    mingwingming Network Guru Member

    I am too having serious issues with FTP on this new router, why is it whenever i rush out and buy a product like this it ends up having problems !! GGGRrrrrr (my last router died after 2 good years of abuse!!)

    Jimbo35 I tried the QOS settings you speak of , but it made the uploads extermely slow speed like 1.5-3.5 , instead of before where it starts of at a good speed and then eventually grinds to a halt. Also the internet seemed to slow down with that setting ( I did try some different values but not much changed)

    I am so mad at the moment i can not begin to tell you, its 2.41am and I should have finished uploading this work.. GGGrrrrrrr


    UK WAG54G V2 Firmware Version: 1.00.19

    If someone has some answers then please please help, I seriously need to be uploading work this weekend, just typical bloody typical. I can see me having to spend money on a better product and returning this product unless someone has some good answers. I have downloaded the firmware mentioned on this thread should i use this ?
     
  37. booly

    booly Network Guru Member

    I've a v2 with the 1.1.22

    I've a pc with filezilla server, incomming ftp conection are ok.

    From any oof my 3 pc at home outgoing ftp connexion are also ok.
     
  38. ReDFlaG

    ReDFlaG Network Guru Member

    right i use the same config, but if you try to use a different port than the 21, it does not work very well.
     
  39. HiSpeed

    HiSpeed Network Guru Member

    But RMA does ! :rofl:
     
  40. booly

    booly Network Guru Member

    I make frequent port manipulation, to access my appliction from my office (My company firewall block most outgoing port, only 80,8080,443 and 21 are open). I swap port using the port forwarding, and it woork fine (internal port keep the standard value)
     
  41. dokteriq

    dokteriq Guest

    Same problem

    guys im having the exact same problem. whenever I upload a file it goes till 100% and then fails. I have tried PORT and PASV both.

    I have also tried the QOS solution.

    I have all my firewalls disabled on the laptop and on the router. the laptop is DMZ as well.

    The beta version links are not working.

    I Need serious help with this peice of crap.

    Also another problem I have noticed: If I turn on upnp my msn takes forever to logon.

    Has anyone come up with a solution to all this?
     
  42. dontbotherme

    dontbotherme Network Guru Member

    Hi, i came here becouse i also had this problem.
    the QOS solution also didn't work for me.
    on the linksys site there is a firmware update. i just installed V 1.01.15 and the ftp seems to work now (2nd test is now running)
     

Share This Page