1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG54G Which Firmware for my problem ?

Discussion in 'Other Linksys Equipment' started by Tbird1, Nov 21, 2005.

  1. Tbird1

    Tbird1 Network Guru Member

    I have 3 PC's connected (2 x wireless and 1 x wired) all occasionally lose either LAN connectivity or Internet connectivity and sometimes both. Re-booting the router usually fixes the problem. Is there a firmware upgrade that could help solve this issue ?

    I am in the UK and have the following

    Model Name:WAG54G
    Firmware Version:1.01.6, Feb 09 2004
    Boot Version:1.4


  2. nick_squonk

    nick_squonk Network Guru Member

    I had the same problem; at the moment I use this one http://www.chez.com/jdc99/www/WAG54G_AnnexA_ETSI_v1.03.1_beta1_00_code.zip that is the more stable I've found. To download it, right click and chose "Save Target As".

    After upgrade, if you have problem with the internet connection (the internet led red) try to use an empty service name in Setup|PPPoE Settings|Service Name, sometimes this fix a problem with some ISP.

    Hope this helps...
  3. Tbird1

    Tbird1 Network Guru Member

    Thanks for that - I assume this is okay for the UK version, how do you know whether Annex A or Annex B ?

  4. Tbird1

    Tbird1 Network Guru Member

    The link you (nick_squonk) provided does not work - please re-post
  5. Tbird1

    Tbird1 Network Guru Member

    Sorry, ignore previous comment
  6. Tbird1

    Tbird1 Network Guru Member

    Sorted !

    All sorted - Firmware upgraded in under 2 mins, thanks for helping a novice :). So far so good in the reliability stakes as well - no lost connections in the last 8 hours.
  7. nick_squonk

    nick_squonk Network Guru Member

    I've found it using google, downloaded and installed; after that I've found a post in this forum with a link to the email linksys support in UK. I've emailed them and they sent me the same file.

    So you may assume the source is the UK linksys support.

    Annex A is for ADSL over analog line, while Annex B is for ADSL over ISDN.

  8. kitch9

    kitch9 Network Guru Member

    Hi there,

    I have exact same problem as you guys in this thread, do you think if I pm you my e mail that you could sent me the firmware?

    Thanks in advance...
  9. nick_squonk

    nick_squonk Network Guru Member

    You may ask for it directly to the UK Linksys support sending an email to support.uk@linksys.com. They sent me the file in about two days.
    Anyway you can download it using the link I've posted in my first reply: right click over the link and chose "save target as..." from the menu.

    Remember that it is for WAG54G Annex A version 1.2.

    If someone knows how to post this firmware so it can be available in the download section, let me know.
  10. DocLarge

    DocLarge Super Moderator Staff Member Member

    If you were having problems maintaining connectivity, you might have tried adjusting the channels your were using (1, 6, 11) on the router or checked to see if you were getting interference from someone else in the area on the same channel. 1.01.06 is "the best" firmware out for the WAG54G in my opinion. Every version after that is what's given people "extreme" grief. For every version people have upgraded to, there's been a loss of functionality somewhere else.

    My WAG54G is still going solid on 1.01.06 since I bought in March of this year. I've let a friend borrow it and it's been running without interuption for three straight months (24/7) and is still going.

    Hopefully the firmware you flashed to is an improvement where others have had problems, but if not, there is "no going back" to 1.01.06 because for some reason, this was never posted on the linksys site :(

    Good luck...

  11. nick_squonk

    nick_squonk Network Guru Member

    I agree with you that this is one of the more stable I've used, but I've had a lot of problems with it, I've tried to use different channels with no luck. Also there are things that simply are not supported by this firmware like the use of a Ximeta netdisk (NDAS protocol not supported).

    In "my" experience the firmware 1.03.1 beta 1 is better and I've no problems with it.

    I agree with you again... It's not so clear why you can't find an officially released firmware on the FTP site, there's only a WAG54G-SE_AnnexA_ETSI_v1.01.6_0209_code.zip; is it the same or a Sweden custom version?
    Perhaps we may ask for it to the linksys support...


Share This Page