1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG54G - wireless connection but no internet

Discussion in 'Other Linksys Equipment' started by AnimalHungry, May 5, 2005.

  1. AnimalHungry

    AnimalHungry Network Guru Member

    Hi all - I'm new to the forum and have what is probably a simple question, but I'm also new to networking and it's driving me crazy. I've been using my WAG54G connected to one PC (running XP SP1) with an ethernet cable for over a year and it has been the epitome of stability and reliability. I now want to move the WAG54G into another room and rely solely on the wireless function.

    I've got a Belkin 802.11g wireless desktop network card (model #F5D7000) which is installed on the PC. I enabled the WAG54G's wireless function and security in the 192.168.1.1 utility. I put typed in the key generated by the utility into the Belkin's setup page and it connects to the WAG54G with a full signal strength of 54 Mbps.

    At this point the WAG54G is still connected to the PC by the ethernet cable, and I still have net access. When I remove the ethernet cable I lose internet access for 30 secs or so and then internet access comes back - so now I'm connected to the WAG54G wirelessly and have a working net connection. This is good, it's all downhill from here. Of course, at this point the router is still next to my PC, so I have to unplug it and move it to its new home in the next room. I relocate it, plug it in and turn it back on and after a minute it connects to the internet, the PC finds the wireless signal and connects to the WAG54G. However, I can't access the internet from the PC, and nor can I access the 192.168.1.1 setup utility. What gives? Do I have to further configure the router? I presume my firewall is OK since I could access the net wirelessly before I moved the WAG54G to the other room.

    Any ideas greatly appreciated? (Apologies for the long post, but I didn't want to miss anything)

    Thanks in advance
    Simon

    BTW, I'm running SP1 because when I upgraded to SP2 all of my PVR software refused to work, so I'm sticking with SP1.
     
  2. DavidC

    DavidC Network Guru Member

    Hi I've had a similar problem but the other way round The wired LAN would only work OK if the Wireless link had been used. This was solved by downloading a new LAN driver from the manufacturer!

    However to your problem - I take it you are running a WAG V1.2?

    On the PC Wireless network have you entered a preferred DNS server in the adaptor TCP/IP properties?

    If not look on the WAG setup/status page there should be a DNS address listed here.
     
  3. dribble

    dribble Network Guru Member

    Wireless troubleshooting

    Hi,

    confirm in your WAG that you dont have MAC address filtering switched on. Make sure that you enable management via wireless. Also, disable the LAN card, make sure that your "ipconfig /all" and "netstat -rn" are picking up the correct address scheme and the card is "active".

    Otherwise I would drop WEP and run it with MAC filtering.

    Cheers

    Lee
     
  4. AnimalHungry

    AnimalHungry Network Guru Member

    Thanks David. The "software version" is 1.02.1 - is that what you mean by "WAG V1.2"? I had not entered a preferred DNS server in the TCP/IP properties of the adapter, so I copied the DNS server address from the "status" page of the WAG setup utility. I rebooted the router and the PC, but still no workee I'm afraid. And it still does exactly the same as it did before :(

    Anything else I should be checking?

    Cheers
    Simon
     
  5. AnimalHungry

    AnimalHungry Network Guru Member

    Re: Wireless troubleshooting

    Cheers for your help, but I'm struggling I'm afraid. I looked at every page in the WAG setup utility and the only reference to MAC address I could find was on the "status" page which showed there is an address.

    I couldn't find anything in the setup utility relating to management via wireless - is this the same as remote gateway management?

    Lastyl, I did an "ipconfig/all" and a "netstat -rn" and it came up with a load of info and addresses, but how do I know what the correct address scheme is? Are there values/addresses in the WAG setup utility that I should be checking the "ipconfig/all" and a "netstat -rn" info against?

    When you say the card is "active", do you mean that it's communicating with the WAG? If so, then that's a definite yes! I have setup the WEP key for the WAG and the card and the card finds the WAG and connects to it. It says that it's connected at a speed of 18Mbps (I think I said 50Mbps in my original post, but that was from memory - bad memory).

    Despite the dawning realisation that I really know nothing about networking, I disabled the LAN card and rebooted the PC anyway but I still had no joy.

    Since the PC is finding the wireless router and says its connected to it, could the WEP settings be preventing the PC from getting on the net? i.e. is there any benefit from using MAC filtering (I thought MAC filtering was just a different type of security for the wireless connection, so since the PC says the conenction to the WAG is good is there any benefit from using MAC filtering?)

    Logically I would have thought that because the router says its connected to the ISP (the ADSL and the Session lights are both on) and the PC says it's wirelessly connected to the router it would appear that it's a problem either with the router setup not letting the PC see the net, or the TCP/IP settings of the PC, or both.

    Cheers
    Simon
     
  6. DavidC

    DavidC Network Guru Member

    The firmware vrsion you have is for a 1.2 so a 1.2 it is!

    Are you using the DHCP facility on the router?

    If yes try setting up a static address - pick an address in the range you have allowed on the setup/basic setup page (I think default is sometihing like 192.168.1.100 to 192.168.1.150 so pick an adress within that range i.e. 192.168.1.130)
    the subnet mask should be 255.255.255.0 then enter the router IP address as the default gateway (Router default addr is 192.168.1.1). Enter the preferred DNS setting as you did before - you can also use the router ADDR here as well.

    I have to do this twice once for the Linksys wireless profile setup and again in the TCP/IP setting for the Wireless LAN entry in Settings/Network and Dial up Connections

    I'm using Win 2K If you are on XP it may be a bit different but not that much.
     
  7. DavidC

    DavidC Network Guru Member

    Forget about MAC access for now - you can see the router setup pages so you are connecting OK.
    For the record its in Wireless/Wireless Access - here you can set the mac address of you PC as permit only.

    ipconfig /all should give you the MAC address (Physical Address) of the wireless adaptor you have - it should be on a label somewhere as well. If you are connected via wireless then ipconfig should confirm the ip-addr/gateway/dns settings as well.
     
  8. AnimalHungry

    AnimalHungry Network Guru Member

    Sorry for the delay in posting (I'm trying to move house). I tried to set a static IP address, but when I did the router could not dial-up to my ISP. This is because to set a static IP on the Basic Setup page of the router util I had to change the mode from PPPoA to RTF bridged (or something - can't quite remember which one it was). This was because there was no option to set a static IP address when PPPoA was selected. I need to use the PPPoA mode so I can tell the router my ISP log on details (user name and password).

    What's carzy about this thing is that when I disconnect the router by unplugging the ethernet cable, the wireless connection is maintained and I can access the internet perfectly. It's only when I then reboot wither the PC off or the router that the PC cannot access the internet (although it will still connect to the router with a full signal strength).

    :(

    Simon
     
  9. DavidC

    DavidC Network Guru Member

    Close but not quite,

    Ignore the WAG for now and try to set a static address on the PC - use a different address for each adaptor you have. The gateway, DNS etc is common.
     
  10. booly

    booly Network Guru Member

    If you manage to acces to setup pages, the problem can come from :
    1) Tha WAG doesn't connect to internet
    2) You have a problem woth the DNS server address
    3) The routing schem is not good ( NAT disabled ????)
     

Share This Page