1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAG54Gv1.2: No internet after firmware upgrade (1.03.0 beta)

Discussion in 'Other Linksys Equipment' started by JesperDN, Apr 21, 2005.

  1. JesperDN

    JesperDN Network Guru Member

    Hi gang :D

    I've read most of this forum and couldn't agree more about the stability of the wag54g v1.2 gateway (or the lack thereof). However I do have a question that I hope you can help me with.

    I have tried upgrading the firmware to the beta referred to around the forum (the 1.03.0 beta4) and the upgrade process completed without any difficulties. I then assumed all was well and my product now was just a notch better than before..

    1) Gateway rebooted fine
    2) Ethernet connected and recieved IP from the DHCP pool
    3) Wireless connected (g/WEP) and recieved IP from the DHCP pool
    4) DSL line trained and found gateway IP's from my ISP

    So far one reading this would assume that this sounds great and the update was a success - However this is not the case for me..

    I had no access to the Internet what so ever. Couldn't ping, nslookup, anything! Even the router could not ping outside IP's.. At first I suspected the routing tables was messed up but they seemed fine..

    Have any of you WAG54G-guru's had the same problem? Any advice for me how to proceed (besides throwing the damn thing out the window) :).. I really need to get this working probably

    Greetings from Denmark,
    Jesper
     
  2. Toxic

    Toxic Administrator Staff Member

    did you perform a hard reset on the router after upgrading the firmware?

    press the reset for 30 seconds.

    then access Web GUI and re-enter the ISP details etc. have yu tried a DHCP release followed by a renew?
     
  3. JesperDN

    JesperDN Network Guru Member

    Hi Simon. Thank you for your reply :)

    I'm pretty sure that I did turn the power off for 2 minutes after the upgrade (which should cover the 30 sec reset button or .. ?) But I honestly can't remember.

    I downgraded to the working edition (1.01.6) again and it's running again. I will try again this sunday and let you know what I find out.

    Furthermore I was wondering - would "Return to factory defaults" do any good in this situation?
     
  4. oopsibrokeit

    oopsibrokeit Network Guru Member

    power off is not the same as a reset.

    All a power-off does is reload whats already there, a hard reset reverts the unit back to bare firmware.

    it will clear all information from the unit. you will have to re-teach it your network arrangement.

    return to factory defaults might help, but pushing the button is a much more sure way of getting a reset.

    I'd push the button, you'd be amazed what a reset will fix!
     
  5. booly

    booly Network Guru Member

    That's true, the wag can becom complety crazy after sw update
     
  6. JesperDN

    JesperDN Network Guru Member

    Geez.. of course! Silly me :) Thanks for the enlightenment guys

    Have any of you succesfully run WPA-PSK on the WAG54G? For obvious reasons :roll: I haven't tried this on any other firmware than the 1.01.6 and here it seemed to drop and renegotiate the connection everytime the key changed.

    Note: I am quite excited to try out the reset button this weekend after a upgrade.
     
  7. Toxic

    Toxic Administrator Staff Member

    Just make sure you hold the reset in for the 30 seconds before releasing. then wait until the router reboots.
     
  8. jrjove

    jrjove Network Guru Member

    I have the same problem with this firmware

    My RFC2364PPPoA connection does well with 1.02.7 version but with 1.02.9 and 1.03.0 the IP addres and the default gateway gets the same address.

    Any ideas???
     
  9. JesperDN

    JesperDN Network Guru Member

    Hi all..

    Well, now I tried holding the reset button after upgrading to 1.03.0b4 but with no effect. After I read jrjove's reply I noticed that my situation is exactly the same..

    Gateway is the same as Internet IP with firmware:
    1.03.0 beta4 and 1.02.9_04

    I up-/downgraded to 1.02.7_03 and then is IP issue was resolved. I have yet to test if the wireless is improved with this firmware. But I find it a bit annoying with the IP's - any ideas from you guys?

    * Edited *

    Btw - I just send an email to the Linksys support about this issue and am waiting for their response..
     
  10. booly

    booly Network Guru Member

    I redread the complete post. I've encounter the same problems with FW 1.2.9 and 1.3.0.
    No internet acces, event if dsl link seems to be OK. The internet session open and close all the time!!
    I've try factory reset, changes settings, I can't make those FW work.

    I've got a WAG V1.

    I wish I had neverr buy it
     
  11. purge98

    purge98 Network Guru Member

    Firmware 1.03.4 Beta4 did the same to my wag54g.

    Both the IP address (which was wrong) and the default gateway were identical addresses even though my IP address is fixed !

    No time and date was shown either.

    Re-installed 1.02.7 and the IP addresses were back to normal but still wireless connection dropped consistantly.

    YOU ARE NOT ALONE
     
  12. JesperDN

    JesperDN Network Guru Member

    This is probably old news for a lot of you but I recieved this reply to one of my many communications with Linksys

    Advanced Wireless Settings:

    RTS Threshold: 2304
    Fragmentation Threshold: 2304
    DTIM Interval (If the value is 3 set it to 1) and (If the value is 1 set it to 3)

    At the moment I am trying to change channel everytime I encounter a problem and for the moment I am so fortunate to have a WEP-encrypted 11Mbit working fine actually - But I seriously doubt that I can achieve the 54Mbit WPA-PSK that I would much rather be running..

    My SSID channel is at the moment 3 but this is very individual according to how many other wireless lan's there are in your neighbourhood.

    Hope the settings help - I will try the 54Mbit PSK some time next week and get back to you

    Note: Am still running 1.02.7_03

    Regards,
    Jesper
     
  13. DocLarge

    DocLarge Super Moderator Staff Member Member

    Alright Jesper, let's do this by the numbers. Make sure you're running firmware 1.01.06 as your baseline before starting:

    1) Turn off WAG
    2) Press the reset button
    3) HOLD RESET BUTTON in for 20 seconds and turn router on AT THE SAME TIME (this is very important)
    4) When router comes back up, you should be running 1.01.06 (this is what I run and I have "NO" problems)
    5) Select the option that allows you to utilize the "retry every 30 seconds" feature (this in my opinion makes all the difference)
    6) Register at http://www.dyndns.org for free dydnamic dns
    7) Download the dynamic updater, for free, of course(http://www.dyndns.org/support/clients/dyndns.html)

    6 and 7 should take you all of 15 mins, and then you should be up and running. I just love me some free stuff, by the way. When I have my WAG online, I "do not" use dhcp that often as a means of limiting the capabilities of War Drivers. Ideally, you want to issue static ip's to limit outside access, but if you need to use dhcp, make sure you're running some form of encryption. I've been able to run WEP (128 bit) with 26 character HEX string along with a static ip arrangement for up to 5 computers at once without any hindrance. I don't use WPA that often because only 3 of my 5 machines have wireless cards that support this feature.

    The WAG "does not" handle dhcp well, which is why I'm including dynamic dns information. When your isp provider refreshes ip'sthe WAG drops; although the router may "speak" dhcp, it doesn't "interprete (as Richard Pryor once said...). Richard Pryor is a popular american comic btw...

    I run all my gear on channel 11 "with" encryption with full 54MBps connectivity.

    Try this for starters and see if you can keep the same basic settings as you try upgrades.

    Doc
     
  14. jagboy

    jagboy Network Guru Member

    you guys should try and buy a cheap wrt off of ebay
     
  15. lawnmower

    lawnmower Network Guru Member

    Web GUI can not be accessed.

    Hello everyone.
    I own a wag54g and i updated its firmware to 1.03.0 beta and it works fine now but i can not access the web gui. When I enter the IP "192.168.1.1" the web browser can not find it. There is no problem right now, I can connect to the net perfectly but I fear I won't be able to make any changes or upgrade the firmware in the future. Does anyone know a solution for this? Is there another way to access the web gui?
     
  16. DocLarge

    DocLarge Super Moderator Staff Member Member

    Don't sweat the technique, it's possible that the firmware has just "hiccuped" on the back end of your upgrade. First, just start by doing a reboot. If that doesn't work, then you'll just have to do a full reload and try it again.

    If you can't get to the web gui, there's no way to make any changes or do a status check, obviously. I forgot to mention to also go to another computer if one is available and try to access the router. I've had computers that were running wirelessly to lose connectivity to other workstations on my wireless lan (and internet connectivitity) "BUT" still be able to pick up the routers wireless signal an pull an ip address (What the Hell?!?!?!).

    A full firmware reload blows, but if you've tried all the above suggestions (unless someone has some other tricks) reloading the firmware is the next option...

    Doc
     
  17. lawnmower

    lawnmower Network Guru Member

    I did a several reboots and I tried with 3 different browsers. I try to ping the adress and it works fine. How can I reload the firmware without using the web gui? Is there another way to do that?
     
  18. DocLarge

    DocLarge Super Moderator Staff Member Member

    Not that I know of. You definitely have a hang up somewhere, because, if everything were alright, you'd be able to get to you gui...

    To the best of my knowledge, there's no other way to do it, but there are other forums available that can also give you a hand.

    Doc
     
  19. jagboy

    jagboy Network Guru Member

    you can flash the firmware with out a web gui.
    just use tftp. aka Auto Upgrade Utility.
    http://www.linksys.com/download/firmware.asp?fwid=201

    or if you have windows use the command line
    $ cd "to direcotry of bin file"
    $ tftp -i 192.168.1.1 PUT "name of bin".bin

    in linux it is
    $ cd /home/voidmain/firmware
    $ ls
    OpenWrt_b3.bin
    $ tftp 192.168.1.1
    tftp> bin

    tftp> put OpenWrt_b3.bin
     
  20. DocLarge

    DocLarge Super Moderator Staff Member Member

    Good lookin' out, jagboy...

    Doc
     
  21. jagboy

    jagboy Network Guru Member

    ur welcome
     

Share This Page