1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wake on Lan in Alchemy 1.0

Discussion in 'Sveasoft Firmware' started by longstride, May 10, 2005.

  1. longstride

    longstride Network Guru Member

    I can't seem to get the wol command to work in Alchemy. I have sshd into my WRT and execute 'wol MAC:ADDRESS' but it always just outputs "Killed" I have not been able to find any reference to that return statement. Can anyone tell me what I may be doing incorrectly. I have tried several other flags in the command as well but it always just returns "Killed" and the machine does not wake up?
     
  2. littlewhoo

    littlewhoo Network Guru Member

    Same problem here. So I guess wol is broken in Alchemy 1.0.
    You can try to use the wol binary from openwrt.
    http://nthill.free.fr/openwrt/tracker/packages/show.php?id=3466
    Just download the .ipk file, rename it to .tar.gz, extract the wol binary and upload it to your router.
    Ususally binaries form openwrt packages are running without problems on Alchemy.

    Edit: There is a working wol version in Alchemy. Use "/usr/sbin/wol" instead of just "wol".
     
  3. longstride

    longstride Network Guru Member

    Thanks, that one worked! I swore I actually tried executing it from that directory but I guess not. Seems to be working now, I just woke up my computer.
     

Share This Page