1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAN didn't work, 1.27-ND on rosewill rnx-gx4

Discussion in 'Tomato Firmware' started by dickhu, Jan 17, 2010.

  1. dickhu

    dickhu Addicted to LI Member


    I heard that the router is supported so I bought one from newegg. But I could not get it work. Flash to 1.27-ND was easy and I could login, wireless worked fine. But the WAN could not get IP with pppoe from my ISP. I also tried to connect it to my home network and it could NOT get IP from local dhcp server.

    Just wondering if I had missed something obvious? Tried the original firmware and WAN worked with no problem.

  2. dickhu

    dickhu Addicted to LI Member

    tried dd-wrt and I got the same problem. However, in the vlan screen, "uncheck w column on vlan 1, applay, recheck it, apply" and this somehow enabled the wan port and test wan with dhcp in my home network and it worked.

    I don't see "vlan" setting in tomato firmware. anybody knows how to do the same thing to enable wan port in tomato?
  3. mstombs

    mstombs Network Guru Member

    I've not seen that router mentioned before, but it seems that the board is not properly recognized and the vlan nvram variables not correctly initialized.

    Tomato doesn't have a web gui for vlans, but you can do it yourself manually, here's an example:-


    I suspect the Tomato author Jon would be interested in adding support to Tomato for this router, there's probably enough info in an nvram dump from a working dd-wrt setup, I suggest you try contacting him.

    Newegg forums suggest all you need is

    Also to watch out for MAC address changing when loading new firmware
  4. Slimey

    Slimey Network Guru Member

  5. dickhu

    dickhu Addicted to LI Member

    the "nvram" command solved my problem. Running tomato happily now. Thanks a lot to mstombs!

    tried to attached is the zipped cfe.bin but it was too big (108kB) and could not upload.
  6. dickhu

    dickhu Addicted to LI Member

    Got another question and not sure if anybody knows why.

    Flashed this route to dd-wrt v24 pre2 (search netcore at dd-wrt.com and this is the recommended). after tweaking WAN port vlan all worked fine. the new version of dd-wrt looked better than the old version I used before. expecially like the bandwidth monitoring.

    I tested and all worked fine, so I turned it off. A few days later, I turned it back on and wanted to use it as my main router, to my surprise, it was not working at all. I had to use tftp to unbrick it back to rosewill firmware.

    So I flashed it to tomato, nvram set vlan and it worked fine. also tried power off and restart.

    I guess I will keep tomato on it for now if it running stable.
  7. Slimey

    Slimey Network Guru Member

    I submitted the cfe to the dd-wrt cfe collection project for analysis so hopefully better 3rd party support can be added for this router.

Share This Page