1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WAP54G SNMP stats pulled with MRTG

Discussion in 'Other Linksys Equipment' started by kokodingdong, Oct 29, 2006.

  1. kokodingdong

    kokodingdong LI Guru Member

    Hi,

    I've bought a WAP54G hardware version 3.1 EU, and when looking over the web interface menus i've found the SNMP menu.

    Since i use MRTG to monitor various stats on my other boxes, i gave the MRTG cfgmaker command a shot:
    Changed the read-only community name to 'local'.
    Only got the following output though:
    $ sudo ./cfgmaker local@192.168.0.11
    --base: Get Device Info on local@192.168.0.11:
    --base: Vendor Id:
    --base: Populating confcache
    --base: Get Interface Info
    --base: Walking ifIndex
    --base: Walking ifType
    --base: Walking ifAdminStatus
    --base: Walking ifOperStatus
    --base: Walking ifMtu
    --base: Walking ifSpeed
    # Created by
    # ./cfgmaker local@192.168.0.11


    ### Global Config Options

    # for UNIX
    # WorkDir: /home/http/mrtg

    # or for NT
    # WorkDir: c:\mrtgdata

    ### Global Defaults

    # to get bits instead of bytes and graphs growing to the right
    # Options[_]: growright, bits

    EnableIPv6: no

    ######################################################################
    # System: Linksys
    # Description: Linux (none) 2.4.20 mips
    # Contact: lonk@lonk.dk
    # Location: DK
    ######################################################################

    So it sees like MRTG cfgmaker could not find nay interfaces, so i've googled the issue for a bit and tried getif etc.

    So i have the following 3 questions:

    1. After looking in some forums, it looks like there actually is not any "proper" SNMP support on a Linksys WAP54G with default firmware?
    2. Can anyone recommend a custom firmware with proper SNMP support, and perhaps even provide a MRTG conf?
    3. Anyone who has a MRTG example page of the things possible to monitor?
     
  2. pablito

    pablito Network Guru Member

    I don't what that unit can do but if it has the config page I'd expect it to work. Have you used a community name other than "local"? Think of it as a password. I've done SNMP on WRT/V and RV units and I get data for the interfaces. The WRV has a "trusted host" field so if you do too make sure that is correct.
     
  3. kokodingdong

    kokodingdong LI Guru Member

    Yes, tried with the default 'public' community name at first - Same result.
    There is no trusted IP option, but that's not an issue, since i do get some sort of "reply":
    ######################################################################
    # System: Linksys
    # Description: Linux (none) 2.4.20 mips
    # Contact: lonk@lonk.dk
    # Location: DK
    ######################################################################
     
  4. stfreddy

    stfreddy LI Guru Member

    I have exactly the same problem with this device... I contacted with the Linksys support once, the suggestion they gave didn't help. As I know, this device use some proprietary MIBs...
    I'm also looking for a modified firmware, please let me know if you've found any...
     
  5. stfreddy

    stfreddy LI Guru Member

    Well, I have found some 3rd party firmwares.
    First of all, this one is for wap54g v3 (EU) devices, based on openwrt-whiterussian micro-rc5 (www.openwrt.org):
    http://www.collen.nl/openwrt/
    I don't know if it works or not, but the readme says it is OK for v3. I don't know whats up with v3.1 devices...
    Original openwrt whiterussian firmwares will brick your AP...some wrong settings related to sdram...
     
  6. kokodingdong

    kokodingdong LI Guru Member

    Thanks stfreddy,

    Seems like the link http://www.collen.nl/openwrt/ is dead though.
    I also contacted linksys support, but the answer i got was so retarded i gave up.
     

Share This Page