1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WDS again. Cant be so hard or?

Discussion in 'Tomato Firmware' started by Sedokles, Aug 1, 2008.

  1. Sedokles

    Sedokles Addicted to LI Member

    Hi Guys!

    I have two Linksys WRTGL-DE Routers and I am trying to build up a WDS in my house but without success. Following Configuration is running:

    Tomato V1.19 on both Router

    Router #1 (With WWW)
    Set as AP + WDS
    IP 192.168.1.1
    DHCP Range 50-99
    B/G Mode: G only
    SSID: Same SSID
    Broadcast: yes
    Chanel: 6
    Security: WPA Personal
    Encryption: TKIP/AES
    WDS: Link with MAC of Router 2

    Router #2 (WDS)
    Set as AP + WDS
    IP 192.168.1.2
    Gateway 192.168.1.1
    DNS 192.168.1.1
    DHCP Range 100-149 (for testing purpose to see, where it connects)
    B/G Mode: G only
    SSID: Same SSID
    Channel: 6
    Security: WPA Personal
    Encryption: TKIP/AES
    WDS: Link with MAC of Router 1

    In the Device List I can see an Interface called wds0.49153 wich seems to be the other AP so they see each other. Now it depends on where my PC connects first, there it will stay and it is not possible to ping the other AP.

    i.E.: Connected on Router #1 getting IP 192.168.1.52 I can go normaly to WWW and all other Devices connected to the Network as long, as they are on router #1. I cannot ping 192.168.1.2

    Connected on Router #2 getting IP 192.168.1.104 I cannot access router #1 so there is no access to internet either.

    If I turn off on of the router, the PC automaticaly switch to the other one, what would show, that there is no problem with the client.

    *)What I have tried: cleard NVRAM on both Routers and then just configured WEB and WDS.
    *) Disable DHCP on Router #2
    *) Set Router #2 on WDS only

    I just spent about 4 hours here with no success. I have no clue what this can be as both router are same model with same Firmware on it.

    What do I do wrong?!?!? :frown:

    This is getting very frustrating, hope some of you could help me out here?!?

    Cheers,
    Sedokles
     
  2. fyellin

    fyellin LI Guru Member

    You do not want DNS running on Router #2.

    When you look at the Device List on Router #2, do you also see wds0.xxxx? You ought to be seeing two interfaces in the device list corresponding to Router #1
    • Interface br0, with an IP address of 192.168.1.1
    • Interface wds0.xxxxx, with a mac address slightly different that the MAC address of the br0.

    My WDS setup (3 routers) is set to AES only. I have no idea if that matters or not.
     
  3. TexasFlood

    TexasFlood Network Guru Member

    I do see wds0.4915x under Device List on both my routers. Out to the right, you should see an RSSI and a Quality number. On mine, the RSSI seems to stay somewhere in the 60s and the Quality somewhere in the 30s. That seems like a lot number for quality but works fine.
     
  4. Sedokles

    Sedokles Addicted to LI Member

    It works!!!!!

    Thanx fyellin!

    I disabled DNS on Router #2 and configured AES as Encryption and it worked immediatly!

    Thank you very much!!!!:biggrin:
     

Share This Page