1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WDS almost there, but still need some help with my 2 54GS's

Discussion in 'HyperWRT Firmware' started by out77880, Aug 12, 2005.

  1. out77880

    out77880 Guest

    I have 2 WRT54GS's, one is connected to the internet, and I'm trying to get the other to act as a client, ap, repeater, or something?...don't know too much about the differences, but I know I want access to the internet through the WDS connection. So far I "think" this is what I've achieved, a WDS bridged connection with AP functionality, but no internet--not really interested in the security features yet...want to get it working before I think about that. Here's my config:

    Internet (WAN)--->WRT54GS v.2---(WDS connection)--->WRT54GS v.2.1--->PC (I have LAN&Wireless functionality, but no internet connection)

    WRT54GS v.2 = A
    WRT54GS v.2.1 = B

    I've tried a few startup/firewall scripts that have been posted around the web, but here's the one that has my 2 routers talking:

    --I pasted these into startup--

    ...for router A:

    nvram set wl0_mode=ap
    nvram set wl0_wds=(mac B)
    nvram set wl0_channel=11
    nvram set lan_ipaddr=(ip A)
    nvram commit

    ...then reboot

    ...for router B:

    nvram set wl0_mode=ap
    nvram set wl0_wds=(mac A)
    nvram set wl0_channel=11
    nvram set lan_ipaddr=(ip B)
    nvram commit

    ...then reboot

    --Additional settings for routers:

    router A:
    Firmware Version: v3.37.6 - HyperWRT 2.1b1, Feb. 18, 2005
    Mode: G only
    DHCP: enabled
    Security firewalls disabled
    Static IP settings for internet
    channel 11
    SSID: linksys
    ----------------------------------------------------------
    router B:
    Firmware Version: v3.37.6 - HyperWRT 2.1b1, Feb. 18, 2005
    Mode: G only
    DHCP: disabled
    Security firewalls disabled
    DHCP settings for internet
    channel 11
    SSID: linksys


    With these settings I cannot access the internet, any help would be appreciated...thanx
     
  2. RTSAnime

    RTSAnime Network Guru Member

    maybe its different for the gs but for the g the commands i used were

    wl_lazywds 0
    wl_wds (insert macid) <-- notice no 0 after wl

    also make sure any security settings are the same on both routers.
     

Share This Page