1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WDS cannot connect more than 1 client?

Discussion in 'Tomato Firmware' started by chbla, Jul 8, 2012.

  1. chbla

    chbla Serious Server Member

    Hi there,

    I've got an ASUS RT-N16 and 3 WRT-54GLs (v1.1)
    Asus is the main AP running tomato-K26USB-1.28.7483.2MIPSR2-Toastman-RT-Std.trx
    the wrts are running tomato-ND-1.28.7625-Toastman-ND-Std.bin
    I have successfully connected 1 WDS client, but the others are not working and I have no idea why.
    They are configured in the same way... but I cannot reach the main host/internet from the clients
    Is there any way I can debug why they are not connecting?
    Thanks a lot!
    Christoph
     
  2. mvsgeek

    mvsgeek Addicted to LI Member

  3. chbla

    chbla Serious Server Member

    hey, thanks for the reply

    I'm using WPA Personal, not WPA2 - what does this nas/nas4not mean or do?

    Thanks,
    Christoph
     
  4. mvsgeek

    mvsgeek Addicted to LI Member

    It seems that nas4not is a mystery, documentation is sparse at best. I gleaned all I know about it by diligent googling. There's a link in one of my previous posts in this thread which may help you.

    And just to add to the confusion, it was when I tried to replace nas with the 'must-use' 126444 byte version recommended in that link, that I ran into the 'read-only' file system issue which has been the subject of another recent thread on this forum. So my script does not use the 'must-use' version, rather it uses the 73280-byte one that comes with the firmware.

    Maybe one or more of the wifi gurus here could provide more info about nas4not?
     
  5. chbla

    chbla Serious Server Member

    I've tried the nas4not version but it still doesn't work

    I have no process called nas4not running, only one called nas /etc/nas.conf /var/run/nas.pid lan
    but I cannot find any information of how to configure all this nas/wds stuff :(
    there is also nothing in the logs, no documentation, etc..
     
  6. mvsgeek

    mvsgeek Addicted to LI Member

    Did you check out this link?
    http://www.bingner.com/openwrt/wpa.html

    And this thread?
    http://www.linksysinfo.org/index.php?threads/wds-wont-reconnect-after-power-outage.37941/

    In my environment, the keepalive script doesn't always force a reconnect - when that happens, I run the nas4not script manually on the main router. Sometimes it works first time, more often than not I have to run it 2 or 3 times - probably a timing issue.

    At startup you should see the nas process you mentioned, but no nas4not until you actually run it. It doesn't seem to clean itself up, hence the kill command in my script.
     
  7. chbla

    chbla Serious Server Member

    so you're running this on the RT-N16?

    I'm also unsure about the different wsd0.x devices... how do they work, are they assigned automatically?
     
  8. mvsgeek

    mvsgeek Addicted to LI Member

    keepalive script is run by cron every 10 minutes on each WRT54GL slave.

    nas4not script is run manually on main (RT-N16) in the event of successive keepalive failures. Not yet automated, that's on the to-do list.

    At main startup, each WDS slave is assigned a 'wds0.n' id based on its position in the wl0_wds nvram variable, which is generated & maintained from the Basic --> Network GUI page.

    In my environment, I have wds0.1 thru wds0.7, corresponding to the 7 MAC addresses in wl0_wds.
     
  9. chbla

    chbla Serious Server Member

    so basically the main router, RT-N16 in our cases assigns the wsd0.x numbers based on the fields where the macs are entered I guess?

    the problem I see here is that it doesn't even work after a reboot, so I don't have the initial connection that your scripts are trying to fix again..
     
  10. mvsgeek

    mvsgeek Addicted to LI Member

    1. Yes.
    2. After a main reboot, you should see all the wds0.x devices in the Device List. If the TX/RX rate is blank, they're being recognized, but there's no connection - that's when the nas4not script should be run. If you never even see them listed (watch for a few minutes, they'll come and go), then your problem lies elsewhere.
     
  11. chbla

    chbla Serious Server Member

    ha, now it worked!
    not sure how, and I did the connects in the opposite order.. but it seems to work now, they are connected

    what is a bit disappointing:
    speed connected to my main router: 13mbit
    speed connected to the client: 2mbit (at -68dbi signal strengh which is 38%)

    not sure if the direct connection isn't faster.. haha
     
  12. tvlz

    tvlz Addicted to LI Member

    Yeah, the older routers need more time for WPA2 to be ready before running nas4not to setup WDS.
    If you can compile your own version change in /src/router/rc/wnas.c around line 222, sleep(5) to sleep(45), to give plenty of time to be ready. It now comes back after a power failure by itself :)
    Code:
    219                }
    220                sleep(1);
    221        }
    222        sleep(45);
    223
    224        /* the wireless interface must be configured to run NAS */
    225        wl_ioctl((char *)ifname, WLC_GET_INSTANCE, &unit, sizeof(unit));
    226
    227        xstart("nas4not", "lan", ifname, "up", "auto",
     
  13. chbla

    chbla Serious Server Member

    Thank's a lot, I'll give it a try!

    Is there anything I can do about the huge drop in performance:
    speed connected to my main router: 13mbit
    speed connected to the client (wifi or eth, doesn't matter): 2mbit (at -68dbi signal strengh which is 38%)

    The wrt54gls only support b/g - how much would a different router with N help here?
    Are there any ways to tweak the config in order to improve this?

    Thanks a lot for your help!
    Christoph

     
  14. chbla

    chbla Serious Server Member

    I've set up the client as a "wireless ethernet bridge" now instead, and hardwired my laptop
    Now the speed is around 9mbit which is quite nice

    However, I wonder what happens if I make an AP out of the laptop now, I'm pretty sure that this is faster than the WDS connection...
    Could the slow speed with WDS be caused by interferences? Or how can I trouble shoot this?
     

Share This Page