1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WDS Connection Issue/Questions

Discussion in 'Tomato Firmware' started by buggage, Jan 3, 2010.

  1. buggage

    buggage LI Guru Member

    Thought not a huge issue, hopefully someone might be able to help, and hopefully this makes sense.

    WDS with WPA AES

    I can get WDS setup and running in this order.

    Step1: Setup router 1 (main upstairs router) WRT54GL 1.1
    Step2: Setup router 2 (basement router) WRT54GS 1.1
    Step3: Reboot router 1

    If I don't reboot router 1, the link does not get established. Once router 1 is restarted, the WDS link is established, I can reboot router 2 as much as I like and it will keep reconnecting fine. If I have router 2 off (only use the router when in the basement - don't keep that PC/router on full time), and happen to reboot router 1, then bring up router 2 after that, again there is no WDS connection established until rebooting router 1 again.

    I guess my question is, is there a way just to get the devices to link up, or re-establish the connection without have to reboot the main router first?

    Have tried enabling Spanning-Tree Protocol and no change. Tried with both Victek's and Teddy Bear's firmwares and no change.
  2. baldrickturnip

    baldrickturnip LI Guru Member

    WDS has always been a "hold your tongue in the correct position when pressing ok " system for me. have never been able to determine why sometimes it picks up straight away and sometimes not.

    there maybe be a correlation to the moon phase and sunspot activity :D
  3. gawd0wns

    gawd0wns LI Guru Member

    When I first tried using WDS a few years back, I had to wait a few minutes after saving the changes for the WDS link to be established. I imagine the routers have to detect themselves, go through the login procedure, and create new routes. Go grab a coffee and a smoke after making the changes and see if the link is up when you return. It usually took my routers 1-3 minutes on average, I think the longest it ever took was 10 minutes, I don't know what it depended on.

Share This Page