1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WDS help...AGAIN!

Discussion in 'HyperWRT Firmware' started by onetonwonton, Apr 11, 2005.

  1. onetonwonton

    onetonwonton Network Guru Member

    Well I went out and bought another WRT54G. They are both running the latest hyerpwrt firmware. I tried following the instructions on the sticky but no dice....a couple of questions...do the SSID have to be the same as well as channel? Also does it matter that one of mine is a v2.2 while the other is a v3?
     
  2. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Ok first off, I haven't used HyperWRT (yet). My responses are debatable as there appears to be mixed opions on this. The SSID does not have to be the same for WDS to work if its using the same wl driver as sveasoft. It only needs to be the same if you are trying to use WPA but I believe Toxic confirmed WPA doesn't work. Second, the channel does not need to be the same. Matter of fact why would you want it on the same channel? More devices on the same channel will cause interference with the routers. Go through the instructions again (I am sure you have xxx times already). Just leave out all extras settings above the basic IP and such (you can add them after it works). Make sure you have the correct MAC address for the wireless address. Check http://192.168.1.1/SysInfo.htm next to RF MAC address if you can't find it. At the end, don't forget to reboot your router (unplug is easiest). Once they both boot wait for a little bit to sort out the WDS association with each other. BTW, do all of this in the same room with both routers. There is also the possibliltiy that the routers are to far away from each other of no signal within range.
     
  3. onetonwonton

    onetonwonton Network Guru Member

    Shouldn't be a range problem, they are in the same room. (although at opposite ends) Also is WDS what I want? I want to connect my xbox to my existing wireless network. What do I set the default gateway of the xbox to? (can i stick a cat5 cable from the WRT54G to my xbox ethernet port and have a networked xbox)

    Thanks again, you guys rock!
     
  4. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    WDS in client bridge mode is what you want to get your Xbox to work. Set the gateway to the IP of the router it is connected to and yes you can use a wire. http://www.linksysinfo.org/modules.php?name=Forums&file=viewtopic&t=2564 Sorry for the sveasoft thread but I don't know HyperWRT and I can't step you through using wl commands in telnet. My WDS experience has been pretty staight forward simple. Just make sure you reboot both routers after making all the changes (power cycle is easier).
     
  5. onetonwonton

    onetonwonton Network Guru Member

    I got it working and hooked up to my xbox. But it's really weird....sometimes it just stops working and i have to drag the WRT54G back to the router, reset and apply settings again. I flashed it back to HyperWRT 2.0 after my WRT54G had problems with large file transfers in 2.2b.
    Any ideas?
     
  6. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    Sounds like the wl process for the WDS is re-initializing. This was an issue from some people with spanning tree enabled for WDS configuration on sveasoft firmware. It escapes me right now how to turn STP off. I'll think about it for a while and get back to you if I can remove jog it out of my brain. I got lots of useless info stuck in there. It may not be STP though, but it is at least a thought. Unfortunatley I am not familiar with HyperWRT.
     

Share This Page