1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Why is my RT042 is slower than my BEFW11S4?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by stillerz, Oct 13, 2006.

  1. stillerz

    stillerz Guest


    I just bought an RT042 to replace my old BEFW11S4 as a router and after doing a simple side-by-side test, I found that the RT042 is significantly slower than my BEFSR11.

    I have a 7Mb cable modem connection, and with my BEFW11S4 I can see a full 7Mb download speed. Actually tested it at 7.1 Mb consistently.

    But, when I'm using the RT042, I'm seeing usually around 3 Mb on average. On one test I got as high as 6.5Mb, but seems to be consistently slower over many tests.

    The RT042 does have the latest firmware (v1.3.5) from the linksys download site and the QoS stuff is all configured to be 10000 kb/s for my computer's IP address.

    So, it would seem this is configured correctly and the router is just slower -- even though it is much newer.

    Has anyone found any ways to make their RT042 routers faster? Possibly with a newer firmware than v1.3.5? Or maybe some way to optimize the settings to improve performance? I noticed that the options are very limited on this router.

  2. ifican

    ifican Network Guru Member

    Try turning off QoS all together and giving it a try.
  3. YeOldeStonecat

    YeOldeStonecat Network Guru Member

    Manually set your MTU...1500 for bridged DSL and cable, 1492 for PPPoE DSL.
  4. ed001

    ed001 Network Guru Member

    I don't have a RT042 bit some other Linksys routers have a field that defines the wan throughput like my RV082 when it is in load balance mode. I do believe that the default is 3Mbs. I think it's under System management. Look for something similar in the RT.

Share This Page