1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wireless Bridge erratic behavior, interesting problem!

Discussion in 'Tomato Firmware' started by mobrien118, Apr 8, 2013.

  1. mobrien118

    mobrien118 Addicted to LI Member

    I find this problem to be interesting (and also one that I am growing desperate to solve):

    I have 2 RT-N12 revB routers, running the latest Shibby version (108). Neither is configured to be a router.

    One is an access point (WAN disabled, DHCP disabled) and the other is in wireless bridge mode.

    They each have a large partially directional antennas pointing at each other on one port. They are only 100M away from each other, so maybe this is overkill, but...

    Anyway, we have availability monitoring and it keeps detecting the network going in and out. The strange thing is that it is the AP one is going in and out of responding (along with the client, of course)

    The interesting part is the behavior of the devices. They will keep going back and forth on responding to pings! While the AP is responding, the client is not, then the opposite (how is THAT possible, right?). Sometimes both stop responding at the same time, and sometimes they bith respond, but the majority of the time, they are see-sawing. A client connected to the bridge actually seems to be responding pretty well, and not going offline as these 2 routers do. I replaced the AP the other day and it worked for a couple days, then started doing it again. Rebooting doesn't provide this temporary boost, however.

    Getting into the settings on either of them is hit-or miss (page loads are about 40%).

    I know what your first thought probably is: IP conflict - Nope. They have different IPs.

    The router that the AP is plugged into is a Netgear and has RIP_2B enabled. Could that have anything to do with it?

    Any thoughts, suggestions, related experiences that you can relate to me would be greatly appreciated!

    Thank you,

  2. ghoffman

    ghoffman Addicted to LI Member

    first - don't use rip.
    second - what is the wireless signal strength?
    third - only use wpa2-aes encryption
    fourth - make sure nat is disbaled on both devices (set to 'router' not 'gateway'mode).
  3. mobrien118

    mobrien118 Addicted to LI Member

    1. Turned RIP off on the main (Netgear) router
    2. "Quality" is hanging around 52 on the AP, 42 on the client.
    3. Already only using WPA2-EAS. Also, have tried with WMM disabled and enabled.
    4. Tried setting both to "Router" with no change. Saw some suggestions that the client should be configured as "Gateway" though. Is that not correct?

    Something seems to have worked, though, as about 10 minutes after disabling RIP, they both seem to be responding fine now... Ping times are much higher than normal, though. I'll wait to see if it is fixed long term and update with status.

Share This Page