1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WL500W seems to have no IP in Recovery Mode?

Discussion in 'Tomato Firmware' started by Drakeg1, Dec 29, 2012.

  1. Drakeg1

    Drakeg1 Serious Server Member

    Hi all, looking for some expert advice on what I am doing wrong... Trying to flash an ASUS WL-500W. Have read and read and read, but after many hours am getting nowhere and am at a loss for what to try next...

    Based on the behavior I am seeing, consistently, it seems like my router does not have an IP address in recovery mode. Or, if it does, it is not 192.168.1.1. The ASUS Device Discovery Tool and Firmware Restoration Utility cannot find it, neither can TFTP2.exe or PING at that address, when in recovery mode. When operating normally, it is at 192.168.1.1 as expected. Any thoughts on how to find out what IP it really has (or if it has one at all) in recovery mode? Or, is there a way to check/set/force a recovery mode address when it is operating normally?

    Running Windows 7 64-bit; CTCP disabled; TFTP enabled. Using the latest version of ASUS Firmware Restoration Utility (Version 3.5.7.0) [This is the version ASUS lists for Vista 64-bit, which is the closest to my actual OS; Win7 is not available.] Also, have the executable set to run in Vista compatibility mode with administrator privileges. In addition, I have tried these steps on a Windows XP machine with an older version of ASUS Firmware Restoration utility with the same results.

    Have had the same results with each of these firmware versions installed on router:
    • ASUS version 2.0.0.6
    • ASUS version 3.0.0.9 (loaded via WebGUI)
    • Oleg's WL500W version 1.9.2.7-rtn-r4772 (loaded via WebGUI)
    Of course, performing these steps first:
    1. Disable wireless NIC on PC (only one local connection active, connected to router)
    2. Disconnect all Ethernet cables from router except one from PC
    3. Manually set PC IP address to 192.168.1.10
    4. Set Subnet mask to 255.255.255.0
    5. Set Default gateway to 192.168.1.1 (also tried blank)
    6. Set DNS to 192.168.1.1 (also tried blank)
    7. Disable Windows firewall (for both private and public networks)
    8. Disable antivirus (MS Secuirty Essentials - stop real-time protection)
    9. Perform 30/30/30 reset and/or web gui restore factory default
    With router in recovery mode, No matter what firmware I try to push, I get the following:

    ASUS Firmware Restoration Utility
    "No wireless device in recovery mode is found"

    TFTP
    "Unable to get responses from the server"

    PING
    "Destination host unreachable"

    And of course, in normal mode, from the regular web interface, using IE, I get the expected "Firmware upgrade fail. It may result from incorrect image or error transmission. Please check the version of firmware and try again."

    Apologies for the length of the post. Any help you can offer would be greatly appreciated!
     
  2. mvsgeek

    mvsgeek Addicted to LI Member

    [quote="
    ASUS Firmware Restoration Utility
    "No wireless device in recovery mode is found"[/quote]

    My guess is that you're really not in recovery mode. See paragraph 4 of this link:
    http://tomatousb.org/tut:installing-on-asus-rt-n16

    I've run into this issue on both RT-N16 and RT-N12 routers (sorry, no experience with the WL500W) - the procedure described in the link eventually worked for both, but sometimes it took me a couple of attempts to get into recovery mode. FYI the restoration utility on the RT-N12 CD is the same as the one I downloaded for the RT-N16, so it may be a universal Asus utility.
     
  3. Drakeg1

    Drakeg1 Serious Server Member

    Thanks, mvsgeek! I have been plugging in the power cord while holding the reset button, but maybe there is a sensitive timing issue? Every time I entered recovery mode (or thought I did) the power light blinked slowly (once every 1-2 seconds). Isn't that the indication the router is in Recovery Mode?

    I appreciate your response and assistance!
     
  4. mvsgeek

    mvsgeek Addicted to LI Member

    Yes, the slow-blinking power light is supposed to indicate that the router is in recovery mode. I remember reading somewhere that it will not respond to ping in recovery mode. However, the restoration utility should work. Did you try the version mentioned in the tutorial? It may work with your WL500W. It can be downloaded here:
    http://www.4shared.com/file/GL0aSSZ8/ASUS-RT-N16-RECOVERY.html
     
  5. maurer

    maurer LI Guru Member

    serial console will definitely help in this case - i totally recommend it
     
  6. Drakeg1

    Drakeg1 Serious Server Member

    mvsgeek, I appreciate the tip and did indeed try the RT-N16 recovery software (thanks for the link!), but got the same results -- no device found in recovery mode. :-(

    Maurer, I am not familiar with the serial console approach you are recommending, can you point me toward some instructions?

    Thanks!
     
  7. maurer

    maurer LI Guru Member

  8. uQuirke

    uQuirke Reformed Router Member

    Hi, I struggled with this for hours, then remembered something I read years ago about not using Port 1 on some routers. Port 2 resolved it for me.
     
  9. Primoz

    Primoz Network Newbie Member

    Does anyone have a solution to this? I have a simmilar problem (i could ping it the first few times, now it's always unreacahble) and different ports don't help. I don't have the gear to do a JTAG port.
     

Share This Page