1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WLAN noob: can't connect to Router

Discussion in 'Tomato Firmware' started by haarp, Jun 2, 2009.

  1. haarp

    haarp LI Guru Member

    Greetings.

    I've been using Tomato for a while now with my WRT54GL. I never bothered much with the Wireless settings since my network is completely wired.

    Today, I got my hands on a Fritz WLAN USB Stick (apparently those are pretty popular here in Germany) and thought I'd give it a try for ****s and giggles.
    Set the stick up on my machine, set the router up and tried searching for APs from the stick.
    I found a few of them in the neighborhood, most of them with terrible reception. But no sign of my Tomato router. I do have all kinds of security options enabled in Tomato, but the router should at least be visible, shouldn't it?
    So I decided to do a Wireless survey on Tomato. Again, lots of APs popping up, so wireless can't be inherently broken.
    I tried placing the stick at other spots, hanging it high in the air, putting it directly on top of the router, tried all kinds of acrobatic stunts, but regardless of position, I just can't seem to find the Tomato router. The distance between the two does not exceed half a meter, so signal strength can't be the issue.

    Router settings: Wireless and Radio are enabled.
    SSID broadcast enabled.
    Wireless Mode: Access Point
    B/G Mode: Mixed B+G
    Security: WPA / WPA2 Personal + TKIP / AES
    Channel: 7 - 2.442 GHz (should be free according to Wireless survey)

    I also tried a static config (fixed SSID and other settings) on my machine to no avail. Same problem when running Linux and Windows.
    again, I've never used Wireless LAN before in my life, so if I'm missing something, please tell me.
    Any ideas what could be wrong here?
     
  2. Toastman

    Toastman Super Moderator Staff Member Member

    Is your router set up to broadcast it's SSID? You seem to have everything OK, otherwise, something should be detected!
     
  3. haarp

    haarp LI Guru Member

    :)

    (message is too short, extending)
     
  4. Low-WRT

    Low-WRT LI Guru Member

    Try it without any security at all. Then, if it works, you can add security.
     
  5. haarp

    haarp LI Guru Member

    Wow, now that's interesting. When I set security to WEP or disable it, my machine instantly picks up the router and shows it in its list! WPA, WPA2 and the combo of both does not appear.
    Strange thing is, WPA should be supported by my usb stick because I can see other WPA-APs in the list.
    Of course, this is no long-term solution, as even I know of the security issues with WEP...
    This is all very, very strange.
     
  6. Low-WRT

    Low-WRT LI Guru Member

    Have you tried just wpa -- not wpa/wpa2? I've not had much luck with wpa/wpa2. I'd try WPA PERSONAL + AES. That should be all the security you'll ever need.
     
  7. haarp

    haarp LI Guru Member

    Yes, I have. Tried a few combinations, none of which seem to work. Only when set to WEP or none can I see the router.
     
  8. bripab007

    bripab007 Network Guru Member

    Sounds to me like the Wi-Fi usb stick does not support WPA/WPA2 encryption. Can you confirm this? If the documentation says those are supported, do you have the latest drivers installed for this device?
     
  9. haarp

    haarp LI Guru Member

    Documentation also says WPA/WPA2 is supported. On top of that, I just upgraded the driver, to no avail.
     
  10. haarp

    haarp LI Guru Member

    Ran outta ideas aswell, I assume?
     
  11. Low-WRT

    Low-WRT LI Guru Member

    Maybe check to see if there are any driver updates for the usb stick?
     
  12. haarp

    haarp LI Guru Member

    already done.
     

Share This Page