1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.


Discussion in 'HyperWRT Firmware' started by ricciardi, Jan 5, 2006.

  1. ricciardi

    ricciardi Network Guru Member

    Hi there folks.

    I need some help here.

    I installed a modified version of wondershaper script as my startup script.

    I have two questions about it.

    (1) Do I have to have QoS ON or can I keep it OFF as it is right now? Will the script do it´s job even with QoS off?

    (2) How can I make sure the script is running?

    Thanks for any help

  2. ricciardi

    ricciardi Network Guru Member

    no one?
  3. Thibor

    Thibor Super Moderator Staff Member Member

    1. leave it off
    2. "tc -s class show dev vlan1", or "tc qdisc"
  4. ricciardi

    ricciardi Network Guru Member

    Thank you Thibor!

    That´s what I got.

    # tc -s class show dev vlan1



    # tc qdisc

    qdisc ingress ffff: dev vlan1


    So, I wonder if the script is running or not.

    What I did was I just loaded it as my startup script and rebooted the router> Do I have to do anything else?

    I really appreciate your help. Thank you.

  5. ricciardi

    ricciardi Network Guru Member

    I discovered what was wrong.

    The 80% and 90% upstream variables were not defined in my script and somehow the "on the fly" calculation was not working.

    I wonder why do we have to define these variables on the WRT54GS and not on a bigger Linux box.

    Thanks for your help.

    Now it´s working.


Share This Page