1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Won't Acquire IP Address

Discussion in 'Networking Issues' started by flynmonkey, Apr 19, 2008.

  1. flynmonkey

    flynmonkey Addicted to LI Member

    Router WRT54G
    Security WPA TKIP

    Background: All system are working fine except one
    I had this system connected to via WIFI with a Belkin pci 54g card.
    I took that card out and no longer have it.
    I bought a new Belkin pci 54g card and installed it (first removed the old driver)

    It will connect to router by does not acquire an IP Address.
    If hard wire it to the router the wireless card gets an address.
    It works even if I remove the Ethernet cable.
    Once I reboot it will not work and does not acquire and address.
    The limited connectivity message is displayed on the WIFI adapter.
    It does not work even if I give it a static address.



    Thanks for the help.
     
  2. flynmonkey

    flynmonkey Addicted to LI Member

    After pluging in the Ethernet cable I tried a static address on the WIFI Card and that works.
    But it will still not acquire and address using DHCP.
     
  3. flynmonkey

    flynmonkey Addicted to LI Member

    My 2 year old just turnoff my pc for me and I reboot I found that the static IP I set on the Wireless adapter does not work until I plug in the Ethernet cable.

    I did run a diagnostic (Netsh Diag GUI then scan). and the card is getting the wrong DHCP Server
    It is receiving 255.255.255.255
    my laptop that works fine is receiving 192.168.1.1

    Any Idea how to fix this?
     
  4. davexnet

    davexnet LI Guru Member

    I would start off by setting all TCP settings in Network Properties
    back to default on the problem computer.
     
  5. flynmonkey

    flynmonkey Addicted to LI Member

    Got it

    thanks for suggestion davexnet.

    I figured it out over the weekend. This is how I got it to work
    • I disabled all encryption on the router. (I hate doing this and avoided it normally)
    • Then I disabled the built in wired NIC on the machine in question.
    • Then I connected to the network and it worked (so I knew it was the encryption that was causing the acquire to fail)
    • Then I re set the encryption backup with the same key so I would not have to change all of my other computers and devices.
    • This seems to have got it al though it does take longer to connect then my other systems but once connected it works fine.

    Thanks for the post.
     

Share This Page