1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Wow, what a day....more bricks.

Discussion in 'Tomato Firmware' started by ladysman, Dec 20, 2009.

  1. ladysman

    ladysman LI Guru Member

    At least I think. Some here have seen my first brick today...if not, here you go.
    http://www.linksysinfo.org/forums/showpost.php?p=356324&postcount=134

    After that happened, I finally put one of my TM routers I got in production. CLocked it to 225 and it was working for a few hours wonderfully. I leave to help a friend with her kids ipod setup (lol, i know.) and I come back and the new TM router I just setup is blinking. Damnit! WTF happened?

    My wife says the power flickered but it never went off. All of my computer equipment is on a big APC surge protector/UPS backup unit.

    Here is where it gets weird. When I got my 2 TM routers, they each had a different power supply. One that looks like the ones that come with the GL's (small) and one like what I currently have for the GS's.

    When I plug the GL one in, I get all solid lights. When I plug the old one that looks like what came with the GS's, I only get 2 solids lights. When I plug another old power supply I have, there are 3 lights lit up.

    WTF is going on here? Man am I have a bad day with routers!!!!!!!!!!!!!!!!

    Any ideas? Is this one bricked too??:mad:
     
  2. TexasFlood

    TexasFlood Network Guru Member

    Oh man. You are having a bad day.

    Based on what I've read and my own experience, doesn't seem like the overclocking could have done it. My two (mine until Christmas when I give one away) TM power supplies look the same, a black brick like this pic posted over on the DD-WRT Broadcom forum. I have heard of some getting a lightweight gray one that can handle input voltage 100-240V shown in this pic from the first slickdeals cowboom thread which I would have liked to get but unfortunately did not. I'm not aware of any other type shipped, at least in the cowboom deal, but who knows.

    If you got something out of spec, you might have a case for an RMA to get a "new" one. Both of those pics are good enough to read the specs, output specs on both are +12V 1A positive center for comparison to yours.

    After checking & confirming the power supply, have you tried a hard reset? From what I've read, given the CFE (GL 1.1) on the TM after running the update, a hard reset on it should clear the nvram and reset the clock speed so might remedy the situation if it is causing a problem. Seems unlikely (to me) to be the issue, but also if it were me I wouldn't take anything for granted and probably worth a try if you haven't.
     
  3. ladysman

    ladysman LI Guru Member

    doing the hard resetnow sorry one hand typing:biggrin:

    edit didn't work

    I got one of each from cowboom as far as the power supply.
     
  4. TexasFlood

    TexasFlood Network Guru Member

    Bummer, my notes indicate that cowboom offered a 30 day warranty on these, you might still have time to RMA it. I can't say what caused the failure but from what I've heard I would tend not to blame the firmware or clock setting. in that case I think I could honestly request an RMA with a clear conscience. Of course if you tell them that you did either, they won't issue an RMA as technically by cowboom Ts&Cs changing the firmware isn't allowed. But apparently they have RMAed 1/2 bricked routers as at least one guy posted that he received a router that seemed it was 1/2 way through the CFE update and never had a firmware loaded on it. He was able to pick up and finish the process successfully. Just FYI you wouldn't be the first. And as I said, if it seems like a hardware failure as it sounds to me, I think you'd have a valid case but think about it and decide for yourself.
     
  5. Toastman

    Toastman Super Moderator Staff Member Member

    Just FYI the scenario you have described sounds like the interruption of supply is responsible. You can easily create problems in GL's by cutting power momentarily, then again just as the router begins to start up again. This happens frequently here due to the primitive electric suppies. A UPS usually prevents it, but some UPS's do not switch quickly enough. It usually doesn't brick the router, just corrupts NVRAM, sometimes resetting to factory defaults, but sometimes just doesn't come up again.
     
  6. bripab007

    bripab007 Network Guru Member

    Yup. I've experienced this on my current -TM, my old WRT54G v.2.0 and my parents' old v.5.0. And two out of the three times, the routers were connected to UPS battery backups.
     
  7. ladysman

    ladysman LI Guru Member

  8. ladysman

    ladysman LI Guru Member

    Were you able to bring the TM back? If so how.
     
  9. ladysman

    ladysman LI Guru Member

  10. Toastman

    Toastman Super Moderator Staff Member Member

    PLEASE DO NOT TRY THIS PIN SHORTING METHOD.

    Most people who have tried this have damaged their router beyond economical repair. Stick to JTAG. But first, look at the other thread where I am failing miserably at recovering my GL with JTAG. :wall:

    http://www.linksysinfo.org/forums/showpost.php?p=356372&postcount=36

    The site you link to seems OK for the cable and pin header though.
     
  11. ladysman

    ladysman LI Guru Member

    I may just try it. Simply because the GL's are $50 shipped now so $10 on a cable can go towards it. Although not sure what to do with my TM.:confused:
     
  12. TexasFlood

    TexasFlood Network Guru Member

    Cable yes, pin shorting no.

    The cable is a great tool that you can use in the future. The ebay one looks like it ships with one 12 Pin Header. Most router boards have the pads but not a header so this needs to be soldered to the board to connect to the cable, as illustrated on that ebay page. If you're going to use it on more routers, you'd need additional headers (12 pin like the ebay one for most routers) to solder to any other routers. I've seen some discussion of "solderless" headers, which create some sort of temporary pressure contact, spring loaded or otherwise. There is some discussion of these and wrt54g-tm jtag here. Not sure I'd trust something like that but maybe a good option if you're not comfortable with soldering and the holes on your board aren't already filled with solder.

    Pin shorting is dangerous and relies on faking the router into thinking the image in flash memory is corrupt by failing a checksum and force it into recovery mode. So you're betting that you can short it enough to fake the corruption but not enough to cause permanent damage. I'd rather not take that bet if there are other options.
     
  13. bripab007

    bripab007 Network Guru Member

    Yes, in all three cases it just appeared to reset the NVRAM and cause the routers to lose all their settings. I think in at least one case, I was able to restore from backup config.

    Come to think of it, I think one of those times the router wouldn't actually come back up until I did a hard reset.
     
  14. ladysman

    ladysman LI Guru Member

    How did you reset the NVRAM without getting into the gui?


    I bought an Asus RT-N16 yesterday as another "toy" to play with.

    My in-laws recently got AT&T uverse and they use the router/modem, whatever that huge honking thing is so they are giving their 54G V3. Thus I will have another spare. I know why the GS died but i'm still puzzled as to why the TM died

    Still haven't ordered a JTAG and might even not do it. Unless you all have another idea to bring it back without JTAG. :wink:

    Have a wonderful New Year everyone! :smile:
     
  15. TexasFlood

    TexasFlood Network Guru Member

    Think you could reset the NVRAM without the GUI a couple of ways. One via a serial console but that's probably as hard if not harder than the jtag router so I'll skip that. The other is from telnet or ssh do "mtd-erase -d nvram" I believe is the syntax. Weird about the WRT54G-TM, I'm puzzled by what happened there as it sounds like you are. Send it to me if you aren't going to try jtag, :-D . I just bought a jtag device based on Tornados recommendation in the dd-wrt broadcom forum, might want to take a look.
     
  16. ladysman

    ladysman LI Guru Member

    I will try what you suggest hopefully tonight. If I remember right, i couldn't even telnet into it. I will try again.

    I did receive my RT-N16 this week but I haven't even opened it yet. :frown:

    Thanks for the link Texas, notice the "ladysman" has already posted there and purchased. I received a shipping notification yesterday. :wink:
     
  17. TexasFlood

    TexasFlood Network Guru Member

    Clearly I didn't read all the messages in that thread, :grin: I don't know why I bought it, but I did. Tornado recommended it, guess that pushed me over the edge, seemingly doesn't take much, :wink: , I got an RT-N16 as well. I got it a few weeks ago, loaded DD-WRT on it, then a version of the Asus firmware with telnet added, then back to stock which is how it sits right now. Ran out of time to play with it any more for a while, :sad:
     
  18. ladysman

    ladysman LI Guru Member

    Why did you go back to stock firmware?
     
  19. TexasFlood

    TexasFlood Network Guru Member

    Basically I wanted to load the telnet version and look at the power setting commands and I wanted to see how hard it was to flash back. Not really using it now or it probably wouldn't be stock any more, :biggrin:
     
  20. ladysman

    ladysman LI Guru Member

    OK, which ddwrt are you using on it? latest? or another build?

    We are basically snowed in tonight, the big game is on, so I may actually flash it tonight while watching. :biggrin:

    I will take a look at the tm as well
     
  21. TexasFlood

    TexasFlood Network Guru Member

    I honestly don't recall but the folder on my laptop says "eko_V24-K26_svn13450_Asus_RT-N16" so that must be it, and think I loaded the "big" build, this would have been around Dec 15 2009. Might be a better one out by now but I've lost track.
     
  22. ladysman

    ladysman LI Guru Member

    i'm back in business again with the broken TM. I have no idea what is going on. Luck? probably.

    All I did was power on the router and I noticed I could telnet into it. Weird. Went to the browser and got right in it.

    It's back again which is nice. :)
     
  23. TexasFlood

    TexasFlood Network Guru Member

    Gremlins...
     
  24. ladysman

    ladysman LI Guru Member

  25. TexasFlood

    TexasFlood Network Guru Member

  26. ladysman

    ladysman LI Guru Member

    well it seems i was mistaken. the gremlins are back.:wink:

    I put both TM's in production today and the one I was had trouble with ever since the power went out, is dead again.

    Last night I decided to reflash it with Victek since I don't need the usb or VPN (right now).

    It went fine. I then spent 30 minutes setting it up getting ready for today.

    All went well.

    I power down modem, switches, etc to do the swap. THen I power cycled everything on and all seemed fine...until I went to get into the router 2 minutes later and it just said, waiting for reply.

    WTF is going on with this thing!!!!!!!!!!!!!!!

    Any thoughts on what I should do next??:mad:

    I should note, i'm not that mad because my RT-N16 is here but I wanted to wait a while to start using that.
     
  27. TexasFlood

    TexasFlood Network Guru Member

    Have you ever had the "bad" one in service for any length of time? Maybe it's got a hardware defect that causes it to fail after a short time. Could try some tests, like swapping the power supply to start to rule that out. Then try unplugging it for progressively longer periods of time until it works again when powered back up again, then see how long it works. Dunno, I've never experienced such symptoms so just kinda guessing at what to do.
     
  28. Toastman

    Toastman Super Moderator Staff Member Member

    Try swapping the power supplies - (clutches at passing straw)....
     
  29. ladysman

    ladysman LI Guru Member

    I did, it wouldn't do anything.

    I will mess with it more later. If i can telnet in it for the first 60 seconds, what commands would you do?

    :biggrin:
     
  30. TexasFlood

    TexasFlood Network Guru Member

    I'm not sure it would help, but if it were me I'd try the below. I think this is safe, on a WRT54G-TM anyway, if not every router. Any comments anyone?
    Code:
    mtd-erase -d nvram
    reboot
     
  31. Toastman

    Toastman Super Moderator Staff Member Member

    Do you own a flame-thrower?

    Where I live we get a lot of very fast power glitches which cause problems with GL's. The reservoir capacitor in the usual power supplies is not large enough to keep the router working, although almost everything else in the apartment block doesn't even notice it. A second glitch during a reboot from the first causes NVRAM corruption. Placing a 4,700 MFD capacitor across the router supply mostly stops this happening. A UPS doesn't always react fast enough.

    After that, I'm out of ideas. Good luck!
     
  32. ladysman

    ladysman LI Guru Member

    I just telneted (is that a word) :wink: into it. I didn't have enough time to erase nvram.

    I powered it off, had telnet open, ready this time and the MTD erase worked. Seems like its OK again but at this point, I don't trust it.

    i'm wondering if flashing to Victek from Teddy bear has anything to do with it? doub it but i'm have No idea at this point. Not sure what i'm going to do with it. Would love to use it because it would have the ND driver on it.

    Edit:

    Put my kids to bed and came down to a blinking power light and all LED's lit up. Oh well.
     
  33. TVTV

    TVTV LI Guru Member

    Why not try and reflash it as soon as you get it working again? Maybe the flash didn't "stick". :)
     
  34. ladysman

    ladysman LI Guru Member

    That's what I was trying to do then it died.
     
  35. TVTV

    TVTV LI Guru Member

    I see. Well, back to the drawing board...
     
  36. ladysman

    ladysman LI Guru Member

    got it working again, the tried to flash it and it died in the middle of the flash. Took it apart and noticed that the JTAG on the board doesn't even have any solder in it.

    Makes it real easy. So the iron is warming up now. Any special JTAG instructions for the TM?

    Texas, I received my jtag kit from the DDWRT link and it's a very well built product if you haven't received yours yet.

    I've never JTAGged (is that a word?) so any special help would be nice.

    I've been looking at these
    http://www.tiaowiki.com/w/Universal_JTAG_User_Manual_(Parallel)

    http://www.tiaowiki.com/w/Debrick_Routers_Using_JTAG_Cable

    Do I want buffered or unbuffered?/?
     
  37. TexasFlood

    TexasFlood Network Guru Member

    Thanks for the feedback on yours. Looks like the instructions for buffered are wrong at the moment and most folks use unbuffered anyway, so at least for now I'd go unbuffered.

    Those links you have look like what you should be reading. You might search around the dd-wrt site as well, such as reviewing the thread about the Universal JTAG Adapter and perhaps reviewing threads such as this "WRT54G-TM JTAG debrick" thread, for the pictures if nothing else.
     
  38. ladysman

    ladysman LI Guru Member

    Header is on. I will try unbuffered. Do I need to change a setting in my windwos laptop for that (XP). Sorry total newbie when it comes to parallel ports, buffered, unbuffered. :redface:
     
  39. TexasFlood

    TexasFlood Network Guru Member

    Well, looking at "Debrick Routers Using JTAG Cable, software section", it says to "Download [TJTAG] program and unzip it to a temp directory on your harddrive, then copy the giveio.sys and loaddrv.exe to C:\windows\system32\drivers for XP." Good luck buddy.
     
  40. TexasFlood

    TexasFlood Network Guru Member

    FYI, DHC_DarkShadow -just- posted a link to an updated "Universal JTAG For TJTAG" wiki edited/written by him with info from Tornado at the end of the Universal JTAG Adapter thread. He notes that it HAS NOT been approved by Tornado yet, so there is some risk and if you spot any mistakes or typo's to PM him or Tornado to let them know. Presumably this addresses the earlier mistakes regarding the unbuffered configuration, but could also have other updated info, not sure. I'd still go with unbuffered for now though since that is a pretty tried & true method that folks are familiar with. Buffered support and documentation seem to still be a work in progress as of now.
     
  41. ladysman

    ladysman LI Guru Member

  42. TexasFlood

    TexasFlood Network Guru Member

    Per DD-WRT broadcom forum thread "Bricked WRT54GS help with tjtag":

    "If it gets stuck on clearing watchdog, you tell it /nocwd (no clear watch dog).."

    Google is your friend, :biggrin:, and I trust it more than my memory.
     
  43. ladysman

    ladysman LI Guru Member

    Sorry, appreciate you doing work for me. :biggrin:

    I've tried a few times and it's gets stuck on probing flash and that's it. I'm going to bed in the next 15 minutes and need a break so i'm going to watch "Chuck".

    I'll probably check this later but won't look into it until tomorrow unless you know something off hand. This is the GS router (I'll do the TM later).
     
  44. mstombs

    mstombs Network Guru Member

    Does it identify the CPU correctly? One tip re JTAG, turn off the router, prepare the command on the PC, power on the router then hit return immediately. Some routers only seem to work in the first fraction of a second after power-on.
     
  45. ladysman

    ladysman LI Guru Member

    Thanks, i noticed that late last night that it mentions that in the program.

    I will try tonight.

    I wanted to update on the TM. Something else is wrong with it. I erased the NVRAM and it came back to life....but 2 minutes later, power light blinking and all lan light on solid.

    Any suggestions on the TM? I'm about to give up on these. I will try that tonight mstombs.
     
  46. Toastman

    Toastman Super Moderator Staff Member Member

    My god that's a complcated bit of kit for something that just needs a few wires :biggrin:

    If you have any trouble with the cable / firmware you are trying, look in this directory: E:\FIRMWARE\Flash and Debrick - JTAG\WRT54GL v1.1 Debricking - see if you can recognize the processor and probe the flash chip.

    If you follow the instructions, and your unbuffered cable is working, it should be very easy to use. If you have trouble probing the NVRAM chip, and you are sure the cable is OK, you won't find much help on the forums but one cause of it is incompatible parallel port on your PC. On the PC's I originally tried, pin 2 was not being toggled.
     
  47. ladysman

    ladysman LI Guru Member

    Thanks toastman. Waiting for you to chime in. :wink:


    I could connect to both routers. it found the chips just fine. On the TM i went ahead and erased NVRAM. That went fine. Then 2 minutes later, blinking power light and all 4 lan lights on.

    On the GS, it will find the chip but gets stuck on probing. I still need to look into that.

    I did both on teh same parallel port and the TM was fine so i'm not sure that's the problem??
     
  48. TexasFlood

    TexasFlood Network Guru Member

    FYI, here's the procedure that DHC_DarkShadow posted towards the end of the "Bricked WRT54GS help with tjtag" thread.

    1. Powered up my laptop

    *Make sure ip of laptop is 192.168.1.10 255.255.255.0

    2. My network cable is connected to port 2 of the router, and hooked up my jtag cables.
    3. Turned on the router
    4. Started giveio.sys
    5. tjtagv2 -probeonly /noemw (I get a successful message)
    6. tjtagv2 -erase:nvram /noemw
    7. tjtagv2 -erase:kernel /noemw
    8. tjtagv2 -erase:wholeflash

    *Power cycle router

    9. tjtagv2 -flash:cfe
    10. Unplug router
    11. Disconnect jtag cables on pc end

    *Plug in router

    12. Open up command prompt and ran a continuous ping (ping 192.168.1.1 -t -w 10)
    13. Plugged in the router
    14. Watched for a successful ping
     
  49. Toastman

    Toastman Super Moderator Staff Member Member

    Blinking power light and all LAN LED's on is a sign that cfe is corrupted. I think I'd try to reflash a new cfe. There was some stuff on here about cfe for TM.
     

Share This Page