1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WPA connection issues

Discussion in 'General Discussion' started by saturndude, Jan 12, 2009.

  1. saturndude

    saturndude LI Guru Member

    Hello all,

    I would like to get the WRT-54GL to work with WPA. I got a D-Link DI-524 to work with WPA-PSK, but I would like to get the Linksys to use it, with your help (NOT both routers at the same time of course).

    After many failed attempts, I used a WIRED connection to a D-link router to change its ESSID and set up WPA. Then typed the WPA key in to the Windows wireless setup wizard (XP Pro 64) and it worked right away (applet that came on CD is 32-bit only, so I must manage card with XP). Rebooted to Mandriva 64-bit, used their wireless GUI applet to type in the information and it "just worked" there too.

    (I am using a D-Link PCI card with an Atheros 5212/5213 chip. Drivers with hacked .INF files for 64-bit Windows flavors are at www.atheros.cz. Under Mandriva 64, I'm using the Atheros in-kernel driver. Some report issues and bugs with the in-kernel driver for Atheros chips when using WPA, but I don't have these problems.)

    When I set up the Linksys router through a wired connection, then set up the OSes, the PC won't connect under either OS. I'd like your help to find what is going wrong (hopefully I don't have to read through too many RFCs about packets and such).

    I noticed something strange. Linux uses a WPA key that looks like FOUR-CH4R-TH3N-D4SH. Even when I check it right after booting, it is not the 63 characters that I typed in to both OS setup screens, it is not even 63 characters!

    Does the router use the last WPA key used as a "seed" to generate future keys? If that is the case, Windows would not know about the last key linux used, and vice versa, so this can't be the problem.

    Does the Linksys (or the computer) translate a text key into a hex key at boot (so the keys don't match) in a way the D-link knows about and properly accounts for?

    BTW, the both routers work fine with no encryption under both OSes. Both routers are set for channel 6, they have the same SSID and both broadcast it. Nothing different that I can see. Just that one works with WPA and the other doesn't.

    Any thoughts or hints? Any troubleshooting procedures you'd like me to try? Help is greatly appreciated (though it could take a few days to try suggestions). Thanks!

Share This Page