1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WPC54GS works fine but Link Information shows N/A

Discussion in 'General Discussion' started by arachma1, Apr 24, 2005.

  1. arachma1

    arachma1 Network Guru Member

    I purchased a WPC54GS this morning. I am using it on my Dell notebook with Windows XP. No problem with the installation of the driver and utility. Everything worked fine until I removed all network services on the Wireless Network Connection properties except TCP/IP. Since then the Linksys Wireless Network Monitor utility behaves very stange. The Link Information always says "Cannot associate with Access Point" and everything else in the "More information" shows N/A with the Status of Disconnected, even though my connection to the internet (through my WRT54GS) is perfectly fine (I am using it now). I have tried to uninstall and re-install the software back and forth, and even deleting all registeries related to Linksys before re-installing it, but still does not help.

    Could anyone suggest me what to do to solve this strange problem?

    Thanks a lot in advance for your help.
     
  2. howardp6

    howardp6 Network Guru Member

    Why did you un-install all the network services except TCP-IP ub=n the first place? Do you have a restore point you can go back to before you originally installed the WPC54GS. If you do, I would suggest you restore the system to the restore point. Most people should not delete registry entries, sine it may render the machine unbootable. If you do not have a restore point I would syggest you add back in Network Monitor Driver and Client for Microsoft Networks. Check the System Event and Application Event logs for errors or warnings. The Linksys Wireless Network Monitor may be dependent on a service you deleted.
     
  3. arachma1

    arachma1 Network Guru Member

    Thanks a lot for your suggestion. But why should I use all other services if I just need TCP/IP?

    The following are network services on my wireless adapter which were enabled before:
    1. Client for Microsoft Networks
    2. File and Printer Sharing for Microsoft Networks
    3. Eacfilt Driver
    4. Odyssey Network Services
    5. Network Monitor Driver
    6. Internet Protocol (TCP/IP)

    Mainly, I usually only use the services that I really need to get the best network performance, so I disabled (not uninstall) all other services except TCP/IP.

    I don't use Microsoft Networks, so I don't need 1 and 2. I will not use VPN on my wireless adapter, so I don't need 3. It is enough for me to use MAC address filtering, so I don't need 4. I will just occasionally sniff my wireless adapter for troubleshooting, so I disabled 5. This maybe becomes my habit in setting up network services for wireless network adapters, especially for GPRS and UMTS where maximum throughput is very low, ~72 Kbps and ~384 Kbps respectively.

    As to the deletion of the registry, I really had to do that as the uninstall program from "Programs -> Wireless-G Notebook Adapter with SpeedBooster" did not do the job properly. It said the un-installation process was completed, but the driver and utility were still listed on "Currently installed programs" (Control Panel -> Add or Remove Programs). I found that out after I got complain from the installation program that the driver and utility has already been installed when I tried to re-install them.

    I have double checked the event viewer for errors and warning related to this, but I found nothing. Everything works properly. I have also tried to re-enable all services and then reboot my PC, but the network monitor utility still can not show the right status on the Link Information. The Site Survey does show the right information though.

    I don’t understand why the network monitor utility needs those services. They are network services. The network monitor utility should physically "talk" directly to the PCMCIA to obtain all information. What I think happened is Windows XP now gains all controls over the wireless adapter as maybe it has more privileges over those services, even I already disabled the Wireless Zero Configuration as suggested.

    Anyway, maybe I need to really clean up my PC and re-install the driver and utility again if I have time.
     

Share This Page