WPM54G w/ RT2500 driver & Linux problem

Discussion in 'Other Linksys Equipment' started by dtgorm, May 13, 2007.

  1. dtgorm

    dtgorm Network Guru Member

    Ok, im taking a shot in the dark here as all my resources are becomming exhausted.

    Kernel: 2.6.9-42.EL-smp-i686 & 2.6.8-42.EL
    Dist: Centos4 (default install - no updates applied yet)
    Hardware: HP Pavilion a1310y (P4 w/ HT) : Linksys WMP54G (Ralink 2560) v4

    Driver Version: rt2500-cvs-2007051313 and rt2500-1.1.0-b4

    The problem i keep getting is with running make

    Code:
    # make
    make[1]: Entering directory `/usr/src/kernels/2.6.9-42.EL-smp-i686'
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/rtmp_main.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/mlme.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/connect.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/sync.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/assoc.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/auth.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/auth_rsp.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/rtmp_data.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/rtmp_init.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/sanity.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/rtmp_wep.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/wpa.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/md5.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/rtmp_tkip.o
      CC [M]  /tmp/rt2500-cvs-2007051313/Module/rtmp_info.o
    /tmp/rt2500-cvs-2007051313/Module/rtmp_info.c:603: error: unknown field `get_wireless_stats' specified in initializer
    /tmp/rt2500-cvs-2007051313/Module/rtmp_info.c:603: warning: initialization from incompatible pointer type
    make[2]: *** [/tmp/rt2500-cvs-2007051313/Module/rtmp_info.o] Error 1
    make[1]: *** [_module_/tmp/rt2500-cvs-2007051313/Module] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.9-42.EL-smp-i686'
    rt2500.ko failed to build!
    make: *** [module] Error 1 
    
     
  2. vibe666

    vibe666 Network Guru Member

    i can't help directly solve your problem, but I have 2 WMP54G's running under Ubuntu 7.04 atm and they work fine with ndiswrapper and the windows drivers. no speed issues or anything. why don't you just do that?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice